Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Spindle finishing past desired depth of cut

21 REPLIES 21
Reply
Message 1 of 22
Hadwood_CNC
501 Views, 21 Replies

Spindle finishing past desired depth of cut

Hi,

 

Please see attached model. I'm cutting through a sheet of plywood with a depth of ".75 (3/4" thick). The gcode that fusion is outputting is cutting past the desired depth -".75 cutting through the tabs I've created and into my spoil board. Please advise what I need to adjust to stop this from happening. Please reference the setup titled " Mold 3 inner\", it represents my most current settings used in my last job.

 

Thanks!

21 REPLIES 21
Message 2 of 22
matty.fuller
in reply to: Hadwood_CNC

There's nothing inherently wrong with the path in Fusion.

I suspect the WCS origin you've set at the machine doesn't match the way you have it set up in Fusion. You have it on top in Fusion and you say it's cutting exactly the stock thickness into the spoilboard, which would imply you have the origin set at the bottom on the machine.
Message 3 of 22
Hadwood_CNC
in reply to: matty.fuller

My WCS origin is set to the top of my stock/work piece so I don't believe
that is the issue.
Message 4 of 22
matty.fuller
in reply to: Hadwood_CNC

So, have you opened the NC file to see what Z co-ordinates are in it?

It's pretty cut and dried, there is nothing wrong with the toolpath in Fusion and you claim the machine is cutting double your stock depth. It's either the post processor doing something weird, the WCS offset at the machine being wrong, the tool offset being wrong, or the tool pulled out of the holder by miraculously exactly the stock depth.
Message 5 of 22
Hadwood_CNC
in reply to: matty.fuller

The tool is not cutting the exact depth of the stock at my spoilboard. It
cuts through my workpiece/stock and I turn off the milling operation at
that point.

The Z axis work offset is set correctly. Can you please take a look at my
fusion file and see if there's any settings that need to be adjusted?


Message 6 of 22
matty.fuller
in reply to: Hadwood_CNC

Perhaps I misunderstood what you meant by "cutting past the desired depth -".75"" then, can you post photos of the actual outcome on the machine?

 

I looked at your file first off and I don't see any issue with it, so I'm curious to know what's happening in the real world. If it's not cutting deep into your spoilboard because you stop it, do you just mean it's ignoring the tabs? I think I have read about a bug involving tabs on circular geometry, perhaps @seth.madore can confirm? (or you can search the forum)

 

The minimum Z in Fusion toolpath data is -0.6875" as below, and you can see the pattern of Plunge moves/ Finish cutting moves that indicate it lifting over the tabs. You should check your postd NC file to see if it matches, so you know if the problem is Fusion/post side or machine side.

 

mattyfuller_0-1701424511008.png

 

Message 7 of 22
Hadwood_CNC
in reply to: matty.fuller

 @seth.madore Can you please help with this issue, as it's persisting. Another issue I encountered is fusion is outputting the Gcode below at the end of my job and it's causing my spindle to plunge unexpectedly through my workpiece and into my spoilboard.

 

G28 G91 Z0.
G90
G28 G91 X0. Y0.
G90
M30

Message 8 of 22
seth.madore
in reply to: Hadwood_CNC

@Hadwood_CNC please share your g-code file here. It needs to have a .nc, .txt or .tap extension. If it does not have one of those file extensions, you'll need to rename it to suit.

What post processor are you using, and what is your actual machine?

In regards to your other issue (end of job code that sends the tool into the spoilboard), it sounds like you don't have limit switches on your machine. Is this a new issue (diving) or have you just been tolerating it?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 9 of 22

Its because you aren't turning on the machine with Z at the top of its movement range, g28 is return to home. Restart the machine beforehand with Z raised up, or remove it from your post. 

Please click "Accept Solution" if what I wrote solved your issue!
Message 10 of 22
Hadwood_CNC
in reply to: seth.madore

My most recent gcode file is attached.

In terms of the post processor, I'm not sure how to determine what I'm using. See attached screenshot, let me know if I should be looking elsewhere.

My machine is a DIY build.

 

I do have limit switches for all my axis. I use them for homing my machine and they work as expected.

 

This issue is not new, but I've just been removing the code shown below from my gcode file so it doesn't happen.

 

G28 G91 Z0.
G90
G28 G91 X0. Y0.
G90
M30

 

On another note, I just snapped a bit during the milling process using the attached gcode. Is there something in the fusion settings I should enable to prevent this from happening? I think my feeds and speeds are good as everything was looking and sounding good before it snapped. I believe it snapped when my machine plunged down to start a new pass. At this point I was nearly all the way through the milling process of my stock which is 3/4" birch plywood.

Message 11 of 22
Hadwood_CNC
in reply to: Hadwood_CNC

Here's the post processor screenshot I mentioned.

Message 12 of 22

It shows at the very top of your Code that the Zmin for the tool is -.875. You have a bottom height or negative stock to leave set somewhere that's causing this issue. Is your setup stock also setup as 0.75 and in the same position as your model? I dont have time to go through your actual files right now for you to check. 

This all sounds just like programming error, not post/fusion/switches/tooling

Please click "Accept Solution" if what I wrote solved your issue!
Message 13 of 22
Hadwood_CNC
in reply to: Hadwood_CNC

@seth.madore 

Just following up as I'm still experiencing the issue of the job not ending at the correct point:

My most recent gcode file is attached.

In terms of the post processor, I'm not sure how to determine what I'm using. See attached screenshot, let me know if I should be looking elsewhere.

My machine is a DIY build.

 

I do have limit switches for all my axis. I use them for homing my machine and they work as expected.

 

This issue is not new, but I've just been removing the code shown below from my gcode file so it doesn't happen.

 

G28 G91 Z0.
G90
G28 G91 X0. Y0.
G90
M30

Message 14 of 22
Hadwood_CNC
in reply to: seth.madore

Attached is my most recent job. Same results. The machine keeps going past the work piece and into the spoil board when it should end after it mills through the stock which is .75" thick. Please advise what to change.

Message 15 of 22
matty.fuller
in reply to: Hadwood_CNC

Can you share the posted NC file for this job too?

If you're getting the tool diving into the spoilboard when it hits the line G28 G91 Z0, this would imply that your machine's Z0 is at the bottom of the travel rather than the top.
Message 16 of 22
jscott6SWZG
in reply to: Hadwood_CNC

Have you tried an air cut.    Set z0 as high as possible (check clearance height).    Then run the program .   The point is to see how far the bit will plunge at the end of the program.   Rather than stopping the program yourself or removing the problematic code

Also check your sender program. Is there more than one wcs entered

do you have limit switches on both ends of the travel?

 

Message 17 of 22
Hadwood_CNC
in reply to: matty.fuller

NC Code is attached. Please confirm receipt. The main issue I'm concerned about is the job not stopping when I expect it to. In this case once the spindle has cut through the plywood which is .75" the job should end, but it continues and starts making passes in my spoilboard.

Message 18 of 22
matty.fuller
in reply to: Hadwood_CNC

Your code backplots perfectly in NC viewer, and the minimum Z in the file is -0.75 which is where the job ends. There is absolutely nothing wrong with this code.

 

mattyfuller_0-1703033512048.png

 

You seem intent on ignoring about half of the questions and advice given. Have you confirmed whether it is plunging straight down on the G28 command on line 503? If so it means your machine's control has the Z home at the bottom and you either need to invert that or change your post processor to remove that line or issue a valid homing command.

 

If the machine keeps running laps around the part rather than a simple plunge, something strange is going on with your control and it's up to you as the machine builder to figure that out, not pester people to fix a Fusion file that has nothing wrong with it.

 

Message 19 of 22
Hadwood_CNC
in reply to: matty.fuller

Thanks for taking a look at this. I appreciate your time and energy in
troubleshooting this issue.

In terms of post processor for Mach4 is there a specific processor I should
use in Fusion?
Message 20 of 22

we just said the post itself if working fine, and the code produced is also fine. 

Please click "Accept Solution" if what I wrote solved your issue!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report