Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Slow working tool library.

16 REPLIES 16
Reply
Message 1 of 17
mikronstce
737 Views, 16 Replies

Slow working tool library.

Hi,

After last update i have problem when i want to change my tool. When i open library , i have to wait 30s or more for the tools are load. I turn off all funcions like the 3D tools preview and nothing change. Anyone have idea how to speed it up?

Labels (2)
16 REPLIES 16
Message 2 of 17

I turn off most of the librarys I don't use. I go to your start menu on computer and type:

%temp% select everything in the folder and delete what it will let you. Reboot computer and see if it speeds it up.

I have to do this for mastercam alot. But my fusion library that used to be slow is instantaneous now. 

Could be related and worth a shot.

Message 3 of 17

That sounds.....risky.

@mikronstce can you share a screenshot of what your libraries look like?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 4 of 17
mikronstce
in reply to: seth.madore

Yes, we have something about 300 tools in library, now i noticed that the problem is also in the modifiable option of the tool. Before update it works slowly but it's really annoing. Just add we use intel i7-12700h, 32gb RAM and 300mb internet speed.

 

Message 5 of 17
mikronstce
in reply to: mikronstce

Sorry for spam but, i make a short video how it's works...

Message 6 of 17
seth.madore
in reply to: mikronstce

If you right click on your libraries, you can "Turn Off" the loading of them. I would recommend doing this to the libraries that you don't user, such as Fusion supplied libraries or other ones that seldom see use


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 7 of 17

Well don't know about that been doing it for years. Windows will not delete what it needs. When file gets over a gig it starts to bog solidworks and mastercam down.

Message 8 of 17

I split up alot of my tools into smaller libraries such as ball flatt bullnose ect. I think that helps as well. I don't have to hit the filters near as often that way.

Message 9 of 17
rengfx
in reply to: mikronstce

I have noticed demonstrable slowness in the Tool LIbrary (without extra features on) since the major update, specifically when selecting a HOLDER

Message 10 of 17

Hi i clean %temp% file and nothing change but thanks for advice:)
Message 11 of 17
mikronstce
in reply to: seth.madore

I try this but still is slowly, maybe a lil bit help but only when tools are loading, but still i have to wait for reload image.
Message 12 of 17
stephen.irvine
in reply to: mikronstce

Hi @mikronstce so from the look of things your tools are loading fine it's just the preview image that's taking a while to load? Correct me if I'm wrong but that's what it looked like in your screen recording to me. You shouldn't need to wait for the preview image to finish loading to continue using the Tool Library, again let me know if this isn't the case for you.


To debug the preview issue specifically, firstly it would be good to know what feature flags you have enabled if any, and second if you could let us know your system specs that would also be useful.

Finally if you could enable extended tool library logging:
Preferences -> General -> Manufacture -> Tool Library -> Enable logging 

Then send us the fusion logs for a session in which you encounter the problem that would also be useful.

 

We know that some customers hardware can have specific compatibility issues with the tools which I suspect is what is happening here, but this information would allow us to look into the issue for you (as we cannot replicate this ourselves).

 

Thanks

Steve


Stephen Irvine
Principal SW Engineer
Message 13 of 17
mikronstce
in reply to: stephen.irvine

Hi Steve,

yes i have problem only with loading image, but can't continue my job when the image dosn't load. I tried to click choose tool but still have to wait.

I think something is wrong with drivers on PC, i check fusion on other laptop with the same hardware and there the image is loading so much faster.
I change here RAM memory for bigger one, but before update that was all fine. Can this affect the work of the program?
When i back to office i will send logs.

Message 14 of 17

I am having the same issue. I had the preview turned off and tried on and it makes no difference. I never used to have this issue till the last 2 updates I believe. Scrolling is even slow and clicks take time to register. I am submitting a ticket today to see if they can look into this. It does seem to be PC specific. 

Message 15 of 17
dlewis1000
in reply to: mikronstce

I've noticed the same thing. Autodesk for sure needs to fix this. It's slowed down my workflow in a way that programming parts is now just annoying on fusion. I know now to expect up to a minute for my tool libraries to load depending on internet speed. Whenever working on a specific tool everything is fine until I go to select a holder, then it just grinds to a halt. 

Message 16 of 17
a.laasW8M6T
in reply to: mikronstce

Yea IDK what exactly the deal is with the tool library, On my work PC it goes fine, on my home PC its almost unusable sometimes.

 

Some of our other PC sat work are a bit older and they also struggle immensely with the tool library.

 

I'm not sure why such a simple interface requires soo many resources from the PC, this has become really bad since the December update.

 

the annoying thing is its not repeatable, I  can have it load something really slowly or hang, then when you try again it works fine.

Message 17 of 17
marcus.toepke
in reply to: mikronstce

Hi!

Sometimes I also have serious problems with the tool library.

It is slow or the graphic visualization is broken.

If I have to work a lot with tools, i.e. change a lot in the library, it becomes slow more quickly.


In my opinion, the tool library is not very well programmed!

I have 1130 SK40 tools and 498 SK50 tools.

I'm sorry, but that shouldn't be a problem!
It's not as if this is complicated 3D data! They're just small data lists.

There is definitely something wrong in the programming!

It's a mystery to me why the tool library has to be constantly reloaded!
If I export my SK40 and SK50 tools I get...

marcustoepke_0-1711956975969.png

nearly 1.5MB thats a Joke!


Autodesk should redo this!

When I open the tool library it has to be open before I release the mouse button!

The constant reloading is unprofessional.

However, you can see this in many places in Fusion, things are constantly being recalculated or reloaded just because you want to look at something again.

I'm writing myself into a rage about this topic! 😉

 

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report