Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Scaling issue with my post-processor for Laguna router table

10 REPLIES 10
Reply
Message 1 of 11
joel.smith3S2VN
222 Views, 10 Replies

Scaling issue with my post-processor for Laguna router table

I have used Fusion for CAM on our 4x4 Laguna Swift Router Table. I usually machine aluminum for our local robotics team, but for some reason, I am having an issue with the part in Fusion360 is correct. When I load the program on my machine (using the manufacturer .cps file for machine post-processing), the part cuts out about 2.5 larger than expected. This seems to be a millimeters-to-inches conversion or scaling issue that I have failed to isolate.  I am trying to cut a 3x5 gusset plate; the boreholes are about 3/8th inch. They should be 3/16th. 

I have attached the .f3d file, and I am importing the post-processor. The setup template is for a 1/8th inch single flute end mill, but it is a .f3dhsm file and is not supported for attachments. 

Labels (6)
10 REPLIES 10
Message 2 of 11

If your controller is in MM, make sure they match on the post window.

programming2C78B_0-1708703996373.png

 

Please click "Accept Solution" if what I wrote solved your issue!
Message 3 of 11

I made sure both were correct on the model and the post-processor. It still gave the same error. The part file was exported from Onshape as a .STEP file, and then I imported it into Fusion to do the CAM.
Message 4 of 11

Its obvious, but is the STEP file the right size IN fusion?

Please click "Accept Solution" if what I wrote solved your issue!
Message 5 of 11

It is the correct size in Fusion and from the export from Onshape. I also checked the dimensions in SOLIDWORKS, and they are all correct. I also can't tell in the gcode where my error might be either. I am at an absolute loss here.
Message 6 of 11

Your model is in Metric, and about the right size. There is no setup in your file.

Make sure the posting units are also in MM as I said above IF your controller is running in MM mode. Switch to Inch if its in Inch.

A .196 hole that is being cut ON CENTER with a 1/8" endmill would end up being around 0.321. 

throw your Gcode into https://ncviewer.com/ and make sure it looks right.

 

Please click "Accept Solution" if what I wrote solved your issue!
Message 7 of 11

As you suggested, I used the NC viewer to check the code. Most of the time, I have to zoom out to see the whole toolpath, which feels like part of the issue. In a few configurations, it appears normal on NC Viewer, but when I use it on my machine, the part is too big or too small.

I found some information about Onshape natively exporting STEP files with meters as the default unit. I have uploaded and converted the step file to .F3D, I have changed the document properties in design to mm and inches, I have the post processor from the manufacturer, the router table runs in millimeters, and I checked all the setup. I am posting everything I have so far to try and get the issue resolved.

 

At this point, I think it has to do with going from Onshape to Fusion. 

Message 8 of 11
engineguy
in reply to: joel.smith3S2VN

@joel.smith3S2VN 

 

Had a quick look at your file, the dimensions of the Model look correct, the only thing I could find that was odd was the Machine selection, there were no values input for it so I removed it and using the Post Processor you supplied, generated the G Code again, looks correct now so give it a try, modified f3d file attached, you will only have to re-set the location for the G Code.

Message 9 of 11
joel.smith3S2VN
in reply to: engineguy

I was hoping this would resolve the issue, but it hasn't. I have attached pictures of what it looks like on my table. The holes there are 10.5mm and the center-to-center distance is 50mm. The holes are supposed to be about 5mm (0.196 in), and the center-to-center distance is supposed to be 12.7mm (0.5 in)

IMG_4412.jpg

IMG_4411.jpg

Onshape natively exports in MKS, but the size looks right in Fusion. When I use the post-processor, it either makes the large version or if I change the units, it makes a tiny version. In the picture above, you can see the differences between each size. I have two Laguna post processors I have tried, and I even tried the fusion library version, and still no luck. Competition is coming up soon, and we are not having any luck.

Note: I have also imported the file in as a dxf and extruded it to the stock thickness and the issue is still persisting. I have checked other forums, and I have contacted Laguna, but they still haven't gotten back to me. 

Message 10 of 11
engineguy
in reply to: joel.smith3S2VN

@joel.smith3S2VN 

 

As I posted earlier the G code being generated is correct, to test this I removed the fillets on the Model and checked the Y axis distance, in the G Code the distance was 3.5in which is the correct size of your Part in Fusion.

 

I suspect your CNC is incorrectly setup either mechanically or at the control, if the G Code is saying move 3.5in and the CNC is not obeying that command (Moving more/less) then you need to look at the CNC.

I`ll try and do a short video that may help later 🙂

Message 11 of 11
engineguy
in reply to: engineguy

@joel.smith3S2VN 

 

No idea what is going on, I can only show you what I have tested here, the only thing I can think of it could possibly be might be your lead in/out settings. Possibly your Tool offset is wrong, that would send the tool to the wrong position as well 🙂 🙂

As you can see from the video the G Code output is correct for the test so the CNC should only move 3.5in

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report