Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rest machining with adaptive cutting non-existent stock

13 REPLIES 13
Reply
Message 1 of 14
AtomicGumball
628 Views, 13 Replies

Rest machining with adaptive cutting non-existent stock

I've been having issues with rest machining when using "From solid" or "From preceding setup". Instead of recognizing areas that do not have stock, it machines the entire part as though from a solid block. In the past, I could quickly step down tool sizes or machine second ops without any noticeable air cutting. Now I have to switch to other toolpaths that require additional inputs to get the cuts I want, which is really slowing me down. I noticed this started happening after the "machine cusps" options were removed from adaptive clearing. In the following pictures, I am reworking the part from the red model to the blue one. I simply wanted a toolpath to half the boss pictured, but it is machining as though I have a raw piece of stock loaded despite selecting the body as my stock.

AtomicGumball_0-1709851011329.png

AtomicGumball_1-1709851089996.png

 

 

13 REPLIES 13
Message 2 of 14

I think this is very related to my latest post: 

rest-machining-parameters-not-working-in-adaptive-clearing 

 

I also just found that, in a 3+2 situation, the adaptive clearing toolpath started milling above the model, although I specified model top as the top height. Never have seen this before.

 

At this time this is my biggest frustration with the CAM side of fusion 360.

Message 3 of 14
seth.madore
in reply to: AtomicGumball

@AtomicGumball Would you be able to share your Fusion file here?
File > Export > Save to local folder, return to thread and attach the .f3d/.f3z file in your reply.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 4 of 14
AtomicGumball
in reply to: seth.madore

No, I cannot share more than I already have. I could potentially make a dummy file, this error occurs anytime I am machining from a stock solid.

Message 5 of 14
seth.madore
in reply to: AtomicGumball

If you could share a sample file that demonstrates this issue, that would be most helpful!


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 6 of 14

Here's an example file. The rest machining works fine for tool 106, but following up the same toolpath with a smaller cutter results in machining the same volume instead of just what remains. Increasing the stock to leave on the smaller cutter results in the same air cuts.

Message 7 of 14
seth.madore
in reply to: AtomicGumball

Couple of options to solve for this on this part:
1) Turn off "Machine Cavities"

2) Leave "Machine Cavities" turned on, but set "Bottom Height" to "Selection" (and select the face) and put your Axial Offset in that field.

In either case, the result is this:

2024-04-11_17h36_37.png

We have some ongoing work (the below image is the exact file you shared, just with toolpaths recalculated) that would give you a toolpath like this:

2024-04-11_17h38_14.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 8 of 14
AtomicGumball
in reply to: seth.madore

This used to work though. Why did it change?
None of your suggested workarounds worked either. Turning off machine cavities produced the same toolpath, as did moving the bottom height(I already was using selection) regardless of the machine cavities setting. I just updated to the latest version today and haven't seen any change in behavior. Even more bizarre, I can duplicate and generate the same toolpath without changing anything and get the same tool path. I used to get empty toolpath warnings if I did that because there was nothing it could cut.
Turning on minimum axial engagement doesn't change the path either. If I set minimum axial engagement to 1.6, the depth of the step, I get no toolpath as expected since it is greater than the machining area. Setting it lower gives me the same toolpath as a zero value in that field.

Message 9 of 14
seth.madore
in reply to: AtomicGumball

I'm not sure what's going on 🤔

In "Production" Fusion (which is the version you're running) I've turned off the Preview flags that would give me different results, in order to emulate the environment that you have. Turning off "Cavities" and making no other changes, gets me this:

2024-04-12_04h37_24.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 10 of 14

So, I decided to have a coworker regen the toolpath without making any changes. He got a different result than I do, similar to what you posted.
I have reinstalled Fusion and still get the same result. We are confirmed to be running the same version of Fusion. I've been digging through the settings and preview features looking for possible configuration differences but haven't found anything yet. Can you think of anything that might cause influence this?

Message 11 of 14

I've been experimenting further. I appear to only have problems with rest machining when using the adaptive clearing strategy. Others, like pocket clearing, flat, and steep and shallow, are seeing the remaining stock correctly when rest machining is used. Is there a cache, or settings file I can clear to try eliminate this?

Message 12 of 14

Tried logging into another computer, still get the same results. Reset my configuration to defaults, still nothing. But I had a coworker log in to my computer, and was able to regen the toolpath correctly. Something appears to be wrong with my Fusion account, that carries over to other computers. How do I correct this?

Message 13 of 14

I believe I found the issue. I had some defaults set from when rest machining was controlled by the "rest material adjustment" settings, the bug surfaced when those settings were replaced by "ignore stock less than". I deleted this line from my NGlobalOptions.xml file in the neutron platform folder, and now I get the expected behavior.

AtomicGumball_0-1716423023494.png

 

Message 14 of 14
seth.madore
in reply to: AtomicGumball

Awesome, thanks for circling back and letting us know! I know your issue was a subject of much discussion internally, so it's good to know the source of the issue..


Seth Madore
Customer Advocacy Manager - Manufacturing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators