Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems with Manual NC Code - Error on Machine (Datron)

4 REPLIES 4
Reply
Message 1 of 5
frank.kloetzer
332 Views, 4 Replies

Problems with Manual NC Code - Error on Machine (Datron)

Hello everyone, we are in the process of swtching to Fusion360. This program has been great so far, yet we still face a huge issue that basically stops us from using it for production at all currently.

 

We require to manually add NC Code to use different machine functions, like enabling specific vaccum sections, enabling our suction, displaying messages on the display, manually moving to specific areas.

 

I have edited the post processor to enable NC Passtrough with the following:

function onPassThrough(text) {
var commands = String(text).split("*");
for (text in commands) {
writeBlock(commands[text]);
}
}

 

This is how I add the NC Code in Fusion:

Anhang3.PNG

 

When I try to load the Code on the machine, it displays following error:

Anhang1.PNG

It basically has something against the bracket "(". It seems fusion places the Manual NC Code on a wrong position. Removing this bracket manually doesn't help either. I feel like this bracket is supposed to be BEFORE the manual NC Code, but I'm not sure about that.

 

This is what the code looks like:

Anhang2.PNG

 

I have tried contacting my cnc manufacturer directly, but they have been silent on the issue since over a week now.

 

Maybe I'm doing it wrong all along. I'm aware that I only have seen the basics of it. My company probably WILL give me a proper professional course / training for Fusion once we get the basics working. But before I can proof that it's worth using Fusion I have to show them that the basic functionality we need is there.

 

Any help to get Fusion working for us would be greatly appreciated. Thank you!

 

Best regards,

Frank.

4 REPLIES 4
Message 2 of 5

Is the * correct for your post? 


Win10 pro | 16 GB ram | 4 GB graphics Quadro K2200 | Intel(R) 8Xeon(R) CPU E5-1620 v3 @ 3.50GHz 3.50 GHz

Daniel Lyall
The Big Boss
Mach3 User
My Websight, Daniels Wheelchair Customisations.
Facebook | Twitter | LinkedIn

Message 3 of 5

I had to replace the "," comma, because comma is used in the code of my machine. I picked * because I didn't see it elsewhere. So I'm (hoping?) it's correct. 

Message 4 of 5

any update on this one? I'm having the same problem.

Thakns

 

Message 5 of 5

Unfortunately all I can say is that we payed 1200€ to an external company that fixed our post processor and implemented all features we needed. Since I can't look into the new post processor or share it (it is encrypted) I can't help you on this one sadly. 

 

The company we worked with is called HSMTEC. They've been great to work with. I don't know if they offer help in English, it's a German company. 

 

Good luck!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report