Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with GRBL post processor and G19 command

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
nectarietotan
134 Views, 5 Replies

Problem with GRBL post processor and G19 command

Hello!I recently aquired a Vevor CNC3018. I'm having some problems when executing the GCode,  I create my GCode in the Manufacture tab of Fusion360, but there is a problem, the board of the CNC gets stuck when executing G19 command, it doesn't follow any commands and the only way to fix it is to reset the board or to powercycle it. This occurs on some shapes for example on a simple rectangle G19 is used, but on a plane rib there is no G19 used and the CNC is working perfectly.That's strange because on simple shapes I encounter problems, not on complex ones, I'm exporting the NC code using the GRBL post processor.Is there any fix to this problem?

5 REPLIES 5
Message 2 of 6

Im not sure why you'd even have ZY plane movements in your code.

Does it output properly with this attached post? How is your model setup in the Manufacture Setup?

Please click "Accept Solution" if what I wrote solved your issue!
Message 3 of 6

Well I don't know why it needs G19 for a rectangle.... I did cut a plane rib and there were no problems that s strange...

Message 4 of 6
seth.madore
in reply to: nectarietotan

I'm guessing the G19 is being output when you have Vertical Lead-In/Out radii defined. If it's approaching purely in the ZX/Y direction, a G19 will be created and then you get an G3 I/J move. If it's approaching at any other direction (in ZX/Y) it will linearize the moves and no G19 is created.

As a test, could you disable the Vertical Lead radii on the last tab of your toolpath? (just set to zero)


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 5 of 6
nectarietotan
in reply to: seth.madore

Where would that be located? In the setup or in the 2D/3D operation?

Message 6 of 6
seth.madore
in reply to: nectarietotan

In the operations

2024-02-22_12h40_49.png


Seth Madore
Customer Advocacy Manager - Manufacturing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report