Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Post processor C+ working ok, C- seems to follow the rotation

Message 1 of 12
361 Views, 11 Replies

Post processor C+ working ok, C- seems to follow the rotation

Hi, I've been using the Doosan post processor 3+2, I'm using a rotary pocket tool path on a DVF 6500 fanuc control. Everything is working ok in the C+ motion, but as soon as it tries to go to C- the tool/spindle seems to follow the rotation instead of staying central to the part and letting the bed do the rotations instead. (I've attached the video below, as I'm not quite sure how to explain it lol) 


I've attached the post processor that I am using below also. 


Many thanks, 


Message 2 of 12
in reply to: ryanYANVW

It seems to be changing the workplane as it rotates in the C- axis. Please help asap 

Message 3 of 12
in reply to: ryanYANVW


It's very difficult to tell what is going on without seeing the part file and toolpaths.

Would you be able to upload your file here?


It could be post related, what I see happening is maybe a linking move with TCP on thats not being executed properly.

Message 4 of 12
in reply to: a.laasW8M6T

Hi, I've uploaded the tool path and files below. 


Thanks for your reply! 

Message 5 of 12
in reply to: ryanYANVW

What setting do you have here?

You will have 5 axis checked but do you have rotary scale checked?



Message 6 of 12
in reply to: a.laasW8M6T




Message 7 of 12
in reply to: a.laasW8M6T



Yes I have checked off the rotary scale, force IJK, G68.2 and 5th axis. 

I did modify my latest post to reflect this. 

Message 8 of 12

It seems like the machine does not have the shortest path enabled.

To verify when you call C axis to 359 in the mdi mode and the next line if you call Cto 1 deg if the C axis rotates just 2deg to reach the position then the machine is enabled with shortest path instead if it rewinds 358 back to reach the postion then the machine is not enabled with shortest path.


if it rotates back 358 deg then in the post you have to change the kinematics like this

  if (getProperty("fifthAxis")) {
    if (receivedMachineConfiguration) {
      error(localize("You can only select either a machine in the CAM setup or use the properties to define your kinematics."));
    var aAxis = createAxis({coordinate:0, table:true, axis:[1, 0, 0], range:[-120.0001, 0], preference:-1, tcp:useTCP});
    var cAxis = createAxis({coordinate:2, table:true, axis:[0, 0, 1], tcp:useTCP});
    machineConfiguration = new MachineConfiguration(aAxis, cAxis);

 and you have to disable the property while posting



This would make sure to output the C axis in linear way 

Boopathi Sivakumar
Senior Technology Consultant

Message 9 of 12

It seems to have shortest path enabled, I put 359deg in MDI and then put 1deg into MDI. It went to 1 deg. Everything seems ok. 


Do you think disabling the rotary scale will solve the issue? 

Message 10 of 12

It's working now, i changed the post and removed rotary scale with you info you provided. 

So we are getting somewhere now, but when the machine moves in G0 the table and head judder? 

When its machining in G01 its ok, do you know how to solve this issue? 

Message 11 of 12

Sorry for the delayed response may be when axis is moving in rapid it may not properly syncronized. you can try using the highFeed rate this will make sure always it outputs the rapid move with the G1 with the High feed rate value



Boopathi Sivakumar
Senior Technology Consultant

Message 12 of 12
in reply to: ryanYANVW

Yes, that's perfect thank you for your help!!


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report