Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NCStudio 4th axis post problem

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
roman_Sholiak
320 Views, 4 Replies

NCStudio 4th axis post problem

Hi All , 

I have 4 Axis CNC machine with 4th axis installed parallel to Y move , but in controller is A axis .

I add 4th axis and have some movement with it - at least first drilling cycle is correct 🙂 .

But after first rotation - instead of drilling using Z coordinate , I get movements on X axis .

Next rotation of 90* and drilling goes up in Z ( instead of down ) .

Can someone advice what to change in post processor attached ? 

Test project also added below .

 

4 REPLIES 4
Message 2 of 5
seth.madore
in reply to: roman_Sholiak

I took a quick look at the post processor, it looks like it just needs a simple edit. 

var tcp = true
Set it to:
var tcp = false

Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 5
roman_Sholiak
in reply to: seth.madore

Thanks - it works !

Message 4 of 5
roman_Sholiak
in reply to: seth.madore

BTW ,
It works not - but only with safe retract as G28 . If I change it to Clearance High - behavior is like before .
But anyway - at least it working 🙂
Message 5 of 5

I tried using the post processor with and without changes , but somehow it both time it failed to generate g code. Telling there the direction is not supported for machine configuration 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report