Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NC code failed to post "Error: Failed to invoke function 'onOpen'."

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
kksAZZV7
67 Views, 2 Replies

NC code failed to post "Error: Failed to invoke function 'onOpen'."

Hello 

 

I have attached my file.

 

I am trying to post process for my fourth axis Stepcraft, but I keeps getting this error:

 

Information: Configuration: STEPCRAFT UCCNC
Information: Vendor: UCCNC
Information: Posting intermediate data to '/Volumes/PRUSA/Tuborg/1001.nc'
Information: Total number of warnings: 1
Error: Failed to post process. See below for details.
...
Start time: Tue Jan 9 10:35:34 2024
Warning:
Post processor engine: 4.6050.0
Configuration path: /Users/kristofferkelstrupsabroe/Autodesk/Fusion 360 CAM/Posts/stepcraft uccnc (1).cps
Include paths: /Users/kristofferkelstrupsabroe/Autodesk/Fusion 360 CAM/Posts
Configuration modification date: Mon Aug 14 19:40:36 2023
Output path: /Volumes/PRUSA/Tuborg/1001.nc
Checksum of intermediate NC data: b658e4784f179fafdfc268a3a4987c84
Checksum of configuration: 1ebf47568740f9d6aad82492cc65e2c5
Vendor url: http://www.cncdrive.com/
Legal: Copyright (C) 2012-2023 by Autodesk, Inc.
Generated by: Fusion CAM 2.0.18186
...
Error: Failed to invoke function 'onOpen'.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Error: Failed to invoke 'onOpen' in the post configuration.
Error: Failed to execute configuration.
Stop time: Tue Jan 9 10:35:34 2024
Post processing failed.

 

Could anyone help me?

 

Br. KRistoffer

 

2 REPLIES 2
Message 2 of 3
serge.quiblier
in reply to: kksAZZV7

Hi @kksAZZV7 

 

Can you share the post processor you are using?

It's a file with the cps extension.

Because, apparently the post is either corrupted, or something is wrong inside.

Posting always start by calling the onOpen function.

 

Regards.


______________________________________________________________

If my post answers your question, please click the "Accept Solution" button. This helps everyone find answers more quickly!



Serge.Q
Technical Consultant
cam.autodesk.com
Message 3 of 3
kksAZZV7
in reply to: serge.quiblier

Hello Serge

 

I think I solved it. I had turned aircooling on by accident which is not supported by Stepcraft. At the same time the cylinder inside the object was (maybe) not cylindrical after all. Anyway. It works now. Thanks.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums