Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

M0 Output Help

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
jacobcanady
116 Views, 3 Replies

M0 Output Help

Been a little while since I posted, but this has me stumped.  I'm not sure if this is a result of a previous update or what, but I can't figure this out.  I also can't remember exactly when this began happening, but allow me to explain:

 

Previously, when I would output gcode from Fusion 360 using the Mach3/CNCRouterParts post processor, I could load the program into Mach3, hit cycle start, and the machine would start cutting.

 

Now, using the same post processor, every time I output gcode, load it into Mach3, and hit cycle start, the program pauses and I have to hit cycle start again.  It appears I am getting M0 right at the beginning of my code and I can't find a way to disable outputting it, *without causing other pauses from M6.*

 

I've toggled the "Preload Tool" and "Output M6" options in every configuration and if I don't get an M0 at the beginning of the code, I get T1 M6.  None of my tools have the "manual tool change" option checked and I don't know what else I can change to output code that will just run without pauses when I start the program.

 

Any ideas?  I'm sure I can change it in the post processor but that's getting a bit above my skill level.

3 REPLIES 3
Message 2 of 4
seth.madore
in reply to: jacobcanady

Could you share a Fusion file that demonstrates this behavior?
File > Export > Save to local folder, return to thread and attach the .f3d file in your reply.

Also, are you using the generic Mach3 post processor?


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 4
engineguy
in reply to: jacobcanady

@jacobcanady 

 

I can see how that might be a little frustrating if you are only running one operation or several with the same tool, you can disable that M0 in the PP as shown in the image below, you can then use the "Optional Stop" (M1) for any tool changes you might want to do as that will toggle on/off as needed.

The M6 will toggle on/off as you wish, below is a small snippet of G code showing how it will work. Have a look and see if that is what you need.

(5757)
(TEST FILE)
(T11 D=6. CR=0. TAPER=118DEG - ZMIN=-1.803 - DRILL)
(T68 D=6.8 CR=0. TAPER=118DEG - ZMIN=-2.043 - DRILL)
G90 G94 G91.1 G40 G49 G17
G21
G28 G91 Z0.
G90

(DRILL M6 THROUGH)
M5
T11
(6MM DRILL SUS - STUBBY)
S3000 M3
G54
G0 X-91.221 Y12.213
G43 Z20. H11
Z10.
G98 G81 X-91.221 Y12.213 Z-1.803 R10. F600.
G80
Z20.
G28 G91 Z0.
G90

(DRILL M6.8 THROUGH)
M5
M1
T68
(6.8MM SUS DRILL STUBBY)
S3000 M3
G54
G0 X-14.302 Y50.42
G43 Z20. H68
Z10.
G81 X-14.302 Y50.42 Z-2.043 R10. F1000.
G80
Z20.

G28 G91 Z0.
G90
G28 G91 X0. Y0.
G90
M30

Mach3 no M0.jpg

 

All I have done is "comment out" line 922 by placing the double forward slash // at the start, that stops that line being executed.

Hope this helps 🙂

Message 4 of 4
jacobcanady
in reply to: engineguy

@engineguy I just tried commenting out line 922 (line 629 in my case) and output a quick test Gcode, and M0 is gone!  Thank you so much for your help!  I am going to go try it on the machine to make sure I didn't break anything else, but thanks again.  Very cool.

 

I'm still confused as to why it began outputting M0 on all my programs when it didn't used to, but I'm guessing it was part of a previous update.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report