Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Lathe live tool wear compensation - Haas ST-28Y

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
JoshSY78U
234 Views, 5 Replies

Lathe live tool wear compensation - Haas ST-28Y

Hello,

 

I am milling a couple small lugs on the face of my part with a 1/2" end mill using an axial live tool holder. I used adaptive clearing for roughing the features and this worked great on the lathe using XZC movements. I then run a simple 2d contour on each feature to finish them to size. In my finish operation in Fusion, I select "Wear" on the tool compensation dropdown, but then when I post the program using the Haas ST-28Y post processor, it fails to post the code. I switch the tool compensation back to "In computer" and it posts just fine. I manually entered in a G41 and G40 in my program and wear comp worked on the machine. I just want to figure out how to get Fusion to do this right from the start.

 

Anyone ever have this problem and come up with a solution other than manually making the program have G41s?

 

Screenshot 2024-03-01 072009.pngScreenshot 2024-03-01 072313.png

 

Thanks in advance!

5 REPLIES 5
Message 2 of 6
hphanQ726A
in reply to: JoshSY78U

What's the error it says?

If you share the file which can easily to figure it out!

Message 3 of 6
engineguy
in reply to: JoshSY78U

@JoshSY78U 

 

Welcome to the Forum

 

Have you tried using the "In Control" option, that should output the G41 for you. Hope that helps 🙂

Message 4 of 6

I see no file, but I bet your Compensation Radius of .025 is too wide and would cause the paths to cross over each other if set to the max. Change this to .005 (or your part tolerance) and try again. If it doesnt work, try again with just ONE lug selected. This will demonstrate where the issue lies. 

Please click "Accept Solution" if what I wrote solved your issue!
Message 5 of 6
JoshSY78U
in reply to: JoshSY78U

I did some trial and error with the post processor selections and checked the "Use G112 polar interpolation" box. I then posted it again, with "Wear" selected in the finishing operation and it successfully posted with no errors. My original program was posting C-axis moves, so it wasn't able to activate the comp when moving the C-axis. I'll go try this on the machine and report back. Screenshot 2024-03-01 083119.png

Message 6 of 6
JoshSY78U
in reply to: JoshSY78U

The compensation ended up working on the machine with the posted program using XYZ. The control interprets these moves into C-Axis moves and handled the wear comp perfectly. Problem solved. Thanks for your help everyone!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report