Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue with Z height offset after facing operation

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
troygATJ4L
424 Views, 4 Replies

Issue with Z height offset after facing operation

Hello all,

 

Let's say for example I have a piece of stock in my vise 1/2" height.  I add .050 to Z+ and Z-.  My first operation on the top side of my part is a facing operation to remove the stock to model top so .050 will be removed.  My second operation could be a 2D chamfer or Engrave operation.  On either strategy I select either "selected contour" or "model top" and set my offset to -0.01 for my engraver depth and after the face op completes, I change my tool and the next operation continues to cut air.  For my 2d chamfer I set the chamfer width, offset and I also continue to cut air unless I manually add the amount of material I milled off to my Z height.

 

If I manually add the .050 to my Z height the tool will then engage into the material.  I have measured my tool several times making sure everything is accurate "length below shoulder" in the cutter information tab and setting the tool height with an electronic tool height setter.  

 

All of my other ops work just fine.  I seem to have the most problems with these two.  Can someone please help point me in the right direction?  I know I must be missing something and have tested, tested and tested only yielding the same results - cutting air.  Now if I re probe my Z and then start the program the machining process is just fine.

 

It's as if my model top or selected contour gets ignored.  I'm running the latest paid version of Fusion 360.

 

I hope this scenario makes sense and hope to find a solution soon because I'm at wits end with it. 

Thanks in advance!

Labels (2)
4 REPLIES 4
Message 2 of 5
johnswetz1982
in reply to: troygATJ4L

Attach your file by File>export>*.f3d and attach to forum reply. It sounds like you are setting your wcs to stock top as Z=0.0 and then setting all of your tools to that. You would probably want to touch off with your facing tool for what ever amount to extra stock you have in your fusion setup so you would have something like Z.040 when you set your work offset with your facing tool. 

Message 3 of 5
troygATJ4L
in reply to: troygATJ4L

Thanks for the quick reply John.  I am setting my WCS on the stock top back left point because I was under the assumption since I am probing my stock that's where I needed to select.  Even though I'm probing to set my G54 I can still select the WCS on my model top back left point and still have my offsets working correctly?  Attached is a sample file that contains everything we're talking about here.  

Message 4 of 5
johnswetz1982
in reply to: troygATJ4L

You can set you WCS to be a model point rather than stock point. I am not sure how it would work with probing, but if your probe touches the stock and gives you Z=0.0 then you would manually subtract 0.050 from the work offset register. Or maybe you can tell the probe when it touches that it is Z=0.050.

 

Your other issue is going to be that when you flip your part over if your are trying to maintain some nominal size that you are going to have to walk in your offset and measure after the facing operation to get the size your after. So when you flip your part over you might set your WCS to be Z=-0.040. Face measure and subtract whatever would be remain from the WCS offset.

Message 5 of 5
engineguy
in reply to: troygATJ4L

@troygATJ4L 

 

Hope you don`t mind, I had a look at your file and found a couple of things that need adressing.

 

1) You have your WCS in Fusion set the the center of your Stock, usually easier to use a corner of your Stock for the WCS, so as you have already mentioned using the Top Left corner then I will use that to avoid confusion in the attached file.

2) Re your Chamfer, that is not the correct method to use when you have a Modelled Chamfer, you select the Lower edge and in your Heights Tab select the "Selected Contours" option for the "Bottom Height", then under the "Passes" tab you do not input a value for the first box "Chamfer Width", leave it at 0, then the next box "Tip Offset" you would only put a value in there if you have a Chamfer tool that does not go to an exact point, because there are few if any tools that are like that then even if it appears to have a point it is usually advisable to put a small value in there to drop the tool a fraction, the third box "Chamfer Clearance" in your case leave that also at 0 as there doesn`t seem to be anything to collide with so no clearance value required 🙂

Look at the settings in the attached file.

3) Your engrave has a small "Cusp" at the cross point in the "t" so you may have to dig that out by hand, otherwise it looks OK 🙂

 

Now we get to your machine, you have your lump of stock in the vise and you bring either a "Master Tool" or a "Probe", "Edge Finder" etc, etc and touch off the Top Left corner of your Stock, you have to use the Stock as there is no model to set from, so do not use "Model Box" point for the WCS in Fusion, that`s when you start to get into adding/subtracting things that can lead to confusion, keep it simple !!

That is it, no need to add/subtract anything at this or any other stage, after you run your Facing Operation the surface that you are left with will be the top of your Model so you will then touch off all your tools to that surface every time if you are manually changing after each operation, the tool lengths in Fusion are completely irrelevant as regards the G code output, they are only for use in the simulation so it doesn`t matter if they are not 100% accurate, they are a good guide to being able to see if any particular tool might have a collision. The value that your CNC control uses for the tool length is the one that you input from your tool setting from the top of your faced off stock.

 

One other small issue that doesn`t really cause a problem is that your Chamfer is 0.110 on the long sides and 0.113 on the short ones, in reality you will get the same Chamfer all the way round 🙂

Anyway, have a look at the attached file, it may be of some small help to you, hope the above ramblings haven`t been too confusing or boring for you 🙂 🙂 🙂

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report