Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

internal cam error 3d adaptive

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
hackish
141 Views, 2 Replies

internal cam error 3d adaptive

I was trying to coax 3d adaptive to cut the outside of my part and by adding a silhouette for the machining contour, I have received an internal cam error. The file is attached.

 

If I add an additional offset, it succeeds - I have a feeling the tool diameter won't fit and is confusing the strategy. HEre is the error traceback.

Debug: Autodesk dcamcomponents 1.168.0 pm12787

Autodesk CAM Kernel 3.116.2 (ef65b034) x64 STABLE vs2022 ef65b03494d9cb86e796a92afa5a65d00d1ae1b0 2023/02/02 04:00

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Autodesk dcamcomponents 1.168.0 pm12787

Exception in thread THzlevels:

Traceback (most recent call last):

File "lib\threading.py", line 954, in _bootstrap_inner

File "lib\roughsteel\ZLevelsClass.py", line 1168, in run

File "lib\roughsteel\ZLevelsClass.py", line 1288, in Lrun

File "lib\roughsteel\ZLevelsClass.py", line 1058, in DoNextDowns

File "lib\roughsteel\ZLevelsClass.py", line 925, in NextZDown

File "lib\roughsteel\ZLevelsClass.py", line 820, in FindFlatLevel

File "lib\roughsteel\ZLevelsClass.py", line 777, in Overlap

File "lib\roughsteel\ZLevelsClass.py", line 773, in OverlapI

TypeError: '>' not supported between instances of 'NoneType' and 'float'

failedthreadinfo = ZlevelsCreator failed.

 

Debug: Total processing time: 125 ms

 

Debug: Total elapsed time: 1330 ms

 

Invalidated: Generation failed

 

2 REPLIES 2
Message 2 of 3
seth.madore
in reply to: hackish

Just set your Boundary to "None", turn on Stock Contours, and then set Rest Machining to "From Prior Operations". Result:

2023-03-04_13h33_37.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 3
hackish
in reply to: hackish

Thanks, this resolved the issue and allowed me to continue. Is the internal cam error a defect in the software that you create a PR on behind the scenes? 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report