Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Haas TL2 Post Modifications Needed

5 REPLIES 5
Reply
Message 1 of 6
jcracing135
329 Views, 5 Replies

Haas TL2 Post Modifications Needed

Hi all,

 

I have a 2019 Haas TL2 with a manual tool post and there are are some items that are bugging me in the generic haas turning post that I'd like to see if I can get resolved.  Here's the main hit list for now:

  1. Uses interpolated X and Z values to radius a curve making it hard to adjust on the machine, how can we force the post to output an R value instead that's easily adjusted?  In some cases we want to see the R value for simple 90 degree radiused edge brakes, and other times we want to see an I/J/K value using G2/G3, but for some reason it only does point to point in X/Z moves.
  2. Outputs a G98 (feed per inch) instead of G99 (feed per rev) on drilled holes.  How can we force it to use G99 for everything, always?
  3. G53 home position on Z doesn't retract to where I want it to for my manual tool change position.  It only sticks the X value in, no Z between tool changes and I always have to go add it before the next tool change.  It does work however at the end of the program.  Is there a setting to also make this happen between tool changes since I have the Manual Tool Change option in the post selected as YES?  One would think that if that option is set to YES, move the tool post to G53 values specified in the post options.

Thanks in advance!

Tags (4)
5 REPLIES 5
Message 2 of 6
seth.madore
in reply to: jcracing135

For the first one, setting this to "true" will solve the R value versus I/J/K:

 useRadius: false, // specifies that arcs should be output using the radius (R word) instead of the I, J, and K words.

 

I'm going to skip the second question right now, as I'm not immediately sure of the best way to do it, but I'll poke at it a bit as time allows

 

For the third question, change this line (around 817):

   writeRetract();

To:

writeRetract(X, Z);

 

 

This is assuming you are using this Haas Turning post found HERE
 


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 6
Arun.rs
in reply to: seth.madore

HI @jcracing135 

 

For the two question @seth.madore has given the correct solution.

 

For your second query, to change G98 to G99 for drilling cycle. I find one similar post in forum. Attaching for your kind reference : https://forums.autodesk.com/t5/fusion-360-manufacture/need-post-to-change-g98-to-g99-during-drilling...

 

If you got any doubts regarding editing the post please let me know.  

 

For detail info about the post editing please refer the  FAQ link

 

Regards



Arun.RS
Technical Consultant - Post Processor
Message 4 of 6
jcracing135
in reply to: jcracing135

Thank you for the reply @seth.madore and @Arun.rs !

I attached the post I am using.  We have already made a few small adjustments to it.  

Line 48 is now set to true but I am still not getting R values on edge breaks.

I can't find where the writeRetract is located...maybe this wasn't in the original post that I downloaded from the site back in September 2020?

I also can't find where to change the Feed per Minute to Feed per Rev.  

Can you guys please have a quick look at this post and let me know if this is the same post you assumed I was using?

Thanks!
Jason

Message 5 of 6
Arun.rs
in reply to: jcracing135

HI @jcracing135 

 

Apologies for delay in reply.

 

1. For R output for circular motions, you have to set 'allowedCircularPlanes = undefined;' . This is allow circular interpolation in all three planes

 

allowedCircularPlanes : Defines the standard planes that circular interpolation is allowed in,PLANE_XY, PLANE_YZ, PLANE_ZX. It can be set to undefined to allow circular interpolation in all three planes, 0 to disable circular
interpolation, or a bit mask of PLANE_XY, PLANE_YZ, and/or PLANE_YZ to allow only certain planes.

 

allowedCircularPlanes = undefined; // allow any circular motion

 

 

2. For Homing codes, the newer version of HAAS turning post has  'writeRetract()' , you can download from here 

 

OR 

 

You can edit in your modified post processor 

 

a. Go to line number 785 

b. Remove '//' from below codes 

 

  //writeBlock(gFormat.format(53), gMotionModal.format(0), "Z" + zFormat.format(properties.g53HomePositionZ)); // retract
    //zOutput.reset();

 

Retract.png

 

3. For Feed per revolution, 

 

  a. Go to line number 853 , and replace

 

From this:

 if (currentSection.feedMode == FEED_PER_REVOLUTION) {
    writeBlock(getCode("FEED_MODE_UNIT_REV"));
  } else {
    writeBlock(getCode("FEED_MODE_UNIT_MIN"));
  }

 

To this :

    if (currentSection.feedMode == FEED_PER_REVOLUTION || getParameter("operation-strategy") == "drill") {
    writeBlock(getCode("FEED_MODE_UNIT_REV"));
  } else {
    writeBlock(getCode("FEED_MODE_UNIT_MIN"));
  }

 

b. Go to line number 1346 , Change 

 

From this:

var F = cycle.feedrate;

To this :

var F = (gFeedModeModal.getCurrent() == 99 ? cycle.feedrate/spindleSpeed : cycle.feedrate);

 

Save the file and check the NC output carefully.

 

Regards

 



Arun.RS
Technical Consultant - Post Processor
Message 6 of 6
jcracing135
in reply to: jcracing135

Hi @Arun.rs 

I just posted a program using a tap, (one of the firsts I believe we have done on this lathe), and the output feedrate is not correct.  

The G84 code it posts is G84 X0. Z-0.8906 R-0.337 P0 F35.7143

RPM is 1000

This is for a 1/4-28 tap

Feedrate should be 1/28 = .0357 and should be independent of RPM.

I do not have an option in F360 to specify IPR, it only shows SFM.

Is there something that needs to be changed in the post or somewhere else to specify the correct feedrate in IPR?

Thank you!

Jason

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report