Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

generate bore tool path fails to find circular faces

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
djlunty
180 Views, 6 Replies

generate bore tool path fails to find circular faces

When re-generating a previously generated bore tool path it fails to find circular faces that are circular.  They are circular - generated yesterday and have a radius and diameter when using inspect.

 

Before Generate

djlunty_0-1701553309470.png

After Generate

djlunty_1-1701553369367.png

With the following warning

djlunty_2-1701553422463.png

All I did was Generate the tool path

 

The components are were created from a sketch with two circles and an extrude so no funky splines 

Undo gets the tool path back.  Same problem for all the setups in this file.

If I copy the component  (display wheel spacers) 

djlunty_3-1701553828519.png

to a new file

djlunty_5-1701555273669.png

 

I can generate a new tool path

djlunty_4-1701554628238.png

 

If I recreate the hole in the component in the original file (delete inner circle, redraw and extrude) still get the error when trying to edit the tool path.  Deleting the tool path and creating it again still gives the error.  Changing cutter size from 1/4 to 3/16 makes no difference,  Restarting Fusion makes no difference.

 

Seems to be something with the  bore tool path in this particular file but I cannot find what I may have changed.

The original file and the test file attached.

Doug

 

Doug

 

 

 

 

6 REPLIES 6
Message 2 of 7
djlunty
in reply to: djlunty

Checked file again today and finding circular faces was erratic - would find them about 1/3 of the time.  Also could not find circular faces for Circular Toolpath.  Seems to have a mind of it's own and just tormenting me.

Tried to repair fusion using the service utility - could not find some file so just uninstalled fusion and re-installed (third time in last two days) and now it works - can find circular faces with the bore tool path

Hope it keeps working!!!

Doug

 

Message 3 of 7
seth.madore
in reply to: djlunty

This does seem quite odd. If I create a Setup off the Design Model (not the MFG model) I'm able to create a toolpath with Bore:

2023-12-04_15h12_08.png

 

More investigation is required... 


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 4 of 7
seth.madore
in reply to: djlunty

I've opened CAM-50149 to investigate this issue.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 5 of 7
djlunty
in reply to: seth.madore

@seth.madore 

Had the same problem today - would not find circular faces with bore tool path.  Attached is a file with a bore tool  path that works - and a bore tool path that will not find circular faces. 

A way I got it to work was when no circular faces are found say "No" to the error message (do not complete the tool path) You will be taken back to the bore tool path dialogue box and now the bore faces can be selected as circular faces - weird!

If one circular face is found  but not a second one  say "OK" in the dialogue  box (complete generating the tool path) and then go back and edit the tool path and select the missing faces and and now they will be selected as circular faces - weird again.

Being as the behaviour is  erratic  I am not sure if the above methods work all the time.

The attached file is part of the original file I sent - just copied and pasted a couple of components into a new file.  Don't know if that would make any difference.

Doug

 

Message 6 of 7
seth.madore
in reply to: djlunty

Interesting workaround, but I'm not given a message that presents anything other than "OK":

2023-12-05_08h08_59.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 7 of 7
djlunty
in reply to: seth.madore

@seth.madore 

This morning I do not get the error "Unable to find circular faces".  Instead I get the same error as you "Failed to generate tool path".  I wonder if it has something specific to do with my install of fusion.  In the last few days when if I use the  service utility to Repair Fusion it fails and I have to do an uninstall and reinstall.  Maybe I have to try a Clean Uninstall- up to now I have been doing the  uninstall from Widows Control Panel.  Your thoughts?

Doug

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report