Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

few issues with the default CL-1 post

4 REPLIES 4
Reply
Message 1 of 5
programming2C78B
106 Views, 4 Replies

few issues with the default CL-1 post

a) line 210:
homePositionX: {
title : "G53 home position X",
description: "G53 X-axis home position.", 

for some reason is being treated as radial, not absolute. We want to go to g53 x-12, so Im having to enter a -6. to get what we expect.


Output: 

G53 G0 Z0.
G53 X-12.

b) I cannot find where/how this is also being called up at the end of the operation and for no reason it's missing the g0's. I see that there's one for the initial X retract, but our operator says the machine just crawls back to home with this as it is. 

programming2C78B_0-1707845897977.png

C) can we have a 2nd home position for when Live tooling is used, since they are on the opposite side of the part on this machine? 

 

Please click "Accept Solution" if what I wrote solved your issue!
4 REPLIES 4
Message 2 of 5

Hi line 3974 is where its being output

alaasW8M6T_0-1707847183988.png

 

Its  in Diameter mode because its calling the Xformat

var xFormat = createFormat({decimals:(unit == MM ? 3 : 4), forceDecimal:true, scale:2}); // diameter mode & IS SCALING POLAR COORDINATES

Change this line, add the /2 at the end

writeBlock(gFormat.format(53), gMotionModal.format(0), "X" + xFormat.format(getProperty("homePositionX")/2)); // retract

 

The reason its not outputting G0 is due to using gmotionmodal format which sees the last moves in the Gcode as G0 so Doesn't output it again.

 

you can add 

  gMotionModal.reset();

 

 

Before to force the G0 output

Message 3 of 5

Thank you. Youre /2 trick only works at the end of the code though. The first safety retracts are -24  and the safety at end of the program is showing -12.
I'm using the identical

"writeBlock(gFormat.format(53), gMotionModal.format(0), "X" + xFormat.format(getProperty("homePositionX")/2)); // retract" in both places and one is outputting wrong! 

programming2C78B_0-1707852322121.png

 

 




The reset didnt work for me. I attached my post. IT SEEMS TO BE BROKEN NOW? I didnt touch line 3987

If you could show me how to get the Visual Studio to show "where" a thing is posted out from, that would be appreciated. I don't know programming languages but have been getting my way around post editing.
EDIT: I found out! There are decent instructions in the pdf. CTRL ALT G ! 

programming2C78B_0-1707851032675.png

 

Please click "Accept Solution" if what I wrote solved your issue!
Message 4 of 5

I fixed it and made some headway. A BIG lesson is you have to SAVE your file before re-posting, otherwise none of the changes will take effect. This made things a lot faster today, since i spent half of yesterday scratching my head why some edits didn't take effect and others did.

Please click "Accept Solution" if what I wrote solved your issue!
Message 5 of 5

You can also do it like I have in the attached. Search for my initials(BD) and you'll see what I did.

 

xFormat has a scale of 2, zFormat has a scale of 1.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums