Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Even with smoothing enabled, Fusion shows and cuts straight lines instead of arcs.

14 REPLIES 14
SOLVED
Reply
Message 1 of 15
adpppw
387 Views, 14 Replies

Even with smoothing enabled, Fusion shows and cuts straight lines instead of arcs.

No matter what I do I cannot get fusion to actually cut arcs on curved surfaces. I have selected smoothing for all operations and set the smoothing and tolerance to really tight like 0.01mm or even 0.001mm. No matter how I change those values it still shows the following stock simulation (while the toolpath looks smooth). The cut also turns out like this (the circle peg should be circular, but it turns out faceted)

 

adpppw_0-1711203495760.png

Same thing with this exterior contour path

adpppw_1-1711203551588.png

 

What is interesting is that in Simulate it shows it as cutting a circle. I am using the GRBL carbide3d post.

 

 

14 REPLIES 14
Message 2 of 15
seth.madore
in reply to: adpppw

What's the Accuracy slider set to in Simulation? If you turn on "Show Points", what do you see?

Would you be able to share your Fusion file here?
File > Export > Save to local folder, return to thread and attach the .f3d/.f3z file in your reply.


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 3 of 15
HughesTooling
in reply to: adpppw

I suspect @seth.madore is correct and you have the simulation accuracy set too low. But if you right click the toolpath in the browser and select Show toolpath data what does it show when you click on one of the circular moves?

HughesTooling_0-1711205109074.png

HughesTooling_1-1711205219754.png

 

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 4 of 15
adpppw
in reply to: seth.madore

Simulation Accuracy is set to max and show points shows arc points. 

Message 5 of 15
adpppw
in reply to: HughesTooling

It shows Circular. But the stock simulation outside of Simulate mode, like just during the regular manufacture workflow process shows facets as above. And it ends up being cut like that. Could my post be converting those circular paths to line segments outside of my control?

Message 6 of 15
HughesTooling
in reply to: adpppw

This is what I get with your file and I don't even have the accuracy set to max.

HughesTooling_0-1711205699076.png

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 7 of 15
adpppw
in reply to: adpppw

Yes I agree in Simulate mode it shows as circular, and in the toolpath data it shows a Circular path as well. But for whatever reason when actually cut out it is faceted exactly like it looks in Manufacture mode outside of Simulation mode

 

adpppw_0-1711205918574.png

 

Message 8 of 15
HughesTooling
in reply to: adpppw

I guess this is in progress stock? Not sure you have control over the in progress stock resolution.

HughesTooling_0-1711205917162.png

 

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 9 of 15
seth.madore
in reply to: adpppw

For IPS, it's going to be a lower accuracy STL than what you see in Simulation, it's just the way it is. In addition, your parts are quite small, with some of the radii measuring 1.4mm. IPS (In Process Stock) just doesn't provide a perfect resolution. 

On a similar note as to @HughesTooling, this is also what I see in Simulation, accuracy set to a few notches below max:

2024-03-23_10h59_31.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 10 of 15
seth.madore
in reply to: adpppw

And looking at your code, I'm seeing a fair bit of arc fitting happening, and your actual circular features (such as the post) are posting in I/J:

2024-03-23_11h01_52.png


Seth Madore
Customer Advocacy Manager - Manufacturing
Message 11 of 15
adpppw
in reply to: adpppw

Ok so it looks like that cause of the IPS resolution setting in Fusion and I happen to be making small parts. 

I had also cranked up the simulation accuracy setting after you guys asked and we all see that in Simulate it shows as a circular cut.

 

This makes me think that my cnc machine (Nomad 3) or its grbl processor is converting those arcs to line segments outside of my control?

Message 12 of 15
HughesTooling
in reply to: adpppw


@adpppw wrote:

Yes I agree in Simulate mode it shows as circular, and in the toolpath data it shows a Circular path as well. But for whatever reason when actually cut out it is faceted exactly like it looks in Manufacture mode outside of Simulation mode

 

 

 


Well that would point towards a problem on the machine. If there are G02/G03 moves in the posted code it should be circular. If you're getting faceting from a G02/03 move must be the machine.

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 13 of 15
HughesTooling
in reply to: adpppw


@adpppw wrote:

It shows Circular. But the stock simulation outside of Simulate mode, like just during the regular manufacture workflow process shows facets as above. And it ends up being cut like that. Could my post be converting those circular paths to line segments outside of my control?


Although the feed rate isn't that high I guess the control might be struggling to keep the correct feed and creating flats. Maybe try a finishing cut at a lower feed.

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Message 14 of 15
adpppw
in reply to: HughesTooling

Looking at other forums it seems grbl processors can ignore G2/G3 codes and convert them into line segments. I need to explore down that route, but I assume for now that is the issue.

However from this thread I learned that it looks faceted in Fusion because the IPS resolution is low and my parts are small! That is useful.

There is no way to increase the IPS resolution correct?
Message 15 of 15
HughesTooling
in reply to: adpppw


@adpppw wrote:

There is no way to increase the IPS resolution correct?

I don't think so. The IPS stock need to calculate as fast as possible so the resolution is lower than using the simulation. Personally I do not have the IPS enabled because it slows toolpath generation too much on complex toolpaths.

 

Mark Hughes
Owner, Hughes Tooling
Did you find this post helpful? Feel free to Like this post.
Did your question get successfully answered? Then click on the ACCEPT SOLUTION button.

EESignature


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums