Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Chamfer does not generate G41/G42 cutter compensation

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
Marek_B
883 Views, 9 Replies

Chamfer does not generate G41/G42 cutter compensation

Hello,

I have to chamfer the hole using chamfer operation. At Passes tab for this operation there is a Compensation Type option.  I have selected " Wear" but the code generated does not have G41 G40 compensation.  Is it bug or I am doing something wrong.

I have attached Fusion file.

 

Thanks

 

Marek

9 REPLIES 9
Message 2 of 10
Steinwerks
in reply to: Marek_B

I believe this is a bug and 2D Chamfer doesn't use wear compensation. Tried it in an entirely different part with completely different geometry and wound up with the same result. You can use 2D Contour though, using the Chamfer checkbox on the Passes tab, and wear compensation is working correctly.

 

@fonsecr could you confirm this?

 

Edit: I got the same result using 2D Chamfer in HSMWorks 2018 R1.41862.

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Message 3 of 10
Marek_B
in reply to: Steinwerks

If this is bug, should it be reported to somebody?

Message 4 of 10
Steinwerks
in reply to: Marek_B

I tagged a developer in my previous post to get his attention hopefully. I feel like this has been around for a while so perhaps we'll get some insight.

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Message 5 of 10
fonsecr
in reply to: Steinwerks

Thanks. An oversight on my behalf. I opened ticket CAM-7448 to get this one supported.

 


René Fonseca
Software Architect

Message 6 of 10
soldfather
in reply to: fonsecr

I've been seeing the same issue.  This thread has been silent for a while now.  What was the end result?  Fix or no fix?

Message 7 of 10
slickmilwaukee
in reply to: soldfather

Still having the same issue. NO G41/G42 with chamfer. Why is it in the drop-down and available to choose if it's not going to work? Is this ever going to be addressed, or am I just missing something??

Message 8 of 10
303Michael
in reply to: Marek_B

I came looking for a missing G41 in my code and apparently, this is still a thing 5 years later.

Message 9 of 10
tommi91CLFY8
in reply to: Marek_B

still not fixed?

Message 10 of 10
DarthBane55
in reply to: tommi91CLFY8

Hi, there is actually nothing to fix.  Read thru this:

https://forums.autodesk.com/t5/hsm-post-processor-forum/2d-chamfer-and-cutter-comp/m-p/11719963#M306...

Actually, you can skip to the last few answers.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report