Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

A-axis Wrap Toolpath: produces weird groove not shown in simulation

Message 1 of 6
332 Views, 5 Replies

A-axis Wrap Toolpath: produces weird groove not shown in simulation

I have a dedicated A (harmonic drive), X, Z setup that im trying to establish some work flow with.


My main objective is to do some spiral'alike (/continuous) wrap around patterns.


  • In CAM "wrap toolpath" (with a 2d contour) seems to be my rescue.
  • I tried to do a simple coil cut out on some round stock
  • Exported with Mach3mill post processor, which allows to define fourth axis (running it in Mach4)
  • G-code > Besides some weird Z0 + Y0 at start and X0 at the end (I removed those), the g-code seemed to work.

For some unknown reason, the cut stops up midway and suddently does a full rotation with the mill engaged into the stock.


  • This leaves an unwanted groove into the stock
  • Furthermore this specific unwanted move is not seen in the simulation at all


Anyone know what's going on or why this is happening?

- Attached image, g-code and Fusion file as reference


I did a 1.5min recording where you can see it happen aswell. It can be seen here:
Ignore the fact that the setup is not calibrated at all

Message 2 of 6
in reply to: Anonymous

Hi @Anonymous 

I cannot see you attached g code. with the video what I am seeing is

1.your rotary direction seems to be wrong,

2. I think your machine does not have shortest path enabled, means when the A rotation value comes like this then 

X23.304 A0.198 F756.8416

X23.449 A-1.056 F758.5158
Instead of choosing the shortest path you machine seems to choose the alternate solution which is rotate 360 deg in the opposite direction to get that value. so if you could attach the post you are currently using then I can help to configure the kinematics properly in the post.
If you are using the generic mach3mill post then changing the kinematics to it like below will sort this issue 
make a copy of the post and edit it and look for this set codes and replace it with the below codes
  if (getProperty("fourthAxisAround") != "none") {
    var aAxis = createAxis({coordinate:0, table:true, axis:[(getProperty("fourthAxisAround") == "x") ? 1 : 0, (getProperty("fourthAxisAround") == "y") ? -1 : 0, 0], range:[0, 99999], cyclic:false, preference:1});
    machineConfiguration = new MachineConfiguration(aAxis);

    optimizeMachineAngles2(1); // map tip mode

Save and test the post carefully 

Boopathi Sivakumar
Senior Technology Consultant

Message 3 of 6
in reply to: boopathi.sivakumar

Thanks a bunch Boopathi, what you mention could surely make sense 😁


The .tap was removed for some reason. Eitherways, I will test your very fine code snippet tomorrow and see if it makes any difference and if not, i'll get the .tap posted again.


I'll let you know how it turns out.


A couple bonus questions to your reply:

  • You mention "shortest path enabled" -> Where would one normally find this option (if it exists)? I guess a setting in Mach4 somewhere? Im using Ethernet Smoothstepper (warp9)
  • I am using the generic mach3mill post, a side question to this: the generic mach4mill post doesn't seem to have the specific fourth axis option - so for some reason getProperty("fourthAxisAround") is stripped. Do you by any chance know why? Just seemed weird to me and confused me since I am using Mach4 and figured the Mach4mill post would be the "logical" choice for me. Both posts are close to identical, but yea, Mach4mill without the fourth axis option.





Message 4 of 6
in reply to: Anonymous

You can change it in the controller setting I believe. If you look at the manual to change the rotary axis setting you may able to see something like below in the controller 


 there you can enable the roll over to so your controller will take care the shortest path. I just pull it up from the mach4 manual.

To your second question yeah I can see for the mach4 there is no properties defined for setting the multi axis but the post has all the codes to do the 4 axis job. All you need is to set the flag ture to enable the post as multi axis. Go over this thread to know how to set the post as muti axis how-to-set-up-a-4-5-axis-machine-configuration

Hope it helps.. 

Boopathi Sivakumar
Senior Technology Consultant

Message 5 of 6
in reply to: boopathi.sivakumar

Thanks again - I made it work! Mach4 have those "rollover" options in:
Configure > Control > General > "Rotary Axes"


HOWEVER, I already had them checked... So the solution for me was actually to uncheck them...

While enabled and hitting 360deg the machine (and a-axis) would reset to 0, however unchecked it would just continue ... 361...362... etc.


There's one annoying "thing" left,- after having run for a while the A-axis end up on something like A1049:



X3.583 A183.798 F1589.9675
X3.465 A183.871 F7676.2525
X105.086 Z30.011 A1049.65 F9088.73



And when done it will then reset to A0 - but this means it will run from A1000 down to A0 - like 3 full rotations.



G0 A0.



I guess I would need to edit this out in the postprocessor somewhere? There's no smart option to handle this?

Message 6 of 6
in reply to: Anonymous


More advance controllers does have an option to reset the rotary encoder by passing certain M code (So this will set nearest complete revolution as 0) so this resolves unwinding all those A moves back to 0. But I am sure something like that will help.

I found this two threads hope it helps 

Boopathi Sivakumar
Senior Technology Consultant

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators

Autodesk Design & Make Report