Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

4th axis wrapped toolpaths are very slow with Stepcraft/UCCNC

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
FusionFan3000
192 Views, 3 Replies

4th axis wrapped toolpaths are very slow with Stepcraft/UCCNC

Hi everyone,

 

I'm using a 4th axis (rotary axis) to machine a cylindrical part. As a result, I'm using the 2D Pocket Operation and selecting "Wrap Toolpath." While the toolpath comes out correctly and it works, the actual travel moves are VERY slow. Maybe 10-25% of the actual feedrate that I was expecting, if not slower.

 

Reading other threads such as this one, it seems possible issues could be:

  • G93 / Inverse Time configuration
  • Incorrectly coded "Post" for my machine
  • Something else?

Any help would be greatly appreciated.

 

What I'm using:

  • Fusion360
  • Stepcraft CNC Machine
  • UCCNC Software

I have attached the F3D file for reference, as well as a copy of the Post file.

 

Thank you!

 

NC Configuration Screen.png

3 REPLIES 3
Message 2 of 4
engineguy
in reply to: FusionFan3000

@FusionFan3000 

 

I don`t see anything wrong with your code, the feed rate of F500 is in the code as a single command, if it was using Inverse Time there would be a different F*** code for every line of rotary movement, so if the code is sending the correct F500 to your Control then it is possible that the 4th axis settings in your control may need to be changed.

Do you have the correct ratio setting for the 4th axis ? Is it 70:1, 50:1 etc? That would cause the atual speed the axis revolves at to be too slow/too fast if not correct.

Message 3 of 4
FusionFan3000
in reply to: engineguy

Thank you so much for your reply! I'm looking at my control software (UCCNC) and trying to see if there is a setting that would make sense..

 

Could it be one of the settings in these in the screenshot below?

 

The thing is, the final part appears to come out reasonably dimensionally correct, but the toolpath is very slow. So, I can't imagine "steps/unit" is wrong, because it's rotating the correct amount.

 

"Units/min" looks a bit suspicious, but I'm not sure what it does. No documentation for it in the manual, still waiting to hear back from support. I could try playing around with it and see what happens?

 

I had played around with "Axis is rotary" and "Roll over on 360" previously but they don't appear to have the desired result. Sorry, I don't expect you or anyone coming by this thread to be familiar with the settings below...just sharing in case something may seem more obvious to you than it is to me.

 

UCCNC 4th Axis Configuration.png

 

Message 4 of 4

Ok, woops! It turns out, it was the "Axis is rotary" setting. (it should be enabled)

 

The reason I thought it wasn't is because I had changed too many settings at the same time, so when I enabled "Axis is rotary", I forgot that I had also increased the feedrate in the toolpath, and so I mistakenly believed that "Axis is rotary" caused the 4th axis to rotate way too fast.

 

Thank you for inspecting my files/G-Code, because when you mentioned it all seemed fine, that gave me the confidence to take a second look at my controller settings, and this time more methodically!

 

Thank you!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums