Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

417 abnormal end of job error when I try to post to Centroid Acorn SOLVED THX

4 REPLIES 4
Reply
Message 1 of 5
Geckocycles
130 Views, 4 Replies

417 abnormal end of job error when I try to post to Centroid Acorn SOLVED THX

The first center drill op (910) is working but none of the other NC's will work. The file size doesn't look right. I tried copy and paste to new document and no luck. Saving to computer instead of flash drive.

4 REPLIES 4
Message 2 of 5
jhackney1972
in reply to: Geckocycles

My guess is that you forgot to assign a Post Processor to your Machine.  If you look at the Machine (Autodesk robo), you will see that there is no Post Processor assigned.  If you edit one of your NC Programs, you will see the same thing.

 

No Post Assigned.jpgMachine Post.jpg


"If you find my answer solved your question, please select the Accept Solution icon"

John Hackney
Retired

Beyond the Drafting Board


Message 3 of 5
Geckocycles
in reply to: Geckocycles

This is a reply from Centroid:
"The problem is the program number.


"O9101" on line 2 of the program tells the Centroid control that the code which follows, until the next M99, are part of a subprogram that should be extracted and saved for later use (rather than being run immediately). Look up M98 and G65 in the operator's manual.

You should either use a program number that is not in the range 9100 - 9999; or you should name your file, e.g., "O9101.cnc", so that Centroid recognizes that it is already in place as a numbered program. Using a different program number will probably be simpler and more intuitive.

Note that you do not need to have a program number ("Onnnn" code) in your file at all. Centroid does not use program numbers for any purpose except to identify embedded subprograms."

I changed the number back to a smaller number (1001) and it worked and the PP was listed.
I had the PP setup in my machine profile but because the number was too large it didn't use the PP when posted is my guess yet it did post a NC.
There is code in this PP that is not needed. I was told years ago to use this PP when I was setting up this machine. Not sure why but it has worked. My son says he doesn't use all the "n" lines on each line and wished they weren't there. I would like to have just a line number instead if any..

Message 4 of 5
CNC_Lee
in reply to: Geckocycles

@Geckocycles 

 You will need to make quite a few edits to the post processor to achieve your desired output. I offer post processor development services and happy to work out a solution for your machine! Message me if I can be of assistance.   

If my post answers your question, please use Accept as Solution.

CNC Lee
Fusion 360 CAM Post Processor Expert
https://linktr.ee/cnclee
Message 5 of 5
seth.madore
in reply to: Geckocycles

So, the only issue is that you had a program number that was reserved for special functions? Isn't the solution just to use a number below 8999?

 

@CNC_Lee I'm not seeing a "whole bunch of edits being needed", what am I missing?

 

If you don't want all the "N" numbers, just untick the box to make it so


Seth Madore
Customer Advocacy Manager - Manufacturing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report