Community
Fusion Manufacture
Talk shop with the Fusion (formerly Fusion 360) Manufacture Community. Share tool strategies, tips, get advice and solve problems together with the best minds in the industry.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

2D Chamfer cutter comp not posting

14 REPLIES 14
Reply
Message 1 of 15
JonSchaeffer
1068 Views, 14 Replies

2D Chamfer cutter comp not posting

Not sure if this is a new issue or if it never did it...

I am setting my 2D Chamfer to Wear and it does not post out G41

Anything else I need to do?

Please see attached file

Last two operations are the culprit...

 

Thanks in advance!

-Jon

 

 


www.genesisprecisionaz.com
info@genesisprecisionaz.com
14 REPLIES 14
Message 2 of 15
Steinwerks
in reply to: JonSchaeffer

It's been broken a while:

 

https://forums.autodesk.com/t5/fusion-360-computer-aided/chamfer-does-not-generate-g41-g42-cutter-co...

 

@fonsecr any news on CAM-7448? Since it was fixed in HSMWorks (https://forums.autodesk.com/t5/hsm-beta-testing-english-deutsch/hsmworks2018-r1-41866-2d-chamfer-wro...) I presume it'll get fixed in the next Fusion 360 update as well.

 

Edit: it isn't fixed in HSMWorks 2018 R2.42084 either.

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Message 3 of 15
fonsecr
in reply to: Steinwerks

Hi,

 

CAM-7448 is still open. It turned out that we never properly support wear compensation for 2D Chamfer and it needs some work before it will be available in a release. There was a recent behavior change that made it not work when posting - that problem should be fixed but it will take some time to get wear support working as it must.

 


René Fonseca
Software Architect

Message 4 of 15
Steinwerks
in reply to: fonsecr

Thanks for the update @fonsecr.

 

I could even see the argument for not supporting compensation as using tight clearance values could cause collisions in the actual operation. That said, I believe it should still be added.

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Message 5 of 15
JonSchaeffer
in reply to: Steinwerks

Ok cool I hope it gets resolved soon. (It would be a nice feature)

 

I had a chamfer mill that was de burring a real shallow C'bore and I couldn't size the chamfer by lowering my H offset without cutting into the floor.


www.genesisprecisionaz.com
info@genesisprecisionaz.com
Message 6 of 15
JonSchaeffer
in reply to: JonSchaeffer

Actually the more I think about it. I understand why there is no cutter comp.

If a guy comps more than the clearance that was set it can crash...

 

I suppose contour would solve what I was trying to achieve.

Maybe remove the "WEAR" option in 2D Chamfer if it isn't going to post it anyways? Less confusion...


www.genesisprecisionaz.com
info@genesisprecisionaz.com
Message 7 of 15
Steinwerks
in reply to: JonSchaeffer


@JonSchaeffer wrote:

Actually the more I think about it. I understand why there is no cutter comp.

If a guy comps more than the clearance that was set it can crash...

 

 


 

I did make note of this above.

 

However, that's not really why it isn't in there as I understand the situation.

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Message 8 of 15

Just spent around an hour trying to figure out why my chamfer wasnt changing size and trying different posts and combos of lead in/outs to get it to post out before finding this.  Can someone from Autodesk disable this in the drop down or make a page of things that are in Fusion but don't work?  Seems a little half baked just leaving buggy/not working things in the program. 

Message 9 of 15
kennyWX7Y7
in reply to: JonSchaeffer

Any new updates on this?  I am having the same problem.  2d chamfer is something we use everyday and we need the wear comp to dial in the tool just enough to break the edge.  I am working on getting all my different chamfer mills set up correctly in Fusion so it hopefully won't be necessary most of the time but its those times in between that will cause a lot of headaches as i will have to manually add it in the g code and isn't the whole point of CAM software to eliminate this step.  Mastercam does it just fine so i am not sure why this is such a difficult problem to solve?  Insert the G41 on the first G1 move and insert G40 on last G1 move?  I do it manually when I use Fusion and it is easy and consistently the same process.  I am really trying to expand my use of chamfering in the machine to reduce inconsistencies with manually deburring and to increase part quality for customers.   I am not worried about having someone enter too high of a value, our machines will alarm out if the value is too high if you set the lead in and lead out to a small enough value.  Please get this problem solved ASAP!  I agree with some of the other posts, this problem should have been fixed a long time ago.  If they address this problem and others like it quickly they will get more users on board.  I'm on board but not fully committed yet.  I am waiting to get an answer on another problem with the cloud tool library as well.  The price point and concept is great but if they want to become an industry leader they need to address these issues quickly as they are important to everyday users and no one likes to explain to their boss the reason it takes longer to complete a program is because of this new software we are using. Our industry is demanding and most of the time customers want things way faster than they used to and having deal with these "minor" issues is a real pain in the butt!

Message 10 of 15
fonsecr
in reply to: kennyWX7Y7

Hi @kennyWX7Y7,

 

I still have the 2D Chamfer work pending. I have postponed it due to some other higher priority features. But we will get to this one also.

 

 


René Fonseca
Software Architect

Message 11 of 15
kennyWX7Y7
in reply to: fonsecr

Thanks for the update! I am using the 2d contour for my chamfer milling as
I found that works with cutter comp. Please let me know when it is fixed.
Message 12 of 15
fonsecr
in reply to: kennyWX7Y7

I will. Have a nice weekend.

 


René Fonseca
Software Architect

Message 13 of 15
slickmilwaukee
in reply to: fonsecr

It's now the middle of May 2020 - is this fix ever going to happen?

Message 14 of 15
DS_P
in reply to: slickmilwaukee

Bump, I spent awhile today before realizing that G41 wasn't posting.  Why is Wear even an option on the passes tab if this won't end up in the Gcode!? 


It really does need to be an option as cutter comp is an industry standard way of dialing in a precise chamfer.

 

The price goes up every year for the professional versions but professional problems never get fixed.

Message 15 of 15
seth.madore
in reply to: DS_P

Sadly, the output of G41 when using the Chamfer toolpath has still not been addressed 😐


Seth Madore
Customer Advocacy Manager - Manufacturing

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report