Communauté
Fusion - Français
Bienvenue sur les forums Fusion (anciennement Fusion 360) d’Autodesk. Partagez vos connaissances, posez des questions, collaborez sur des idées, et explorez les sujets Fusion populaires.
annuler
Affichage des résultats de 
Afficher  uniquement  | Rechercher plutôt 
Vouliez-vous dire : 

Problème avec les réseaux d'extrusions démarrant sur une arrête

3 RÉPONSES 3
RÉSOLU
Répondre
Message 1 sur 4
Hemgé
414 Visites, 3 Réponses

Problème avec les réseaux d'extrusions démarrant sur une arrête

Fusion360, version personnelle 2.0.9719


Constat de départ : une série d'extrusions démarrant sur un coin aboutit à une extrusion unique consolidant la série d'extrusions programmées et leurs espaces intercalaires, soit ici une encoche de 170 mm de long au lieu d'une série de 6 encoches de 20 mm avec 5 intercalaires de 10 mm.

Comportement inattendu. Bogue ?
Lien public : https://a360.co/3ux6tpE


1er composant : Réseau rectangulaire d'extrusions
Création volume 200 x 60 x 20 (esquisse + extrusion) = Composant1
Activation du Composant1 et sur la face avant de ce Composant1 :
Esquisse1 de 20 x 20
Extrusion - couper de ce carré sur 20 mm
Réseau rectangulaire de cette découpe : fonction, espacement de 30, répétition de 6
Résultat : 6 découpes, comme attendu


Esquisse2 de 20 x 20, avec contrainte de coïncidence sur le coin inférieur gauche du Composant1.
Extrusion - couper de cette esquisse sur 20 mm.
Découpe/encoche du coin inférieur gauche, comme attendu

2e composant :
Ligne 1 : réseau rectangulaire d'extrusions, comme pour Composant1
Ligne 2 : découpe du coin, comme supra, et réseau rectangulaire de cette découpe : fonction, espacement de 30, répétition de 6 le long de l'arrête inférieure.
Prévisualisation : crénelage ombré présentant la série attendue d'extrusions, avec l'espacement attendu.

 

codeT8DCX_0-1614360728148.png

 

Après validation, pas de crénelage, mais découpe unique sur la longueur cumulée des créneaux et dents intercalaires

 

codeT8DCX_1-1614360782485.png

 


Exploration complémentaire.
La découpe lors de l'extrusion du coin est-elle imputable au coin ou aux arrêtes du composant (ou encore aux bords de l'esquisse sous-jacente du composant, à explorer) ?
C'est l'arrête/bord qui est en cause : un réseau horizontal et un réseau vertical démarrant respectivement à partir de l'arête gauche et de l'arête inférieure sont d'un seul tenant, sans montants intercalaires.
Les détails de construction ne sont pas (inutilement) répétés.


Un test supplémentaire a été fait et mérite d'être détaillé.
La découpe inférieure du 2e composant s'arrêtant à 170 mm, une série d'extrusions a été démarrée sur un 3e composant à partir de cette distance de 170 mm et étendue a retro vers la bordure gauche, avec les mêmes paramètres que sur le Composant2, mais en inversant le sens d'espacement (-30 mm au lieu de +30 mm).


Résultat : la série d'extrusions est préservée et il subsiste même une paroi virtuelle en bordure gauche.
C'est donc bien l'arrête et non le coin qui est en cause, le coin héritant des propriétés de ses deux constituant.
Le résidu de paroi ne devrait pas être là (test à compléter).

 

 

 

3 RÉPONSES 3
Message 2 sur 4
Caderix
en réponse à: Hemgé

Bonjour, 

 

Essayez de changer les options de calcul dans la fonction réseau. Ici, éviter "Optimiser", préférez "Ajuster"

 

Caderix_0-1614416528557.png

 


Cordialement

Eric GUELEN
Formateur AutoCAD
Site Internet

Message 3 sur 4
patrick.emin
en réponse à: Hemgé

Bonjour @Hemgé 

Si une des réponses résout votre problème ou vous a permis de mieux le comprendre, voulez vous avoir l'amabilité de cliquer sur le bouton  APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Merci de ne pas accepter comme solution le message que vous êtes en train de lire.


Patrick Emin animateur de la communauté francophone


Vous avez trouvé un message utile? Alors donnez un "J'aime" à ce message!
Votre question a eu une réponse satisfaisante? Voulez vous avoir l'amabilité de cliquer sur le bouton
 APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Signez notre Livre d'Or
Message 4 sur 4
Hemgé
en réponse à: Caderix

Effectivement, Ajusté donne le résultat escompté. Du coup, j'ai testé avec Identique qui donne également le résultat attendu.
Il n'y a qu'avec Optimisé que cela ne fonctionne pas. Pas de chance !
Merci.

Vous n'avez pas trouvé ce que vous recherchiez ? Posez une question à la communauté ou partagez vos connaissances.

Publier dans les forums