Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why did you release Fusion Electronics?

19 REPLIES 19
SOLVED
Reply
Message 1 of 20
ESCAPEKIT
1280 Views, 19 Replies

Why did you release Fusion Electronics?

Please, explain it to me. 
WHY would you release something SO BUGGY?
Do you hate your users?
It is completely UNUSABLE. It's not that it has a few annoying bugs or a TON of missing features, it is just plain USELESS. It is even worse than USELESS it works just enough to make you believe you can use it and then you end up wasting ten times more time.
I've spent a few hours routing the PCB I'm working on (it would have been finished days ago if I used Eagle instead of Fusion) and in the process I must have saved at least 3 times. Possibly 4. 
Then out of the blue, Fusion closes. When I open again it turns out Everything I did is lost in the 2D PCB but present in the 3D PCB. I've tried to check the older versions of the 2D PCB but they are all the same.
Pushing to 2d PCB from the 3D PCB doesn't work either.

If you are going to release this BULLS**T at least have the DECENCY of placing a BIG disclaimer letting your users know it is unusable. Now I have a week of work put into a PCB and at least 20 or 30 components created with footprints and packages that I can't move to Eagle because for some stupid reason they are not compatible.
I have two options now:

  • Keep wasting time in trying to finish this PCB in Fusion (and possibly end up scraping it off next week and starting from scratch) 
  • Admit that your incompetence has cost me one week worth of work and start from scratch on Eagle.

I need to use Fusion to create a complex 3D printed enclosure for this PCB so I need all the Packages, and seems like the old Fusion-Eagle workflow is also messed up from what I've seen in other posts.
As a paying client I am seriously disappointed in the team behind this mess. To the point that I'm even considering moving to a free option. What good are all this cool features if they don't work at all?
Please, explain it to me. 
WHY would you release something SO BUGGY?
Do you hate your users?

FUC_THIS_SHlT_A.jpg

 

FUC_THIS_SHlT_B.jpg

 

19 REPLIES 19
Message 2 of 20
Spragnut
in reply to: ESCAPEKIT

I can understand your frustration, I've been experiencing the same issues for weeks now and am disappointed it's taken this long to accept there was an issue and act on it.

 

Something I tried yesterday, so it's still early days..

 

In preferences I set the recovery time interval to 99minutes and turned off "automatic version on close".

 

I managed two successful save and reopens after doing this, which is something I have't managed once yet. I'm not sure if it's linked and it's certainly try at your own risk, but it might be worth a try if you've got a project that needs working on.

Message 3 of 20
ESCAPEKIT
in reply to: Spragnut

Thanks Spragnut,
I'll give it a try!

Message 4 of 20
chris.eganY2EK3
in reply to: ESCAPEKIT

Fully in agreement. We've gone too far into the mentality that it's ok to have users do the bug testing. This integration was clearly not ready for primetime, it should not have been released. Between all the previous problems like having no clear path for migrating over existing eagle designs and libraries, all the problems with 3d packages, and now the problem of entire versions of files literally deleting themselves, how did this get through testing? I've been struggling just with libraries. As I build libraries sometimes it will just delete every single item inside that library and i'll have to roll back 2-5 versions and try again. I'm to the point that I save, close, and re-open the library after adding 1 component just to make sure it hasn't happened and wasted an hour of my life. 

It would be one thing if this was released with a big warning that it was all preliminary, don't lean on it for real work. But it wasn't. It was announced as fully ready to go and even broke the stand alone eagle to fusion linking. Then we were told to go back to standalone eagle, a fix is coming in 9.6 to link things again. 

Message 5 of 20
matt.berggren
in reply to: ESCAPEKIT

Thanks for your post.  To be sure we have seen a few cases where the version of a document has been “resurfaced” as the head revision and thus, it is appearing as data has been lost.  (Which it could be, but we are tracking this down.). 

Have you checked to see if any of the prior versions (each create on Save) in the Data Panel (you will see a small V1, V2, V3, etc next to the file in the panel which you can click to see previous versions) contains the board with its correct routing?  Curious what you find for versions.

 

Apologies you’re experiencing ing the issue...We are (and have been!) working to sort this out.  It’s not been easy to recreate until a few cases earlier this week.  

Thank you!

 

Matt - Autodesk 

Message 6 of 20

I'm going to reply here because I can directly answer. It seems as though the schematic just flat out isn't saving the latest, sometimes. Example this morning, coworker fixed a problem, the last thing he was touching was the board file. He goes to the main design file and hits save to save all, and it creates new versions of the design, board, and 3d model, but not the schematic. Verified in the data panel that new versions were created for each, but the schematic shows the older one and an old save time. If you then close all tabs, the file gets hosed. If you change something minor on the schematic, and save all again, sometimes it works that it creates new versions of all files correctly. Sometimes not though and you have to try that again. 

We've been fighting through this all day. We're to the point that he'll call me and make sure when I open the design file, all parts open without sync errors before he'll close it, just because we've been burned so many times in the last couple days. 

Message 7 of 20
Tbaker25
in reply to: chris.eganY2EK3

I've been running into the exact same issue. Even the preview in the electronics design file shows the latest work, but if you open the SCH it doesn't reflect any of the work since last open.

Message 8 of 20
ESCAPEKIT
in reply to: matt.berggren

Hi Matt,
As I said in my post, the last two or three versions were all the same, none of them had saved the changes made. I don't remember the exact version numbers, but lets say version 10 saved ok and then version 11, 12 and 13 were just copies of version 10 and didn't save the changes. And as Chris said, the thumbnails in the main project window did in fact reflect the changes.
I strongly belief it is a cloud related issue. What I've been doing is everytime I save I wait for all documents to update versions, this can take a long time. For some reason the * marking changes not saved disappears fast, but the version can take a couple of minutes to change. I also export the whole project as a *f3z file once every 45 mintues. It takes anywhere from 5 to 10 minutes but I've checked and they were ok every time.
I have a fairly powerful computer, it is an HP ZBook workstation and even though it is a few years old it has performed great both with Eagle and Fusion 360 but with Fusion Electronics it seems to struggle a bit. Every time I push to 3D it takes a couple of minutes to render. Maybe I have too many packages. I don't want to imagine how slow it would run with a mid range laptop.
Edit: Still no one answered why you released a software THIS buggy. Either you thought it was working ok, in which case you need to improve your testing, or you didn't care and wanted us to be the testers, in which case you need to think again, we are customers, not testers, and most of us rely on the software we use to make a living.

Message 9 of 20
robert_seliger
in reply to: ESCAPEKIT

Eagle + Fusion crashes every few minutes. We can't figure out what the pattern is that causes the crashes so we don't know what to avoid.

 

As others have experienced, we are loosing schematic versions and have to recreate work, sometimes doing the same things two, three or even four times. 

 

This mess is costing my company dearly in terms of the time we are wasting as we desperately try to get a new set of designs to our contract manufacturer before they close due to the pandemic.

 

How does Autodesk plan to compensate those of us who are debugging their code?

 

Robert Seliger, CEO

WHIM Inc.

 

Message 10 of 20

@robert_seliger 

I quickly gave up after blowing a few valuable days thinking F360 electronics would have any usability.
Not sure about everyone else, but I don't have time to volunteer countless hours being an unwitting developer for a huge company like Autodesk.

At the moment, I am not even paying attention to F360 electronics until i can see that they have escaped the 'release random stuff and see if what everyone says on the forum' approach.

The responses I have gotten from my questions and concerns are totally and completely inadequate.

Carlos Acosta
Factory400 - YouTube|Instagram
Message 11 of 20
mrm1018
in reply to: robert_seliger

It should have been released as beta at best.  This is not the Autodesk I grew up with.

Message 12 of 20

Can you please move this to an alternate post as the contents are different than the OPs post and I want to isolate these items.  Thank you!

Message 13 of 20
matt.berggren
in reply to: ESCAPEKIT

Thanks for the reply.  We have a fix for this and are testing it.  The hotfix will come next week.  In the meantime can you explicitly save schematic and PCB documents rather than saving from the electronics design doc.  In investigating the issue, the cascading save and a few related items regressed (not there on release day) related to save being triggered and the electronics design being updated but the save not “taking” or rather, the “requires save” flag being reset when “sister documents” were saving.  Fusion never had this concept of assets quite the way EAGLE had but it is essential and we missed an issue in a recent release.  

 

Regardless, explicit saves of the docs will resolve this but it will be addressed and the fix is already merged and being reviewed.  

Thank you for raising this!  And sorry this is causing you grief!

 

best regards,

 

matt - Autodesk 

Message 14 of 20
kschepens
in reply to: matt.berggren

This reaction just reveals again the unprofessional way Autodesk is dealing with these issues. We are not talking about some bugs here. We are talking about a systematic failure of your team to deliver stable software. Every release new bugs are being introduced. This means there is a very deep error in the way you are developing software. There should be a cultural change!

 

I've worked in software for over 15 years and I know enough that this should NEVER have been released. If you had decently working tests (unit, integration, acceptance etc.), none of these bugs should ever have surfaced. I can imagine there are some software developers in your team that knew about how buggy this was and that it should not have been released. Maybe some manager pressed the team to deliver on a deadline?

 

And sure, I realize that this integration was a huge project that has loads of difficulties. That's always the case when integrating old (and I bet not super well written) software into a new product. I get that and I know how frustrating and slow that process is. But that is absolutely no excuse to just release it without properly testing it and have the users do all the testing for you. 

 

My project has been delayed for weeks because of the Fusion 360 Electronics instability (I switched to Electronics because the Eagle-Fusion 360-link was not working and damaging my files). I even bought a new computer in the hope that it would solve the issues. During the current Corona-crisis, I can't work from home because Fusion 360 is slow and unstable on my MacBook. This is not acceptable.

I've used my valuable time to report numerous bugs on the forums. Time that should have been used to develop my own product, which I often couldn't do. This should have been done by a (IMO very well paid) tester. And remind you: These are not just bugs but actually stop people from doing their work and worse, ruining work they have done, or even worse, bringing products into production that contain errors! Can you imagine the lawsuit Autodesk will get?

 

I really hope someone on a managing level at Autodesk will step in and work on these issues (although you probably now are just putting out fires).

 

I'm really sorry to sound harsh here but to be honest, I've run out of patience with this.

Message 15 of 20
mrm1018
in reply to: kschepens

@kschepens although I don't blame you for being so frustrated and needing to vent, I doubt your message finds the audience you want to hear it through a message board.  You're probably gonna have a pick up a phone and start calling customer service with the hopes you're allowed to speak to someone in a management position.

Message 16 of 20
kschepens
in reply to: mrm1018

You are right. I only wanted to vent.

There are people from Autodesk on this forum that could pick this up. I
feel in no way responsible to spend more time to contact them to solve
this.
Message 17 of 20
jorge_garcia2
in reply to: kschepens

Hi @kschepens,

Don't worry it's been taken up to the appropriate decision makers and they have been following this thread with interest.

I'll keep taken these to management and keeping them aware of what's going on.

Let me know if there's anything else I can do for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 18 of 20

Hi All -

 

Just a quick note to say that we deployed a fix for this (rather unsavory) Save issue.  (Really...bad...pun). Thanks to all of you for helping us understand better what was happening and helping us nail just where this was coming from.  Also want to thank the Fusion QA team and the dev org for jumping in there, working thru the weekend & getting this out the door.

 

No one I know of has ever done an integration of this scale before and to predict the outcome of 100% of the changes / workflows can (at times) prove tricky at best.  With your help & support and the team's efforts here, we promise to find & address anything we didn't catch thru testing.

 

As an aside related to this -- we also addressed a similar "Library Losing Parts" issue which was all bugged up in the same Autosave issue and some noise in the notifications occurring between modules.  (One thing firing while another waited to hear back and so on and so forth.)

 

Please continue to elevate the priority on these items and we will continue to fix them as they come in.

 

Best regards

 

Matt Berggren

Autodesk

Message 19 of 20
ESCAPEKIT
in reply to: matt.berggren

Still no one answered why do we have to do the testing for you? This is costing me a ton of hours (aka money). Who's going to pay for this? Why do you expect me to deal with your mess and report the trillion bugs this code has? Fusion Electronics is a joke. The product I am designing should already be in production and I am nowhere near finishing the design because Fusion keeps messing things up. I am extremely disappointed and looking for alternatives. Of course I won't be able to recommend your software to anyone, quite the contrary.

Message 20 of 20
duncanBC5DV
in reply to: ESCAPEKIT

I would also add that I was excited when Fusion 360 Electronics was launched but I've found it to be unworkable for anything to do with production. I've put about 20 hours in and don't really feel like I've made any progress. I will be moving back to Diptrace and just exporting the STEP file when I want to do mechanical.

 

Here are some of my issues with Fusion360 Electronics that are the most recent issues I had:

 

  • The workflow is convoluted and not properly explained in documentation. It may be more obvious to EAGLE users, but that doesn't help others like me who come from different EDA packages.
  • Commands that should be GUI accessible are hidden in arcane typed menus.
  • The tutorials are half-baked and leave out many critical operations.
  • Footprints and packages aren't linked, so that when I update a footprint, the changes aren't reflected in the package that I created for that footprint, so I have to delete the package and re-draw it apparently (happy to take advice if I'm wrong)
  • Even something as simple as selecting a pad in Footprint and dragging it to move it feels clunky and requires multiple clicks just to actually select it properly.
  • Being forced to work in imperial units. Even when I am given the option of entering a value in metric, it still just auto converts to imperial. For visual consistency and ease of double-checking values, users should be able to choose the measurement system they are familiar with (in case it needs to be mentioned, 95% of the worlds population uses metric)
  • The versioning system is a nightmare. This is actually across all of Fusion 360. Having a model which is v30 and a drawing which is v5 just sows confusion.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report