Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vias renaming does not trigger ratsnest

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
FrankEagle
335 Views, 7 Replies

Vias renaming does not trigger ratsnest

Hi, 

 

the GND copper layer is not recalculated automatically after changing the name of a Via to GND. To trigger a recalculation is necessary to move a bit the Via. 

I don't know if this is related to the fact that the GND polygon has a Rank of 2.

 

To replicate the problem: 

 

1. add a new Via. 

2. select N and click on the Via to name it

3. name it GND 

4. move a bit the Via

 

If you don't see the problem try to set the rank of the GND polygon to 2.

 

Regards

 

 

7 REPLIES 7
Message 2 of 8
jorge_garcia2
in reply to: FrankEagle

Hi @FrankEagle,

 

I hope you're doing well. I've reported this issue, I don't think the rank has anything to do with it. Seems like a graphics update issue.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 3 of 8

Hi @FrankEagle ,

 

So sorry to hear that you're having trouble.

I tried this workflow you mentioned in the latest Fusion Production build 2.0.16485, unfortunately we cannot reproduce this issue by ourselves. The via renaming to GND works well with us and able to connect with the GND polygon automatically.

 

May I know what's the Fusion version you are using?

Do you mind recording the steps or send us a simple test file to have a try? Just leave the via is not renamed, then we will rename it directly to check.

 

Much appreciated.

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 4 of 8

Hi Helen, 

 

I'm using:

Fusion 360 2.0.16486 x86_64 [Native]
macOS 12.4 (21F79) on MacBookPro16,2

 

Please find attached a project file with 2 vias, only one has been renamed to GND, but not moved after renaming and still has the unrouted yellow line. The second via has the default name. 

Note that to create this situation, the renaming must be done as last action, if you rename a via to GND and then add another via, this will trigger the ratsnest. 

 

Regards

Message 5 of 8

Hi @FrankEagle ,

 

Thank you very much for your files!

I could confirm that this is an issue in current Production build 2.0.16486 you are using, so sorry for any inconvenience.

We have a fix in the internal build for this issue and once the fix is ready for you I will keep you be posted as soon as possible.

 

Much appreciated for your report and your time.

Please feel free to let us know if anything needs our assistance.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 6 of 8
FrankEagle
in reply to: FrankEagle

Thank you

Message 7 of 8

Hi @FrankEagle,

 

Hope all is well!

Thank you very much for reporting this issue to us.

Good news that in today's new Fusion version 2.0.16753 this issue has been fixed.

Could you please upgrade to latest version to have a try? Thank you!

 

Hope you have a great day.

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 8 of 8

Hi @HelenChen-ElectronicsQA,

I confirm it works with the latest version.

 

Many thanks

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report