Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Uploaded Eagle libraries are not reconized anymore

12 REPLIES 12
Reply
Message 1 of 13
thijsmoring
360 Views, 12 Replies

Uploaded Eagle libraries are not reconized anymore

I have two accounts. One at work where we do commercial things with a paid account, and a free account for hobby at home.

 

A couple of months ago I imported all my custom eagle libraries into the Assets folder on my work account. This worked fine, I could use them in multiple designs, change them, etc.

Assets folder in work accountAssets folder in work account

 

Today I'm trying to do the same on my personal hobby account. Uploading libraries into the Assets folder. But Fusion won't recognize any of it.

 

I pick my file for upload like this:

1.png

Directly after uploading it looks like a library icon appears on the file:

2.png

But one refresh later its gone:

3.png

The library is nowhere to be found in the library manager:

4.png

 

Am I doing this wrong and was I just lucky it actually worked a couple of months ago? Or does this only work on a paid account?

 

Bonus question, if I ever get this working, how do I share libraries between both accounts? I don't feel like making the same changes twice when editing a library.

12 REPLIES 12
Message 2 of 13
Taylor.Chris
in reply to: thijsmoring

Hi @thijsmoring ,
can you try and import the library into the library manager using the button in the top right?  You should see an option to "import from Fusion team", then you should see the library in your manager.
(Ideally these libraries import automatically, but sometimes they get missed.  If the libraries still don't show, then let me know and I will walk you through clearing the cache)

The easiest way to share between two accounts is to invite both accounts to be members of a shared team.  If you need to share content between two teams, that functionality is more limited, but you can link libraries between teams by using library.io.  [First open the library, then in the manage toolbar section choose push to library.io.  Then switch to the second team, find the library.io library in the manager, then edit it.  This will copy the library into your second team, and then you can use the push/pull actions to keep them in sync].

Message 3 of 13
thijsmoring
in reply to: thijsmoring

Hi @Taylor.Chris,

 

I've tried importing the libraries, but the files are simply not recognized as libraries. They don't show up in import windows of the library manager.

 

6.png

 

As you can see I can't even pick the Assets folder in the import library window (while it's for libraries?). I've uploaded a library straight into my project, but it's still not recognized as such and can't be picked in the import window.

Message 4 of 13
thijsmoring
in reply to: thijsmoring

I've just tried uploading a library on my paid account, and it works just fine. During the upload an extra icon is displayed, and after uploading the library is recognized as  such and I can open it.

 

2024-03-11_11-05-06.png2024-03-11_11-06-44.png

 

Does this mean this function is getting paywalled? That would make it impossible for hobbyist to migrate from Eagle to Fusion.

Message 5 of 13
taylorachris
in reply to: thijsmoring

I don't think that this should require a paid account, it might be a bug in the free tier that has gone unnoticed.  I'll ask around and get back to you.

Message 6 of 13
Taylor.Chris
in reply to: thijsmoring

A couple of quick questions:
1. What happens when you try to open one of the incorrectly uploaded libraries?
2. Are you able to successfully upload other file types (like board / schematic)?

Message 7 of 13
AlinaPeng
in reply to: thijsmoring

Hi @thijsmoring 

 

Hobby accounts appear to have some restrictions, particularly with file uploads which are not automatically translated. As an alternative solution, I suggest you try opening the library file directly in Fusion and save it from there.

 

Best Regards,

 



Alina Peng
SQA Engineer
Message 8 of 13
thijsmoring
in reply to: Taylor.Chris

Hi @Taylor.Chris,

 

1. There is no Open option on the file.

8.png

 

2. Good question. I've tried uploading a board and schematic, and it's recognized as such. During upload an additial window appears, and after upload I've got a working electronics project with forwards & backwards annotation.

 

Uploading a board, schematic & library file at the same time results in the same result as uploading them seperately. Uploading a library in the web interface also gives the same result.

Message 9 of 13
thijsmoring
in reply to: AlinaPeng

Hi @AlinaPeng,

 

Thanks for the suggestion. I've tried it and the library is recognized correctly. It's a bit of extra work to upload my initial libraries, but it works.

 

And while I can only save a library in a project in the program, in the web interface I can move the library to the Assets folder without a problem.

Message 10 of 13
Taylor.Chris
in reply to: thijsmoring

Looks like @AlinaPeng found the answer and unfortunately it is the result of a restriction on the free accounts.
We appreciate that you brought this to our attention, and we are discussing it internally.
I do think we should be able to work around it using library.io though. 
What you will need to do is create a managed folder on library.io, invite both accounts to the managed folder, then push the Fusion libraries to library.io.  Then your free account should be able to open them, which will migrate them into it's team.

(And the extra benefit of this approach is you will be able to keep the libraries in sync, rather than having to make every change twice)

Message 11 of 13
Taylor.Chris
in reply to: thijsmoring

Hi @thijsmoring, here is the steps to link two Fusion libraries in different teams using library.io:

Use this button to push the library to library.io (it will ask what folder to push to)

Screenshot 2024-03-12 103605.png


Then in the library.io site, you can invite your other account to become a member of the folder here:

Screenshot 2024-03-12 103649.png



Then using the second account, hit "restore all library.io libraries" in the library manager:

Screenshot 2024-03-12 104809.png
Then you should see those newly pushed library.io libraries in your library manager.  Double click (or edit) these libraries and they will migrate into the second account's team. 

By doing it this way, the two Fusion libraries will be "linked" to the library.io library.  After making changes, you can push those changes using the same button you used to create it (blue up arrow), switch to the other team, and use the "Pull" button to keep the libraries in sync (blue down arrow).

Message 12 of 13

Hi @Taylor.Chris,

 

Thanks for the detailed instructions. I've given my work account access to my personal account on libray.io, and uploaded the libraries to my personal account. I've been working with these for over 15 years in my own time and adding to them once in a while, and now I started to create some little projects at work I wanted to take advantage of that.

This worked for most of the libaries, but some did not appear in Fusion. I had to manually push a new version from Fusion the way you described it. In the end it works, and I can access all libraries from both accounts.

 

Oh, don't put both opening and closing brackets together in the name of a managed folder on library.io. You're allowed to, but the whole site stops working. I'm using the latest version of Firefox.

 

On that note, it's been a bit of a fight to find all the functions again. I haven't build anything for the past 5 years, and since Eagle is stopping I thought now was a good time to migrate. I like some new functions and the fact that I can access it from multiple PC's, I dislike the lost functionality. At times it even feels like I'm beta testing the software.

As I try to migrate there will be probably a couple more posts here. Like about the custom shortcuts which have suddenly stopped working.

Message 13 of 13
Taylor.Chris
in reply to: thijsmoring

Hey @thijs.moering 
Unfortunately, things like custom shortcuts can be a challenge to negotiate with the rest of Fusion, but we hope that the added benefit will be worth it once you get the hang of things.  We have done our best to make sure that we have not lost functionality so if you find an issue or can't find something feel free to reach out here.  We welcome all feedback.  

I'll make a ticket about the folder name issue.  About the beta testing, I understand; we certainly suffered from some instability in order to get Fusion and Eagle working together by given deadlines.  Recently though the stability and usability has been our highest focus, we want to get everything bug free and we have come a long way (but still have a lot more to do).  Any time you can report specific bugs to us that really helps.

Working with the library system is still a bit awkward too, as you just experienced with this workflow case.  We do however have a solid plan for how to simplify it all and make situations like what you just experienced much more straightforward.  The transition had some challenges, but currently our priorities are in the right place and the software will only continue to improve.  We appreciate the patience, please reach out anytime.
Thanks,
Chris


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums