Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

'This version of package 3d file might have no 3d model'

3 REPLIES 3
Reply
Message 1 of 4
purchasingC6FDE
223 Views, 3 Replies

'This version of package 3d file might have no 3d model'

Hello everybody,

I have a similar problem to already existing issues in the forum, but was not able to solve it with the proposed solutions. 
My issue is as follows:

I used a certain library (locally) with my old Eagle environment and want to use the same library in Fusion 360, so i imported the library and saved it in Teams. This library does not yet have any 3D components saved. So I started editing the library by clicking on the Footprint of component 1 and adding a new 3D model. It opens up a new window with the existing footprint. I have also saved two .stp files for component 1 and component 2 into a Teams folder and inserted the .stp file for component 1 into the new window with the footprint in it. I adjusted the positioning and saved it. I did the same process with component 2. Then I created a new electronic design and tried adding the parts. First bug I noticed, is that it does not show a preview of the 3D-model in the 'ADD' window (picture).

Component.png

And it shows Version 1 + Edits in the description.

 

Adding only one component into the schematic and making the 3D-PCB out of it works fine, and both components can be individually displayed. But adding both components into the same schematic and then trying to make the 3D-PCB gives me following warning (picture).

3D-View.png

 

I do not know how to fix this or where the problem lies. 

 

PS: The 2D-PDB was extracted from a sketch in a 3D-Model of a enclosure, not sure if this has anything to do with that.

 

Greetings,

Samuel

Labels (4)
3 REPLIES 3
Message 2 of 4

PS: I did also delete the library locally and only have it on Teams anymore, also not sure if that has any effect on the matter.

Message 3 of 4

Hi @purchasingC6FDE ,

 

Sorry to hear that you're having trouble.

Our development team is able to reproduce this no 3d model issue and we are investigating it.

Will keep you be posted if we have a fix.

 

Currently you could upload the 3D model twice one by one to Fusion, and then create libraries by using the two 3D models in each library separately as workaround. But not inserting the same 3D model to create the 3D package for different libraries. 

 

Hope it helps a little bit.

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 4 of 4

Hi @purchasingC6FDE ,

 

Hope all is well.

 

Good news!

Today Fusion 360 just released an update with version 2.0.9313, which has a fix about the issue you reported about missing 3D model when viewing 3D PCB.

Could you please try to view 3D PCB again and see whether the issue is fixed or not? 

 

Looking forward to hearing from you.

Thank you.

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums