Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Strange Gerber output - large circular drill at origin

7 REPLIES 7
Reply
Message 1 of 8
LloydTravisSmith
185 Views, 7 Replies

Strange Gerber output - large circular drill at origin

Hello, all. I have been revising an existing design that I had fabbed successfully before, but this time when I output Gerbers I see one large circle centered at the origin that overlaps almost the entire board. I checked in both the DigiKey DKRed viewer and the PCBWay viewer and I see the same thing in both. There are four layers named drill in this screenshot and the large circle at the origin exists in two of them.  

 

LloydTravisSmith_0-1641235713716.png

In the screenshots below from Digikey's DKRed Gerber upload service, there is another odd characteristic. It appears that the scale of the majority of the board layout is presented in a small area behind the circular drill, but an additional drill_1_16.txt entry is presented at 10x scale:

 

LloydTravisSmith_1-1641236165435.png

LloydTravisSmith_2-1641236222344.png

I inspected the contents of the various layers of my design and did not see anything that would account for the problem. 

 

Would you give me some feedback as to what I may be doing wrong?

 

7 REPLIES 7
Message 2 of 8

I reviewed some other posts in the forum and tried exporting to Eagle to produce CAM output, but that produced exactly the same result. I also investigated the placement of the M71 entry in the drill file, and moving that up near the top did not change the result.

Message 3 of 8

Just a couple of additional points. Manufacturing > CAM Preview looks perfect.  I do not see the mismatched scale issue in the preview, and there are no unexpected circular features at the origin. I have been using Gerber output type Gerber RS-274X as this seems to be the default. I tried Gerber X2 to see if it would change anything, but it produces basically the same result.

Message 4 of 8

I exported the board to Eagle, then exported Gerbers from there. The result is similar to what I saw when I exported from Fusion360. The profile.gbr and drill_1_16.xln layers are scaled about 10x the size of the top and bottom Copper and soldermask layers. In a section entitled Other, there is a layer called PnP_<boardname>_front.txt that contains a large circle at the origin and it has been labeled as Drill File. An error is displayed: "Warning Non-Critical File(s) have been labeled twice: Drill File." So there seem to be two problems. 1) Text from somewhere is being exported to a txt file and it is interpreted as a drill file, but should not be. 2) The scales of the drill file and profile do not match the scales of the other Gerber layers. Would someone be able to provide some insight on how I can correct this? 

Message 5 of 8

I created a Windows environment variable to ensure that "." is used to indicate decimal places, then rebooted and restarted Fusion360. I can see now that the PnP files are being interpreted as drill files, so I should be able to remove those from the batch to avoid that problem. I still have the problems that the scales of profile.gbr and drill_1_16.xln are about 10x the scale of the soldermask and silkscreen layers. Any advice on how to correct this would be appreciated.  

Message 6 of 8

Looking at the PCB layout of two boards in Fusion360, I noticed that in the Inspector panel under Board Information, the board that is giving me trouble has Width and Height in mm,

 

LloydTravisSmith_0-1641322824293.png

 

but a previous board from which I had no Gerber export problems, the Width is in mil, but Height is in mm. 

 

LloydTravisSmith_1-1641322876824.png

 

These boards are the same size except for any parts that may extend beyond the PCB edge.

 

I don't see a way to edit the Board Information directly, but I wonder whether the mm units for Board Width are at the root of the Gerber export problem.

 

Again, any feedback would be welcome.

 

Message 7 of 8

Hi @LloydTravisSmith ,

 

I hope you're doing well. Could you specifically detail how you are generating the gerbers? It seems like there maybe an issue in your CAM processor setup. What do you get if you run the one-click CAM? Try that and let me know how the resulting gerbers look.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 8 of 8

Thanks, Jorge. I am selecting Manufacturing > Export Gerber... I have tried tweaking some other settings, but only after this simple method failed, because this is the method I have been using with success up to now, including with a previous revision of this same board.  

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report