Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Slow performance, crashing

21 REPLIES 21
SOLVED
Reply
Message 1 of 22
grahamKB84N
710 Views, 21 Replies

Slow performance, crashing

Fusion 360 electronics is painfully slow on my PC, which is a high-end Mac, 32GB RAM, i9 etc. Even after clearing cache and restarting Fusion 360, there's low frame rate, zooming in/out lags badly, components lag behind the cursor when moving them, there's a lag between clicking and selecting, and a major lag between switching tabs, especially when both electronics and 3D CAD models. PC fans going continually. The designs are not complicated and there are not many components. This issue basically halves efficiency.

 

To add insult to injury, I still get crash reports multiple times per HOUR. If Autodesk intents this to be a serious tool, then these issues needs to be resolved ASAP. 

 

See screen capture below on performance.

https://www.loom.com/share/87abc1dbc23d4546a4c945eb25a79b82

 

Eagle does not have issues like this - responsiveness is MUCH better. Any advice would be appreciated.

21 REPLIES 21
Message 2 of 22
jesper8W75R
in reply to: grahamKB84N

Welcome to the wonderful world of crappy computing.
Sadly, Autodesk seems to be completely ignorant of these issues, that multiple people, including myself, have reported.
I had 70 error reports/support cases.
I still have lots of issues with Fusion, but have given up completely on reporting them as almost nothing happens.
New releases are coming out with new bugs and even slower performance.
This is a tool going down the drain.
I've even resorted to use EAGLE for my PCB work, it's fast, doesn't crash and does the job.
As any tool should do.
Fusion is certainly not in that category.

 

Message 3 of 22
grahamKB84N
in reply to: grahamKB84N

I'm stuck right now. Performance is too slow on Fusion 360 Electronics, but I cannot get Eagle Premium to work due to licensing issues that customer support has still failed to solve. My only other option is to move to KiCAD which I will be forced to do if Autodesk does not assist. 

Message 4 of 22
furaTT4KY
in reply to: grahamKB84N

Can any of the employees comment on this? It's a terrible job.. @HelenChen-ElectronicsQA @annaka.ketterer @jorge_garcia2

Message 5 of 22
sh9WZ6F
in reply to: grahamKB84N

Problems here too.

 

I cant open Libraries to edit them.

I get an instant crash if I try to upload a Library.

Crashes every couple of steps when editing Boards or Schematics.

I had 30 Crashes in 4h Today... I'm done...

Message 6 of 22
jorge_garcia2
in reply to: grahamKB84N

Hello Everyone,

 

Let's explore these issues. Sorry for the delay in responding, I've been pulled into another project and that's been taking up the majority of my time as of late.

 

@grahamKB84N , Thanks for posting the video. I know responsiveness on EAGLE is better, but the video seems to show about 1-1.5 sec delay as you rotate the cursor. It's not good but it doesn't seem like it would be a showstopper. Maybe the screencast makes it look better than it is. What licensing issues are you running into, let's see if we can get that sorted first so that you can get your work done. We are working on the graphics performance improvements but those have not been released yet.

@sh9WZ6F I hope you're well. Are you seeing this with all of your designs or only a specific design? If you try uploading different libraries do they all behave the same? The reason I ask is to see if we can isolate the issue to a specific file. If we can do that then I can pass the file to the developers so that they can reproduce the behavior and fix it.

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 7 of 22
grahamKB84N
in reply to: grahamKB84N

@jorge_garcia2 I'm on a startup license, which customer support confirmed provides access to premium Eagle, but on signing it, it defaults to free version. 

Message 8 of 22
furaTT4KY
in reply to: grahamKB84N

@jorge_garcia2

That video is exactly how Fusion behaves in our company (multiple PCs, many different projects). It's really bad. You can't wait 1-1.5 seconds for each operation... can you imagine how long development takes and how much money it costs?

 

I confirm that some time ago the performance was improved, especially the work with the Data Panel. But normal development work remained tragically slow.

 

 

What is the recommended computer hardware configuration to make the Fusion as fast as the old eagle?

 
Message 9 of 22

Hi @furaTT4KY@grahamKB84N,

 

For the performance issue you are facing, I'd suggest you try to drag the schematic and board file window out of the Fusion main window, which should have better performance.

We noticed for few specified laptops which have dual graphic card (related to hardware) have performance delay when moving assets that our developer is working on closely. We will keep you be posted once we have any update about this.

Sorry for any inconvenience and thank you very much for your understanding.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 10 of 22

Thank you @HelenChen-ElectronicsQA for your message. I'd like to notice that my laptop has CPU AMD Ryzen 7 PRO 4750U with Radeon Graphics on the same chip (GPU is a part of CPU). I don't think my computer has a dual graphics card.

 

My laptop is Lenovo Thinkpad T14 gen1.

Message 11 of 22
grahamKB84N
in reply to: grahamKB84N

@HelenChen-ElectronicsQA this is exactly the situation - dual graphics card. Specifically I am using:

  • Mac OS 11.6.8
  • 2.3 GHz 8-Core Intel Core i9

  • GC 1: Radeon Pro 5500M
  • GC 2: Intel UHD 630

Dragging the schematic out of the main window does not help in my case. 

 

@furaTT4KY I tried installing on a Windows i7 NUC, 32GB RAM + SSD, Intel Iris 655, which is less powerful than my Mac. Performance is MUCH better, which is frustrating because it's not my primary workstation. I'd recommended buying a couple Intel NUCs for your team if you plan to stick with Autodesk. 

Message 12 of 22
silvio3105
in reply to: jorge_garcia2

Will community get decent replace while you're off F3E project?
Message 13 of 22
sh9WZ6F
in reply to: jorge_garcia2

Hi,

the crashing issue when uploading was on all kind if different files. I tested different .step ans .lib files.

 

But this issue is resolved till the update I could install yesterday morning. Till then the integrated eagle is working fine again.

 

 

Thank you!

Message 14 of 22

@HelenChen-ElectronicsQA @jorge_garcia2 

I've heard those ideas to a solution before.

And, as before they don't do ANY difference. At least not on my machine (Imac 27", 4GHz I7, 32MB RAM, 

Radeon R9 M395X).

 

I think you don't (despite my videos and other docs) really understand how insanely slow Fusion is, on a medium/large board.


It is close to unusable. Several second delay to connect a track is NOT acceptable.
When I do the same in EAGLE, that process is INSTANTANEOUS.
I have gone back to doing a lot of work in EAGLE 7.7.
Takes me a fraction of the time to do a board in EAGLE, compared to Fusion.

It is mind-boggling how I can run HUGE 3D worlds or games with incredible graphics, all at 50-60 fps.
But, I can't even route a track on a SIMPLE 2D application, in less than a second.

I know Matt is going to tell us he have the best dev team ever and can route a billion tracks in a millisecond.
I don't give a *.
I can not!

You NEED to do something about this, it's ridiculous how you keep brushing the problems away.

 

 

 

 

Message 15 of 22

Hello @grahamKB84N and dear all,

 

Thank you all very much for feedback, we take this performance issue as priority.

 

So far for the issue about dual graphic card on Windows OS laptop, we could reproduce and our development team is working on it.

For the issue you met on Mac OS, I noticed on @grahamKB84N your machine,  the panels are opened, do you mind collapse all the panels and then drag the schematic and board file out of the main window to move the asset again?

 

And for the crash issues you mentioned, do you mind share any crash report ID to me to have a check? Or could you please send private message to me with your email address of Fusion account? 

 

We will keep you all updated once we have any update.

Sorry for any inconvenience and thank you very much for your understanding and patient.

 

Hope you all have a great day.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 16 of 22
grahamKB84N
in reply to: grahamKB84N

@HelenChen-ElectronicsQA after following your instructions, the performance seems to get even worse after dragging schematic and board files out of the main window. Noticeably worse frame rate and lag. 

 

Please see my email on crash reports.

Message 17 of 22

Hi @grahamKB84N,

 

Thank you so much for your email with more information and noticed your Macbook connected with 5K monitor.

I just replied with your email, please kindly have a look.

 

Thank you!

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 18 of 22

Dear Fusion Team,


I have a computer with this specification: Lenovo T15 Gen1, inteli7-10850@2.7GHz, 32Gbytes of RAM, NVIDIA GeForce RTX Super). I updated the driver of my video card to the latest one. I even modified the windows parameters to give priority to performances (So I have a really dirty display render now). 

 

Given that could you please explain me technically why fusion is so slow compare to Eagle?

 

My company pay for Fusion360. I'm really sorry, I do not want to hurt anybody, but Fusion is not working as a professional software should do. I was using Eagle until now but now I need to switch to fusion and it's really hard (to not say impossible sometimes) to work with because of its poor responsiveness.

 

Please do something for that. I hope this is your number1 priority for now.

Message 19 of 22
jorge_garcia2
in reply to: grahamKB84N

Hi @sebastienN38NE,

 

Thank you for your feedback. Performance is one of our top priorities right now and we are working on it.

 

Thanks again.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 20 of 22

Dear all,

 

I'd like to share with you a great news that today there is a new Fusion version 2.0.14567 published, and we have put an improvement about the performance issue you reported in this new version. 

Could you please kindly upgrade to latest version to have a try? 

 

Hope it works for you and hope you have a great day!

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums