Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Schematic-PCB sync does nothing!

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
silvio3105
216 Views, 10 Replies

Schematic-PCB sync does nothing!

Hi,

I did next - I made PCB from schematic v10, then I realized PCB components are mirrored, I' deleted traced and again routed PCB. Then I realized I was wrong(lol!) and to save some time(big mistake!) I opened old version of PCB and saved it as latest. In meantime I changed few things on schematic side. Now schematic are newer than PCB and sync seems not working since laste update(vacation? not sure, never had to use sync but I guess as always, last update ****ed up few important things).

 

As always from me - here's video.

https://youtu.be/xfcCp85zByg

Enjoy!

 

10 REPLIES 10
Message 2 of 11
silvio3105
in reply to: silvio3105

Sync does not work after deleting all traces not all components.

Pretty bad!

My luck that PCB does not have a lot of traces and components.

Really bad for AutoDesk!!!!

Message 3 of 11
silvio3105
in reply to: silvio3105

Here's one more video about this really big problem.
https://youtu.be/_VnFUrnbh6Q

Where I can send my CV for tester?

Message 4 of 11
silvio3105
in reply to: silvio3105

I see this i 2D PCB workspace

 

SilvioCro_0-1664221465958.png

 

 

I'm not sure how to change variant in 2D PCB.

Workflow is really weird in F3E.

 

@@EDIT:

Okey, as far I get (weird) workflow - If, before pushing schematic to 2D PCB, some other variant is selected(other than default '' variant) then PCB will be fixed to that vairant and I cannot change it (later).

But, to use sync, both PCB and schematic have to be on default variant.

🤦‍:male_sign:

Message 5 of 11
silvio3105
in reply to: silvio3105

And you someone suggest - delete PCB and try again - I cannot. 

Why?


PCB file is linked with 3D model(of PCB). I cannot delete 3D model because file is linked with PCB. I cannot delete PCB file because it's linked with nothing. So you actually have (after some time) bunch of "dead" files which reminds you why you should not have choosen Fusion for main SW.

 

I'm using Fusion for DIY projects so it's not SW I use at job(I'm embedded dev). If I(as DIY user) have large amount of bitterness/angriness/rage to Fusion because of those little bugs that are around for too long, how much of bitterness/angriness/rage have people which use Fusion as SW for making $$$ for living (and paying for it)???

 

This "unable to delete"/"non existing ref" exists for two, three years(?) and it's not only bug in F3E, it's bug in whole Fusion and it's not fixed, yet!!!

I really like(ed) Fusion because it has nice UI(compared to CATIA and SolidWorks - I started with 3D modeling in Fusion so that's the reason why I'm mentioning 3D modeling SWs), but that file managment if really annoying and pain in the ass. Lol, to open STEP file I have to upload it and then open it(upload takes 30-60s).

I hope I will me able to export my own libs to EAGLE(and hopefully keep my 3D models in lib) because I'm scared how much time I will lose if I encount similar problems with large projects. That's reason why I'm thinking about moving to EAGLE 9.6.2 or KiCAD 6. I don't have time to waste by fixing PCBs and other problems because Fusion has weird workflow and it's buggy.

 

F3E has potential but it really need weekly bug fixes. Last update(09/2022) did not bring any bugfixes(acording to changelog). Leave all feature requests aside and fix all little bugs qucik, otherwise this looks like a cat chasing it's tail - one update brings bugfixes, one brings new features and new bugs without fixing old ones. It's bug net positive.

 

And with all problems F3E has, some guy decided to move Product Manager to another project(maybe standarlone EAGLE v2) and leave F3E in mess. Am I only one who noticed reduced anwsers after @jorge_garcia2 has been moved to another project?

 

I hope Jorge will answer to this post.

That's from me tonight.

Message 6 of 11
silvio3105
in reply to: silvio3105

Re-link with project helped.

But, that's not a solution, Autodesk!

Message 7 of 11
jorge_garcia2
in reply to: silvio3105

Hi @silvio3105,

 

I hope this message finds you well. There is a lot to unpack here. Reading through the posts where things went wrong is when you saved a previous version of the board as latest but didn't do the same thing with the schematic. I know there is no way you could have known to do that but it highlights a bad workflow that needs to be improved. Restoring previous versions of a design is currently very error prone.  If that would have been simpler you would have never needed to use the synchronizer and get into the situation you are currently in.

 

You may have already moved on from this issue, but if you haven't you can get that older version of the board do save as latest, then get the same version of the schematic and do save as latest there. Make sure to save the Electronics design file so that it recognizes the new versions of the schematic and board then you can move forward from there.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 8 of 11
silvio3105
in reply to: jorge_garcia2

That's why sync exists? Why it does not help then?
Reason why I go back with version is because of component placments. All components are same, only footprints are different(that is why I altered schematics).

 

 

Also, I hope I will get some type of answer to problems with bidirectional infinite links between files.

That thing needs rework asap.

Message 9 of 11
jorge_garcia2
in reply to: silvio3105

Hi @silvio3105 ,

 

The bidirectional infinite links thing is a general Fusion thing so the electronics team can't do much there.

 

It just so happens that you and Matt have been running into a similar issues with the synchronizer which is prompting that code to be revisited to get these issues addressed.

 

I already have this thread on our teams radar so this feedback will help.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 10 of 11
silvio3105
in reply to: jorge_garcia2

Who can do something about infinite links?
Message 11 of 11
jorge_garcia2
in reply to: silvio3105

Hi @silvio3105,

 

I would post that to the general Fusion 360 forum. If you do a search you'll probably find that others have been complaining about that for some time. Add your voice to the mix. From what I've been told this is something the team wants to be addressed but there are a lot of moving parts to get that sorted.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report