Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Routing is not using width of net class

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
infinitemach
366 Views, 6 Replies

Routing is not using width of net class

I defined a net class rule with a width of 0.254mm. When I start routing a net of that class my expectation is that the width of the wire the routing is producing will change to that class width. This is not happening. Instead, I have to manually change the trace width to match the class width of the net.

6 REPLIES 6
Message 2 of 7
mtl.asm
in reply to: infinitemach

afaik the way it works is that the trace width will be the net class defined width or the selected route width, whichever is MORE. So if you have a width of .3mm selected then route a net that belongs to a class that has a width of .254mm defined, it will stay .3mm.

 

alternatively if you have .2mm trace width selected in route, then click on a net belonging to a class with width .254mm defined, then it will change the width to .254mm.

 

i agree with you that you would expect it take the width defined by the class as default, but this is not the case. it takes the max of the 2 values.   

 

 

Message 3 of 7

Hi @infinitemach,

 

Go into Preferences > Electronics > Misc and make sure that Auto Set Route Width and Drill is checked. Then it will behave as you expect.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 4 of 7

Thank you, that setting worked. Seems like this should be the default behavior.

Message 5 of 7
lkhamad10
in reply to: jorge_garcia2

When I use manual routing, even setting MIcs to auto is not working, is that expected? It only respects net classes in the autorouting.

Message 6 of 7

Hi @lkhamad10,

 

I hope you're doing well. Remember that netclasses only define a minimum, you can make traces larger than that minimum. Additionally if you set the DRC min width to be larger than what is in your netclasses, then the netclass value will never be used.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 7 of 7
jm.wagenaar
in reply to: infinitemach

I would (and did) expect routing to always start with the netclass width (or maybe the DRC minimum width if that is more, debatable). Then during routing the width can be changed for the segments now being routed with a width from the menu. Once routing stops new routing would again start from the netclass. 
Editing existing traces should start with the current width of that segment (the current shift-route option)

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report