Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PTH-Pad won't connect to Polygon

8 REPLIES 8
SOLVED
Reply
Message 1 of 9
till.kettner
252 Views, 8 Replies

PTH-Pad won't connect to Polygon

3637689546357895.PNG

Problem:

I created my own custom parts, because i need exact these "special" parts for my PCB. So i created everything on my own and now i have the problem that the PTH-Pads of my custom parts won't connect to the polygon i want to use.

All footprint of the custom parts have active thermals option and i tried also everything with the net_classes. To change the PCB rules also changed anything as you can see in the pictures.

The reason why i want to use the polygon is that i have to transport a high amperage over it.

673456787567854.PNG

 

567532467896754.PNG

 

Question:

Is there any reason why the polygon won't create thermals to the PTH-Pads even if they are in the same net_class?

Or am i do something completely wrong?

8 REPLIES 8
Message 2 of 9
jesper8W75R
in reply to: till.kettner

If you design in your polygon in the footprint, you wont get thermals.

Screen Shot 2021-08-10 at 18.31.26.png

If you add the polygon later, in the board editor, you can have thermals (give everything the same net name).

Screen Shot 2021-08-10 at 18.32.10.png

It's a shame it cannot be done in the footprint, as it would be nice to have everything as ONE finished part.


Message 3 of 9
till.kettner
in reply to: jesper8W75R

First thank you, for your reply. 🙂
I added the polygon not to the footprint but to the PCB-Sketch. So the footprint does not contain any polygon.
I tried everthing with the net_class but the results looked like the pictures above.
Airwires and polygon were in the same net_class.
I searched a long time to figure out if i set wrong settings or something like that, but all tutorials and videos i found tell me the same things i did/tried. 😞
Message 4 of 9
jesper8W75R
in reply to: till.kettner

You need to connect all your pads and the polygon to the net, otherwise they will not connect.
Connect the pads in the schematic and use the NAME command in PCB to connect poly and pads.
You can also connect all the pads together in the footprint. That might be easier. Then you'll just have ONE pin to connect to in the schematic.

Edit:
Sorry.
I was making a screencast for you, but the ****ty Fusion locked up and crashed. Again.
This frigging toy program really pisses me off.

Message 5 of 9
till.kettner
in reply to: jesper8W75R

I am sorry to here that. The integrated Eagle version is not really stable. It crashed serval times at my own and ruined some work i did.
Thank you any way i added the polygon to the footprint again and tried to connect them like you said. It is a workaround, but with the traces i can connect both parts. I don't know at this moment if i can use this way practically.
I hope they will improve this Eagle version these bugs are very annoying.

Thanks again for your time and reply! 🙂

Message 6 of 9
jesper8W75R
in reply to: till.kettner

It is not a workaround, it's how it's supposed to work and how it's always been.
If you want to use the "features" of a polygon like thermals, isolation, rank e.t.c., you HAVE to add it in the PCB editor, where the DRC rules will be applied. You cannot do that in the footprint.
The polygon, in footprints, is mostly used for making complex footprints.
No need to draw any traces if you do it this way, it will all be automatically connected.

Message 7 of 9

Hi

we had a working layout of a circuit board, but somehow its not working anymore.
As you see in the picture some pads are/arent connected over a Thermal with the polygon. So we have a ton of airwires.  
We didnt change anything of the routing or the polygon, so we think its a probelm of the newest Eagle Version?!? 
We really need some help. 

Cheers Timo
1.png2.png3.png

4.png5.png

Cheers Timo

Message 8 of 9
PW_VOX
in reply to: till.kettner

There is a secret feature in the Via command which may help you.

Essentially you start the via command and then enter the name of the net that you want the via on in single quotes, for example 'GND', in the command line.  Then you find that the via contiguous with the polygon pour when you place the via. 

 

Message 9 of 9

Hi PW_VOX,

i dont think, that its a problem with the vias. Its defently a problem with the thermals function. 
If you turn off the thermals function, everything gets connected fine. See pictures

 6.png

Thermals Off7.pngThermals On

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums