Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Nets move in weird ways when dragging group

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
pstormarkG9SGY
182 Views, 4 Replies

Nets move in weird ways when dragging group

I'm experiencing annoying issues when dragging groups (and components in general) in the schematics. Certain parts of the nets seem to be "stuck" and don't move along with the components. The origin of the problem might be the way new nets don't merge with others when drawing them, but that's only a speculation from my side.

 

Before drag:

 

Before drag.PNG

 

After drag up:

After drag up.PNG

 

This happens all the time. I drew multiple nets to an IC, and everything went out the window when trying to reposition.

 

As it seems like there was some overlap of the particular net on the screenshot, I tried redrawing it and moved the group down. I ended up with this:

 

After redraw.PNG

 

Am I doing something wrong when drawing nets or is this intended, annoying behaviour?

4 REPLIES 4
Message 2 of 5
panpan_fan
in reply to: pstormarkG9SGY

Hi @pstormarkG9SGY 

I hope you are doing well!

I have a quick try for the Move Group workflow and it works well for me.

I guess the reason is that some objects are not on your group.

Would you mind Ungrouping them and grouping them again?

If it still doesn't work, you can send me your file.

I will send my email address to you as a private message.

 

Regards,

Panpan Fan

Message 3 of 5
pstormarkG9SGY
in reply to: panpan_fan

You're correct. That particular issue went away, but I'm still having weird net behaviour when moving components not related to groups as well. 

 

Before.PNG

After drag down:

After.PNG

Why doesn't Fusion simply shorten the net instead? This doesn't look good.

 

Message 4 of 5
panpan_fan
in reply to: pstormarkG9SGY

Hi @pstormarkG9SGY 

For the new issue you mention, I think we can do some improvement.

I will report it to the develop team.

If I get more information, I will keep you updated.

 

Regards,

Panpan Fan

Message 5 of 5
pstormarkG9SGY
in reply to: panpan_fan

Amazing! I'm glad to hear. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums