Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

More library issues

12 REPLIES 12
Reply
Message 1 of 13
adrian.carpenter
380 Views, 12 Replies

More library issues

Jorge kindly pointed me in the correct direction on how to do various things, and I'm now a lot more understanding of the "way" that fusion electronics currently behaves.

 

But, I've ended up with a slight mess where stuff was all over the place and I didn't know what was current, what wasn't and just a real all round mess.

 

I've moved my libraries into their own project, although currently, only the latest revision of my project uses the libraries from the correct place, those libraries have the fusion 3D model projects stored in a sub folder below where the libraries are and it's how Jorge has recommended stuff be laid out.

 

All good so far, I know where I went wrong, and going forward things will be a lot easier.

 

I went through the library manager, and removed all of the duplicate libraries that are referenced in other earlier revisions (each revision has a clean copy in a totally different folder of the previous version which is then modified) and now all I see in the library manager in the current revisions "in use" page is the list of my current libraries, no other third party libraries are used.

 

All good so far.

 

These older libraries, that exist in older revisions do not appear anywhere in the library manager windows.

 

Even better so far!

 

But...

 

In my latest revision, where every component is mapped to my master libraries collection (the "My Libraries" project) if I hit update, I am greeted with a list of libraries, including libraries which are not mentioned anywhere in my design, my design only uses the latest libraries from "My Libraries" project.

 

Here you can see the multiples, and although it doesn't matter if I select all and update because those superfluous libraries are not used, it is a bit irritating for them to be there, I'd prefer to just see the libraries that are actually referenced.

 

So can I purge these "dead to this project" libraries?

 

adriancarpenter_0-1638907603279.png

 

12 REPLIES 12
Message 2 of 13

Following......library issues are my biggest daily concern in F360 electronics.

Carlos Acosta
Factory400 - YouTube|Instagram
Message 3 of 13

I had noticed too many libraries in that window before too, this is good confirmation.  I wonder if its showing all the downloaded libraries, maybe deleting them from the available tab in the library manager will get them out of there?  

I'll recreate on my side and figure out exactly whats going on.

Message 4 of 13

confirmed, the table is being sourced by all the downloaded libraries.  In the available tab of the library manager, these rows are missing the little download icon.  There you can delete them, and it will fix this.  Thanks for helping track this down!

Message 5 of 13

@Taylor.Chris  Ok, I see what you mean now.

 

But how do I delete them from there?  The delete button is greyed out, the only button not greyed is Use.

 

I've tried the delete key (I'm on macOS) and that does nothing, they are just sitting there.

 

Message 6 of 13

In my test the downloaded libraries were allowing me to use the delete button.  Maybe try messing with its state (marking use / unuse) and see if that delete button gets enabled.  We are working on improving all of this right now.

Message 7 of 13

I've tried use, nothing I do allows these libraries to go.  They're not listed in any of the library manager tabs.

 

It's when I go to UPDATE I see these libraries listed, even though they're not used in the design.

 

This is so frustrating, the library stuff is just so flakey, it's got to the point what I pull a funny face when I perform a library operation (saving, loading) because it crashes so often that it's got to the point that I'm more surprised if it doesn't crash.

 

How much development work and testing are done on the macOS version because I'm finding it really hard to understand how something could be so bug-ridden without these being fixed, the only conclusion I can come to from these facts is that your developers use Windows and macOS is a token effort.

 

I have another issue that I have reported here but nobody from Autodesk has commented on, the view cube stops responding a lot, many times per session, usually, I move the mouse back over it while I "mash" the Cmd + Opt + Shift + Ctrl while performing left and right mouse clicks (or single finger/double finger tap on my trackpad on my laptop) and after a number of cycles of that it usually springs back into life, sometimes it doesn't though and I have to quit fusion and go back in.  When the view cube stops responding, it's actually greyed out and this state seems to affect everything, i.e if you switch to another diagram the view cube does not work in that diagram either.

 

There are further issues regarding panning and zooming, often I will be doing some operation that requires me to select a number of faces all over the model, I see the Zoom & Pan when selecting objects stops working reliably

Zooming doesn't work reliably, one second I can be happily selecting and panning/zooming and then suddenly I can't do anything, occasionally it'll let through the odd operation, but you end up zooming in and unable to zoom out or pan to select other items.

 

Again, when this happens, normally I end up quitting the operation I was trying to do, and then try to repeat the operation.

 

This happens a lot, like pretty much all the time and again, I can't understand why you seem unable to repeat this problem, it occurs so frequently that surely you must see this on macOS?

 

I see on various Facebook groups people have reported these problems, they've mentioned it on here as well because I've searched for them, however, I see a lot of people in these threads stating that they don't see these issues, but they're nearly always running on Windows, macOS seems to be the place where the issues are so prevalent.

 

These bugs make it incredibly annoying to use, I'm using Fusion as a hobbyist but I pay for the license because the limitations of projects are just so annoying that I pay to not deal with it, I feel like because I'm a hobbyist I should really be complaining about these problems, but, I'm paying for a license and if I were using fusion day in/day out commercially on macOS, I'd probably be having a nervous breakdown by now because it's so flakey.

 

I'm trying to be constructive here, it's hard to be when you just end up dealing with fault after fault after fault after fault with it on macOS.

Message 8 of 13

For what its worth, I am on Mac.  

Many of the fusion issue you have mentioned are different teams and sometimes out of my control (view cube, zooming etc).  I'm not as familiar with these because I mostly focus on the library editing and consumption.

But I can speak for the electronics team when I say that we are aware of the issues and are taking working hard to fix things.  Moving into Fusion wasn't easy and some of these things require structural fixes and thats why it has taken us some time.   Our team just finished a group effort at building library parts and we are feeling your pain.

We are both pushing hard to have these fusion bugs fixed and simplify the library experience.  Our XD team is doing great work, hang in there.   The structural work is almost done and our progress is going to really accelerate over the next year.

When you do encounter these problems, the more information you can give us about the state, the better.  It helps us track it down.  Also, maybe you could share your machine specs. OS, etc?
Have you seen these issues also with a mouse?  Or do you usually use the trackpad?

Message 9 of 13

If your libraries get into a bad enough state that you would rather just start over and mark everything as in use/ not in use again, you can look for the file called libraries.rc and delete it.  That should reset your whole library manager state.  If you do that, local lbr files that you have added you will need to add again.

Message 10 of 13


@Taylor.Chris wrote:

If your libraries get into a bad enough state that you would rather just start over and mark everything as in use/ not in use again, you can look for the file called libraries.rc and delete it.  That should reset your whole library manager state.  If you do that, local lbr files that you have added you will need to add again.


As per the first post n this thread, that is not an option I have available to me.  

 

The only place these libraries exist is in the UPDATE window, they're not in the library under Available or In This Design or In Use or anywhere at all inside the library manager.

 

These libraries only appear in the UPDATE command dialog and there are no "remove" buttons or no enabled "remove" buttons I can press. 

 

I have a 3D model in a library as well, that when browsing my projects via the website shows that it's not in use anywhere, yet when I try to delete it from my library, I'm told it's in use and cannot be deleted.

 

I've tried everything I can possibly think of.

Message 11 of 13


@Taylor.Chris wrote:

When you do encounter these problems, the more information you can give us about the state, the better.  It helps us track it down.  Also, maybe you could share your machine specs. OS, etc?
Have you seen these issues also with a mouse?  Or do you usually use the trackpad?


I can't give you any useful information about the view cube, it's random, but it happens so frequently that you should have no problem recreating it, or rather somebody who works on that side of fusion should be able to repeat it.

I do not use a mouse, only a trackpad, I'm on Monteray on a 2016 MBP with touchbar 16GB RAM.

 

The bug appears just doing normal work, flipping between sketches and bodies selecting, performing operations and then suddenly it goes greyed out and is not accessible, prior to realising that "mashing the keyboard and trackpad" was a solution, I used to just quit fusion and re-open it and my project at which point the view cube will work.

 

Whatever the problem is, once the cube gets into that state it's unresponsive across the entire package, every simple open diagram will be unable to use it.

I think I posted a screen capture of it in this state in this thread, on that occasion I was unable to get it back working without restarting fusion.

 

I see this problem so often and I'm using it as a hobbyist in my free time, if I were using it professionally I think I would have moved onto a different package now due to the frequency at which this happens.

Message 12 of 13

https://knowledge.autodesk.com/support/fusion-360/troubleshooting/caas/sfdcarticles/sfdcarticles/Vie...

This troubleshooting page does say that they have figured out that it has to do with Mac/ trackpad / Chrome.  I suspect that's why a good number of people have not seen it, I don't think we have a high number of users who regularly use the trackpad (+ tap to click enabled narrows it down even more).  This page also has some information on how to prevent it, hope that helps.

Message 13 of 13

I don’t use google chrome.  This issue occurs directly inside fusion, when it occurs it’s always while I’m working inside fusion, it’s not because I’ve switched to a different application, I remain in Fusion.

 

given I’ve seen others report this exact behaviour, and given that autodesk know there are issues around the view cube on Mac and given that it happens so frequently I can’t understand why somebody hasn’t been tasked with working on this to discover the problem, it’s not a bug that requires you to do anything specific, all I ever really do in fustian is create sketch’s and extrude and fillet!  Those 3 operations are enough to reproduce the error, in an alarming number of occasions within every design session I open.

 

that’s no exaggeration, this bug appears so often, and that’s the really frustrating part, because of the frequency it’s easily reproducible and no doubt fixable.

 

Fusion should have this many bugs, the electronics side crashes a lot.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report