Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Memory Hog

12 REPLIES 12
Reply
Message 1 of 13
zigzag2015
239 Views, 12 Replies

Memory Hog

Hi, in recent times, say the last fortnight, I've noticed Fusion Electronics has become a memory hog meaning my PC all but stops any other tasks. What has changed?

 

Additionally if I wish to place a part it takes a long time, a minute or more. It was not uncommon, nor a problem when first starting a design at the first instance of 'Place a Part' it would take some time, even as much as a minute for the parts libaray to become available. At susequent 'Place a Part' requests however would happen within seconds. Something has changed because now at every 'Place a Part' request it takes a miute or so before the library loads. Again something has changed and slowed the whole design process down.What is the change and how can it be corrected?

 

Craig

12 REPLIES 12
Message 2 of 13
jorge_garcia2
in reply to: zigzag2015

Hi @zigzag2015 ,

 

I hope you're doing well. Has anything changed on your computer recently?

 

Did you change the libraries that are in use? Can you think of anything that's has changed in this short time?

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 3 of 13
zigzag2015
in reply to: jorge_garcia2

Hi,
no nothing about the PC has changed.

The 'slow to load library' issue became apparent after an update, about a fortnight ago. The update, among other things, changed the 'Add a Part' icon. Thereafter the program has become nearly impossible to use, it just takes too long to load libraries, 40 seconds to a minute on each occassion, and with a new design that could be a 100 parts. Is it possible to go back to the version prior....I'm now struggling to use Fusion, and am looking at Altium.

Craig
Message 4 of 13
jd.vorheis
in reply to: zigzag2015

@zigzag2015 we are really sorry this is happening to you! We are looking into this issue now. Until then, can you please type add in the command line which will bring up the old add part dialog. See if you still have the performance issues and let us know. Thanks. 

Message 5 of 13
jd.vorheis
in reply to: zigzag2015

@zigzag2015 can you please share your hardware specs with us as well? 

Message 6 of 13
zigzag2015
in reply to: jd.vorheis

Hi,
i5, 3.2GHz with 4G RAM.

I have been using this exact PC with Fusion for two years, and until recently (one month) or so never had reason to suspect that Fusion was using memory badly, but it is now regularly consuming 94% of the memory.

I have used EAGLE for years, and followed it to Fusion two years ago.


1. With the change to cloud-based Fusion has more, approximately double, the number of crashes.
2. Each time Fusion recovers takes minutes, five or more, very slow
3. A slow internet connection stops Fusion altogether. I can no longer use Fusion at home for instance, because the wireless broadband is patchy.
4. When going to Fusion EAGLE's polygon pour was broken and the ULP pcb-gcode no longer works and I use it extensively. I raised the issue at the time and was told 'it's not a priority', thanks for **** all.
5. I now export a Fusion PCB to EAGLE so I can use the ULP, a time consuming and frustrating workaround.
6. I have asked repeatedly about a means to break links between files so that I might delete PCB files, but cannot. I can delete from the top design file down, but what I can't do is delete a sketch from which a PCB blank is generated or the PCB file while retaining the top design file and the schematic. Ergo the only way to delete a PCB file is to delete the entire design. You have always claimed it's the way the cloud works....but that's not a solution. All I can do is sweep redundant files into a trash folder. I can't control my own data, and that pisses me off.
7. Over the last month Fusion has become a memory hog, whereas I used to be able to have Atmel Studio open at the same time as Fusion so I could review my design schematic while programming has become near impossible with Fusion hogging all the PC's resources. Do I have to upgrade my PC just to accommodate the changes you have made?
8. Within the last fortnight a change has been made so that each occasion I want to place a part in a schematic it takes 30 seconds to one minute for the library list to be populated. This would happen once, on the first occasion I wished to place a part in a design, that was perfectly acceptable, but now it can take ten minutes just to select ten parts, which is just too time consuming for the purposes of a business

I use Fusion, the electronics module a lot, about 80% of all my Fusion work is with the electronics module. Since Autodesk has taken over EAGLE it's gone backwards in terms of productivity. You've added a few nice features but overall its just become so slow that I feel I can't use it for business anymore. My subscription is due in June, and my decision at this time is not to renew it, if I cant use it for work what's the point?

Craig


Message 7 of 13
zigzag2015
in reply to: zigzag2015

Hi,

I just tried using 'add' in the command line in a current design. It changed nothing, it took about 40 seconds to one minute to load the libraries, so I tried a second time, and the same delay was experienced.

I decided to try a third time and time it....I got to 50 seconds and then Fusion just crashed, disappeared, no warning, no nothing.

 

Craig

Message 8 of 13
zigzag2015
in reply to: zigzag2015

Hi,

Fusion took 4.5 minutes to recover, is this normal?

 

Craig

Message 9 of 13
zigzag2015
in reply to: zigzag2015

Hi,

to be fair I have just been using Fusion to make some modifications to the current design and at the conclusion have saved the changes and found Fusion is consuming 480Mb, but nothing like 90% of available memory.

 

There have been circumstances where Fusion has hogged all the memory and all but stalled the PC, it is not the norm I've decided.

 

Craig

Message 10 of 13
jorge_garcia2
in reply to: zigzag2015

Hi @zigzag2015,

 

Hmmm... that's weird. I wonder what was happening when it was hogging all of the memory. By any chance was Fusion updating?

 

Any other info you can provide will be helpful. We are happy that it's not hogging your memory but right now but it would be useful to understand what was going on.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 11 of 13
zigzag2015
in reply to: jorge_garcia2

Hi,
it may well be that something was happening. I have monitored Fusion's memory use much more closely over the last week or so, and while it can and does
occasionally hog memory, it does that infrequently. For instance this morning, when using Fusion between other jobs its sitting at about 150Mb, which
is perfectly acceptable.

What has not changed is is a show stopper is the huge delay in loading parts libraries so I can add a new part. This changed about a fortnight agoi
from acceptable to now just plain useless. Why does it take over a minute to load?

Craig
Message 12 of 13
jesper8W75R
in reply to: jorge_garcia2

Not updating, just sitting there eating up my memory. Doing nothing.
At least it's "only" at 99% CPU, not 630%+ as it is sometimes. For no particular reason it seems.

Screen Shot 2022-04-16 at 19.11.15.pngScreen Shot 2022-04-16 at 19.10.59.png

Message 13 of 13
silvio3105
in reply to: zigzag2015

Did you try reinstall?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report