Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ground Pour polygon fills entire polygon instead of board outline

10 REPLIES 10
Reply
Message 1 of 11
kevinm7EVUG
1391 Views, 10 Replies

Ground Pour polygon fills entire polygon instead of board outline

I am working with a board outline that was created from a sketch in a model. I make just a plain rectangle polygon and connect it to ground like I always did in eagle. I hit ratsnest and the entire polygon fills not just the board outline. It keeps away from the board outline so it is recognizing it but it fills the whole thing. See attached photo , I created a new board and schematic that was just extremely simple and it still does it.

10 REPLIES 10
Message 2 of 11
jorge_garcia2
in reply to: kevinm7EVUG

Hello @kevinm7EVUG,

I hope you're doing well. This is the normal behavior typically you wouldn't have a polygon extend so far outside the limits of the board. Additionally, if you haven't defined a name for this polygon then this behavior might also be expected.

If you want the polygon to stick to the limits of the board then you are better off right clicking on the board oultine > Convert to polygon > COpy and then select what layer to place the polygon on. This will make the polygon follow the contour of the board with a couple of clicks instead of trying to trace it exactly.

Let me know if there's anything else I can do for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 3 of 11

Im having the opposite problem, my polygon pour doesn't reach the edges of my board outline. I tried the suggestion here, but when attempting to convert the circular board outline into a polygon I am unable to select it and right click. I watched a video from this year that made it seem like you cant do this with circular polygons, only rectangular ones. So instead I drew the polygon around the edge of the board, but when I poured the copper polygon as GND, the copper had a significantly smaller diameter than the polygon itself. 

How do I get it to fill the whole top layer?

Message 4 of 11

Hi @kristofer.porter 

I hope you are doing well!

For your question, I think you can change the Distance value in the DRC dialog.

I hope it can save your problem. Please have a try, thanks!


Screen Shot 2021-03-18 at 4.48.12 PM.png

 

Regards,

Panpan Fan

Message 5 of 11

@panpan_fan ,
That worked pretty well, but there is still a difference in diameter between the board and the copper layer which is evident in a smaller PCB. How do I remove this last little edge?

 

Note: I only have one "default" entry in Net Classes and all three values are set to 0 mil.

 

Thanks for the help!

Message 6 of 11

Hi @kristofer.porter 

Thanks for your reply.

Would you mind attching the screenshot ot your DRC settings for distance?

Do you set it smller enouth to satisfy your need?

 

Regards,

Panpan Fan

Message 7 of 11

@panpan_fan 

 

Attached. I have it at 0 mil.

Message 8 of 11

Hi @kristofer.porter 

Thanks for your screenshot. 

I think they should be matched well when the distance is set to 0 mil.

I guess it may be result to other settings in your file.

Would you mind sending your file to us for checking? I will send my email address to you as a private message.

 

Regards,

Panpan Fan

Message 9 of 11

Hi @kristofer.porter 

Thanks for sharing your file to us!

You can change the Isolate of the Polygon to make the polygon and outline match well.

Please have a try, thanks!

Screen Shot 2021-03-25 at 5.13.55 PM.png

Regards,

Panpan Fan

Message 10 of 11
jlgarcia94KGT
in reply to: panpan_fan

Reducing the insulation works so that the ground plane reaches the edge of the PCB, but now the problem is that the separation between the ground plane and the tracks and pads is reduced as well. This doesn't happen in Eagle, is there a way to solve it in Fusion 360? Thanks in advance.

Message 11 of 11

Hi @jlgarcia94KGT,

I had tried in both Fusion and Eagle making the Isolate value 0mil. The copper pour clearance around any objects with different signals is taken from the Clearance rules in the DRC dialog Clearance tab and the thermal relief air-gap value from the Supply tab Thermal isolation value. If you change the DRC clearance then the separation between tracks, pads, vias and the copper pour will follow this value. I did the same thing in both Fusion and Eagle and the result is the same. I have created a solid polygon.

Isn't this behaviour the same with the one you see in Eagle?

 

Please let me know if there is anything else I can help you with.

 

Kind Regards,



Constantin Popescu
Principal Software Engineer

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report