Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fusion 360 Electronics deleting contents of my SCH file every time I save

7 REPLIES 7
Reply
Message 1 of 8
maustinQZ9FZ
548 Views, 7 Replies

Fusion 360 Electronics deleting contents of my SCH file every time I save

Hi,

 

Something is seriously wrong with my version of Fusion 360 at the moment.  I've been happily working on a project for several weeks, but just in the last 48 hours its been going bananas.

 

Basically, everytime I save my SCH file and close that file (e.g closing down Fusion 360 at the end of the day), when I go to reopen that SCH file, its completely blank.  Absolutely everything in it has been deleted.

 

I've been going around and around in circles trying to resolve this, by:

1.  Removing the affected SCH file from my project (so, deleting the link)

2.  Promoting a previous version of the SCH file that isn't empty

3.  Updating that version of the SCH so that it has all the most recent changes, and hence is compatible with the PCB file

4.  Linking this new SCH file back into the project.

 

Its at this point my SCH ends up blank again.

 

I've spent hours yesterday and hours this morning trying to fix this, but clearly its something to do with Fusion 360 and not me.

 

I really need urgent help - I've got customers needing designs completed, and I've got software I can't actually use 😞

 

Mike

7 REPLIES 7
Message 2 of 8

Have you ever had a crash in this project?

 

I had similar case after I have got neutron electron missing files error. Usually it were the libs which, I have reworked and saved as team. When I saved sch or Projecy(do not remeber), after this error - sch was blanked.

 

Try to  reinstall/clean tool/ this crap. If it does not help, then open the last known good project and replace( to refresh internal links or references) all the parts which you have worked with. From the very beginning fusion was not working proper whit re-edited parts. 3D features was implemented but  it seems without any serious tests. When you use only built in parts all is fine. Problems come when you change something or you assign 3D package.

 

This software is like ticking boomb. Do not relay on it, export project backups often, if you do not want cry.

 

Address your post to @Jorge or @HelenChen-ElectronicsQA and share your project archive if you can. Perhaps they will find source of problem.

Message 3 of 8

Hi @maustinQZ9FZ,

I hope you're doing well. If you get a blank schematic, that means the file got corrupted in some way. I'm going to send you a DM with my e-mail so we can start tracking this down.

Let me know if there's anything else I can do for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 4 of 8

Thanks @christopher2KLSVU , @jorge_garcia2 

 

Panpan Fan ended up helping me out.  Took nearly a week, but turns out (surprise, surprise) there was a massive bug in Fusion360.  The Dev Team were able to easily replicate my error, and then found out what the issue was.  They were going to add this fix to the next update, but I've not had any information as to when this update is going to get rolled out, so I'm in a holding pattern until that happens in case I just burn another week of my (and my customers time) going around and around in circles.

 

With all the bugs in Fusion360, I'm gonna go out of business if things don't improve significantly...and quickly 😞

Message 5 of 8
panpan_fan
in reply to: maustinQZ9FZ

Hi @maustinQZ9FZ 

 

I hope you are doing well!

I have replied in your first post that we release Fusion 360 V2.0.9313 which has fixed your issues about data loss.

Please have a try, thanks!

 

Regards,

Panpan Fan

Message 6 of 8

I do hope it's truly solved this time. Since we first starting seeing this bug back in the spring, worked with the devs, were told it was fixed, then saw it again a number of weeks ago, worked with the devs, were told it was fixed, and still find reports from other users on the forums of the same thing. 


Always appeared to be library related for us, and since I'm seeing new library bugs popping up, we'll be doubling down on the extra saving and exporting. 

Message 7 of 8
ayorkR8GD6
in reply to: maustinQZ9FZ

This got me too.  Days of work lost because the thing quit allowing files to be updated.  I reverted to Eagle.  I don't need the 3d stuff.  Eagle is faster, doesn't have that could save stuff, and works.

Message 8 of 8
keqingsong
in reply to: maustinQZ9FZ

hey all - this issue should be resolved in our latest product update. 


Keqing Song
Autodesk Fusion Community Manager
Portland, Oregon, USA

Become an Autodesk Fusion Insider



Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums