Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: "Part has inconsistent 3D packages in schematic and board..."

3 REPLIES 3
Reply
Message 1 of 4
infoAGJ6T
423 Views, 3 Replies

Error: "Part has inconsistent 3D packages in schematic and board..."

I've tried looking for solutions to this online and none seems to solve my issue.

When I run ERC Validation, I get the warning "Part has inconsistent 3D packages in schematic and board..."

I don't have any idea what that means and there are not hints as to where the inconsistency is and how to fix it.


Steps Taken:
--------------

- removed part in schematic and re-placed
- removed part in board and re-placed

- opened library and inspected device/package and seemed fine

- checked connections in device and they look fine

 

3 REPLIES 3
Message 2 of 4
edwin.robledo
in reply to: infoAGJ6T

Hi infoAGJ6T,

Thank you for posting on the Fusion 360 electronics forum. Regarding the offending part, please add a new one on the schematic and follow it to PCB and 3DPCB. Do you get the same error with the new part?

Is this one of our default parts or one you created?

Keep me informed.

Ed



Edwin Robledo
Tech Marketing Manager
Message 3 of 4
infoAGJ6T
in reply to: edwin.robledo

I did that but it did not seem to work. Instead I have gone back and removed the link between the PCB and schematic and started a new PCB. I wish I understood why this happened and how to avoid it, but I don't know what I did to cause it so I'm not sure I can give you what you'd need to tell me how to avoid this in the future. 

 

I suppose I could ask the question in another way: what would cause the error I experienced? 

Message 4 of 4

Hello @edwin.robledo,

 

I am having the same issue with parts which I create my own 3d package for - sometimes when I modify the 3d package, it seems to only push into board but not to schematic, and then the F/B annotation is broken. No matter what I do after, it is still broken, even though I 'replace' the parts in the schematic and the board manually for the latest part I have in the library.  Quite annoying issue, I wonder if I do something inherently wrong 😕

 

EDIT: Update: I was just able to manually fix the issue by 1) changing the 'value' property in the pcb editor to match the value in the schematic (which got updated with the V2 appendix which I used to annotate the new version of the 3d package - apparently, the value in the pcb editor didn't update automatically). and 2) I had to right click on the parts in the schematics and just view the 3D package. Doing that on all the instances of the corrupt part one by one helped to get the F/B back. Quite unintuitive bugs I'd say.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums