Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: Failed to load 3D model on fusion 360

5 REPLIES 5
Reply
Message 1 of 6
saideep.kamishettyEEZEL
819 Views, 5 Replies

Error: Failed to load 3D model on fusion 360

Hi,

 

I tried the following to rectify above error by referring to eagle online forum previously solved questions, but nothing helped me.

 

1. Made the user defined library as managed and made sure using same version of library on fusion 360 and Eagle.

2.Uploaded both schematic and board file to default project folder on fusion 360.

3. Replaced the components on board file to the component in most updated version of library on eagle(Which has 3D step models associated to components) and pushed it onto the fusion 360 3D model. I see a green check mark beside the components under 3D symbols section while pushing the model to fusion. Still all components on the 3D PCB model show as black boxes, instead of showing 3D models for those components. 

4. On a different instance, tried replacing the components directly on the fusion 2D PCB file with component from the most updated library,  and switched to the 3D PCB file but still the components are shown as black boxes.

 

The original board and schematic file are made around 2011 and made some changes to it recently. Can view  3D models for whatever components which are added recently but the 3D models for the past components will be viewed as boxes. Is it because since the board files are old, that it will not work with the fusion 360?

 

Any suggestions will be helpful. Thanks.

Labels (3)
5 REPLIES 5
Message 2 of 6

Hi @saideep.kamishettyEEZEL ,

 

First old board files should be supported.

 

An issue we known is if you insert the 3d models as xref into a Fusion design and use the Fusion design in EAGLE's managed library, the 3d models might not be recognized. If that's the case for you, can you go to the 3d package documents -> select the linked component -> right click -> break link -> update the library versions and try to create 3d pcb again?

Message 3 of 6
ssava025
in reply to: yqliu

Hello,

 

I am trying to bring a 2D board file into fusion 360 for a 3D view. But, I am not able to get the 3d model of the op-amp and arduino into fusion 360. As you can see in the photo, I am getting errors. Can anyone please explain that? I have imported that from mouser.ca and it has 3D package. Still I am getting the error.Capture.PNG

Message 4 of 6
yqliu
in reply to: ssava025

Hello @ssava025,

 

If you use the library downloaded from mouser.ca directly, there won't be 3d packages because EAGLE doesn't know where to get them. Please refer to this article: https://support.snapeda.com/en/articles/3545085-how-to-import-3d-model-into-eagle

Message 5 of 6

@yqliu Thank you for your suggestion. How to download the 3D. STP model file. For example, I am using SC12PAQR as a switch. Can you suggest to me how to download it? Also, when I click the library option there is no option like 'create manage library '

Message 6 of 6
yqliu
in reply to: ssava025


I'm confused with your question of how to download the 3d STP model. You just find the link and download, that' all. But it's possible that the web site you are using might no provide any 3d models.

 

For the specific part SC12PAQR, the model provided by mouser.ca is very simple:

sc12p.png

 

and you can create one (and most probably better one) in Fusion 360 easily. If you are new to Fusion 360, you might start by looking at this design.

 

The link I shared last time contains an image to show where the command 'create manage library ' is. If you can't find it, I guess you are using an older version of EAGLE?

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums