Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Electronic Libraries are infuriating and syncing/linking sucks

2 REPLIES 2
Reply
Message 1 of 3
f.valkenhoef
301 Views, 2 Replies

Electronic Libraries are infuriating and syncing/linking sucks

I've been trying to switch from Eagle to Fusion and had the idea to rebuild and restructure my libraries.

As a test/practice run I created a library with some headers.

 

During the process I ran into numerous bugs that caused fusion to crash.

Which is where it started to turn sour.

(I had Fusion crash on me about 15 times in 1 day. I can provide you with more details if you want them but I have also submitted the crash reports)

After learning where those bugs were, I could work around them (not ideal, but OK).

 

Now that I have my library finished I turned to a new electronic design.

But my library named "Headers" is nowhere to be found.

image.png

So I opened the library manager

image.png

and there it is, my library named Headers.

 

Though the library manager insists the library is in use, I can't get the library to appear in the ADD dialog.

However, in both the library manager and the ADD dialog an older version of my library appears.

Namely the last version before I renamed my library from "Connectors" to "Headers".

 

Two things:

1.) Please fix the way things sync. The user experience sucks (mainly because of the frequent crashes)

2.) Is there any way I can salvage the work I did on the library?

things I tried to get the library to show up in the ADD dialog so far include:

  • Running the UPDATE command, 
  • which does show the library like the library manager
    image.png
  • Using the "Update design from library" button, which also shows the library
  • Removing the library from used and re-adding it.
  • Restarting Fusion.
  • Restarting my PC.
  • Renaming the library with a new name, or the old name.
  • Promoting an older version of the library of which I know did work before

 

2 REPLIES 2
Message 2 of 3

Just want to add I had the same problem with fusion crashing a lot in a short amount of time when I was trying to use my libraries.  Alas I don't have a solution (yet)

Message 3 of 3
rbkyorem
in reply to: f.valkenhoef

This is why I am keeping away from FUSION 360 Electronics for now... We are having a little push/pull problem with Eagle to FUSION 360 now. While it is being fixed I wanted to try out if they have fixed anything since launch but I see that library system as you have mention is still a mess to be honest. I created a library called DRAWINGS added a frame for A4 papers and yet I still see my old first libraries from FUSION 360 electronics launch days and no I could not find my newly created DRAWINGS library.

This is really odd that even though I deleted some of those libraries months ago they still sit there creating mess. I can not remove libraries i do not want. 

On the other hand they have fixed lagging and most of the bugs that caused the crashes. Added command line and some more...

But it is still unpractical to move on to FUSION 360 electronics with this library system. You can not use ULPs or import from other libraries still.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums