Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eagle to Fusion library migration

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
mike.durian
742 Views, 10 Replies

Eagle to Fusion library migration

I have an existing Eagle design that I'm migrating to Fusion 360. The current design does not have any 3D packages in the library. I've successfully uploaded the board, schematic and library to Fusion. I've also added 3D packages to all the components I use in the design. I'm stumbling trying to figure out how to update the existing components in the design to include the 3D packages.

 

In Eagle, if I made a change to a footprint or symbol, I'd save the library then re-add the part to the schematic. I wouldn't actually place the part, but in the process of adding it, Eagle would tell me it would update the existing parts to match the new version in the library. This processes doesn't seem to work in Fusion.

 

I think it is because the Fusion thinks the library used by the components still lives on my local computer, which is distinct from the updated library in the Fusion cloud. I know I can delete the component from the schematic and re-add the new one, but I'd prefer to update in place. How do I do this?

 

Also, in the library Fusion library manager, I removed all the stock libraries that I don't use. I only use my own personal library. But for some reason, all the other libraries re-appeared under the "In Use" tab. Not sure what happened there. I removed all the libraries again. Hopefully they'll stay away.

 

mike

Labels (1)
10 REPLIES 10
Message 2 of 11
mike.durian
in reply to: mike.durian

Replying to my own post.

 

I deleted and replaced one component using the new library. I notice the schematic design manager lists the new library as _xxx-uuid.flbr instead of the old xxx name. Are the schematic and layout files stored locally anywhere? Perhaps I could close F360 and edit the files, changing the library name from xxx to _xxx.uuid.flbr and then reopen the project? In that case, would F360 know to update the components using the new library and include the 3D models? Would the changes get synced back to the cloud?

 

mike

Message 3 of 11
ayorkR8GD6
in reply to: mike.durian

Keep backups of your Eagle stuff!!  I learned this the hard way.

 

My new Fusion 360 project file got corrupted.   My schematics and board files open blank documents.  I can't go back to the old versions of the files because they aren't lined together  (i.e. Schematic v12 is not the same as Board v12) so you get error message about the boards and schematics being out of sync.  

I've lost a week of work over this.  360 will get you and cost you.  It will not be easy to get work done in 360 back to vanilla Eagle.

Message 4 of 11

Hi @mike.durian ,

 

Sorry for any inconvenience.

If your managed library has new version updated in EAGLE, then in Fusion 360 currently, please try below steps to get them be updated. Hope it helps.

 

Step 1:

Open the saved schematic file again, it will remind the library you used has update, please update it in Library Manager in the banner.

Step 2:

Go to Library Manager to update the library.

Step 3:

In Schematic design -> Go to Library tab -> Select Update designs from all libraries used in this design. -> You will use the new version of the library for the existing part.

Step 4:

Add new part from the updated library -> You will use the new version of the library for the new added part.

截屏2020-05-12 上午11.22.54.png截屏2020-05-12 上午11.13.12.png截屏2020-05-12 上午11.13.32.png

 

Regards,

Helen

 

 



Helen Chen
Principle QA for Fusion 360 Electronics
Message 5 of 11

@mike.durian , as for the deleted libraries show up in the In Use tab of the Library Manager again, we have a fix in today's released Fusion 360 latest version 2.0.8335, could you please upgrade your Fusion 360 to latest version and try again?

 

Please feel free to let us know if it works for you or not. Thank you.

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 6 of 11

Hi Helen,

Thank you for the reply. Unfortunately, the steps did not help. F360 did not detect a library update. When I tried "Update designs from all libraries used in this design", I did get the following warning (referring to the one component I deleted and added new from the F360 library).

Following devicesets are used in schematic but have not been found in
the corresponding update library:

_boogie.9a924681-549e-4865-65df72a03681.flbr (id: urn:adsk.wipprod:fs.file:vf.
2M_KqiJITRizrUqVGmryrA): PJ-037BH-SMT-TR.

If this is not intended, adjust the library paths or library deviceset
names and update again.

 

After the update, the Design Manager did list the library for the part as boogie instead of _boogie.uuid.flbr, as it did previously.

 

I should also clarify that I did not upload a managed library. I uploaded a vanilla Eagle library without the 3D packages. I only added the 3D packages after uploading.

 

When I check the library manager, I see the following. The versioned library is the F360 one with the packages. Only a single component from that library is present in the design. I'm assuming the library with the warning symbol is a reference to the library when it lived on my local drive. If there were a way to tell F360 that the two libraries are really the same thing, then maybe it would be possible to get the update to go through?

 

Screen Shot 2020-05-12 at 11.11.52 AM.png

Message 7 of 11

Hi @mike.durian ,

 

If you see the orange warning icon next to the library in the "In Design" tab, it means the library is not downloaded yet to your current machine.

Please go to the "Available" Tab to find the library -> Click "Use" button.

Hope it helps.

 

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 8 of 11

Hi @HelenChen-ElectronicsQA,

If you look in the screenshot I provided above you'll see the boogie library listed twice. The one with the warning was created using Eagle on my local computer. It is not a managed library as it contains no 3D packages. It was used to populate all the components in the schematic.

 

The other boogie library is the one created in Fusion 360 after I uploaded the Eagle one. I have since added 3D packages to the all the components used in my design. I am trying to use that library to update the components in the schematic so they include 3D packages. I'd like to do this in place, without having to delete and re-add all the components.

 

The only reason the Fusion 360 library is shown in the "In Design" tab is because I did delete and re-add a single component. All other components come from the other library - the one with the warning symbol.

 

As you can see in the attached screen shot, the boogie library is not listed in the Available tab because it has already been used and is present in the "In Design" and "In Use" tab.

 

Can you please provide a method for me to convince Fusion 360 that there is only a single boogie library and that all the component in the design can be tied to the Fusion 360 version of the boogie library. That was I'll be able to update them in place without having the rip-and-replace everything.

Screen Shot 2020-05-14 at 12.00.46 PM.pngScreen Shot 2020-05-14 at 12.09.06 PM.png

Message 9 of 11

@HelenChen-ElectronicsQA,

In case it is still not clear what I'm requesting, maybe these screen shots will help. Please note the Library fields shown in the Info windows for two components. In the first screen shot, the Library is "boogie (Version 12)". This is the component I deleted and re-added. Since it was added directly from the Fusion 360 library, it shows the revision number.

 

The second screen shot shows a part that was added to the schematic from Eagle. It does not show a revision number because it still references the original boogie library, before I uploaded the library to Fusion 360.

 

Because Fusion 360 didn't automatically make the associate between the Eagle version of the boogie library and the Fusion 360 version of the same library, I cannot update that component by adding a new component of the same type from the boogie library (Fusion 360 version, which is the only one that can be used). I can add a new part, but Fusion 360 doesn't realize that the existing part is the same part because it still references the original Eagle version of the library.

 

I'd like a way to update all the components in my design so they reference the Fusion 360 version of the boogie library instead of the original Eagle version. Then I'll be able to update the components with 3D packages just by adding a component of the same type to the schematic.

 

I hope that makes sense.

Screen Shot 2020-05-14 at 12.58.42 PM.pngScreen Shot 2020-05-14 at 12.58.57 PM.png

Message 10 of 11
jorge_garcia2
in reply to: mike.durian

Hi @mike.durian,

I hope you're doing well. You are super close to getting everything working. The key thing to not here is that if you unmanaged and 3d modeled parts from the same named library in the design update wont work. The term managed doesn't apply to Fusion since it's library system is separate (we released a bridge in the latest release of Fusion360 but that's another point).

Here's what you need to do:
1) Remove the 1 part you've added to the design from the Fusion version of boogie library.
2) Check the library manager in design tab. You should now only see one boogie library. The one that doesn't have a version number.
3) Now click on the library menu in Fusion360
4) Update from Library(Don't use update ALL, it makes a lot of assumptions)
5) Now select the versioned boogie library and click OK.

If everything is good, the in design tab in the library manager will now show the versioned library boogie instead of the original unversioned one.

Let me know if this works for you.

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 11 of 11
mike.durian
in reply to: jorge_garcia2

Thank you, @jorge_garcia2,

That worked and now I have 3D packages for my components.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report