Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Components loose position if PCB is attached to another body.

4 REPLIES 4
Reply
Message 1 of 5
glbVTW4G
145 Views, 4 Replies

Components loose position if PCB is attached to another body.

I have this small product with a PCB, components and a case. I needed to add components to see where to place the PCB in the case. 

When I push the Eagle PCB to fusion everything is fine until I use a joint to locate it in the case. If I just move the PCB all the components follow along and stay correctly positioned on the PCB after the move. If I add a joint from the PCB to the case, the components get left behind. I can fix it by making the Whole PCB group a rigid group, but then if I go back into Eagle, the next time I push it to fusion it won't update the components positions.

4 REPLIES 4
Message 2 of 5

I have a similair problem, is there any solution? Is there a way to make the PCB/components a rigid group within the 3D PCB workspace?

Message 3 of 5
jorge_garcia2
in reply to: glbVTW4G

Hi Guys,

 

I hope this message finds you well. This is a known limitation of the current implementation.

 

I'll ping the developers on this to see if there is any ideas on how it can be worked around temporarily.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 4 of 5
engineeringNCMXB
in reply to: glbVTW4G

Link the PCB into your model - make a rigid group out of it BEFORE you apply a joint.

Pain in the butt - but it works for now.

Carlos Acosta
Factory400 - YouTube|Instagram
Message 5 of 5
polaris360
in reply to: glbVTW4G

This is bug and the team is fixing. For now, besides the suggestion from @engineeringNCMXB , the other way you can try is to update the timeline:

 

rigitgroup.png

then save the design and update the assembly of the case.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report