Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Component search has never worked

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
josh_l
152 Views, 5 Replies

Component search has never worked

Hi,

 

Just writing this to Autodesk out of frustration that since beginning with Fusion in 2020, searching for an electronic component has never worked for me for a user-created library.

 

Here's a clear and simple example:

 

I have an Electronics library called "Meanwell IRM-90-12", which I created. Within that is a component also called "Meanwell IRM-90-12". Within that is a symbol called "Meanwell IRM-90-12", and a footprint called "Meanwell IRM-90-12", and a 3D model called... you guessed it... "Meanwell IRM-90-12".

 

While putting together a schematic, I bring up the "Add" dialog to add a symbol. I type "Meanwell" in the search box at the bottom and press return. Search results are completely empty. If I manually scroll through the libraries and components without searching, I can see it right there in front of me. The search function SIMPLY DOES NOT match a search result in the most simple of scenarios.

 

As a paying customer, I think maybe it's time to fix it?

 

Finally, just to preempt in case someone from Autodesk is tempted to respond with "it only matches text from the 'description' of a library or component"... nobody on this planet expects a search function to search everything about a thing EXCEPT the name of that thing.

 

Thank you kindly for your continued hard work on this product.

 

Josh

5 REPLIES 5
Message 2 of 6
n.smithHJCP5
in reply to: josh_l

I'm glad someone else shares my frustration. Here's a post I made a couple years ago. https://forums.autodesk.com/t5/fusion-electronics/can-t-filter-for-attributes-in-schematic/td-p/1123...

The workaround I've been using is the "Add" command. Design > Shortcuts > Created one for the command "Add". I just tied mine to the letter "Q". Now in a schematic, every time I hit "Q" it brings up the old Eagle Add window which actually works how you describe. Given you use wildcards "*".

nsmithHJCP5_0-1707402460763.png

 

Message 3 of 6
Taylor.Chris
in reply to: n.smithHJCP5

Hi @josh_l ,

It sounds like you might be using the add dialog instead of the place panel.  The place panel should search as you are expecting, it does not require wildcards, and does search across name, description, variant name, etc.  The place panel should be to the left of the schematic, unless you have adjusted your panel layout.

From what you describe, it sounds like you are using the old add panel without wildcards.  This is something that confused me when first using EAGLE as well, most modern searches can handle extra text in front or behind the search word, but without adding wildcards, EAGLE's add dialog cannot.

The add dialog is still around primarily because the place panel lacks the ability to search by attribute-value, as @n.smithHJCP5 correctly points out.  It is one of our near-term goals to allow searching by attribute-value in the place panel, and its search will continue to improve in other ways, hopefully diminishing the need for the old dialog.  Other common requests are for fuzzy search / allowing wildcards, and some users prefer the tree view of the old dialog.  We are also working on making sure the panel always remembers the last chosen variant / attribute set dropdown selections for each component.

I have been collecting improvement requests for the place panel, so if either of you have any further suggestions for how to improve the place panel, feel free to make those here.

Let me know if this resolves your issue, or if you need further assistance.
Thanks,
Chris

Message 4 of 6
josh_l
in reply to: Taylor.Chris

Thanks @Taylor.Chris . I was never an Eagle user, but my first exposure to using Fusion Electronics was a tutorial that taught me to use the "Add" command. Until I read your post, I had never used the Component Place menu. That works much more like a good app should!

 

Thanks for your quick and helpful reply!

Message 5 of 6
Taylor.Chris
in reply to: josh_l

No problem!  Can I ask what tutorial that was?

Message 6 of 6
josh_l
in reply to: Taylor.Chris

I don't recall, as it was a long time ago. I started using the Electronics in 2020 when it had only been in included in Fusion for a few months, so most of the available educational content was actually for Eagle. I never used Eagle, but definitely relied on a lot of search results that were Eagle-centric to learn how to do things. I still occasionally do so today 😃

 

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report