Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Component Origin Not Showing

10 REPLIES 10
SOLVED
Reply
Message 1 of 11
crgmakes
370 Views, 10 Replies

Component Origin Not Showing

I'm not entirely sure if this is me or the new version of Electronics. I don't seem to have an origin layer any more. The only way to get origins to show for my silkscreen items is to turn on the top layer, which sort of defeats the purpose of only having the silkscreen layer on. Am I missing something here?

 

Secondarily, and unrelated, the "BoardOutline" layer in PCB seems to be the same as "Dimensions" in the foot print editor? Caused some serious issues for me the other day.

 

Third, double clicking a route when deleting no longer deletes the entire trace?? There doesn't seem to be any way to delete an entire trace without affecting all?

 

Annoying, but I found a workaround, but the board dimensions just "selecting" a "convenient" dimension unit is simply dumb - serious WTF?

 

Finally, how can I change the color of a layer? I'm at a lost....

 

Many thanks!

 

-tom 

10 REPLIES 10
Message 2 of 11
panpan_fan
in reply to: crgmakes

Hi @crgmakes 

For issue 1: you can refer to forum post https://forums.autodesk.com/t5/fusion-electronics/components-origin-layers-have-disapeard-since-last...

For issue 2: We have updated the layer names and make them more readable. You can see the reminding in the Display dialog. You can find all layer name change in https://help.autodesk.com/view/fusion360/ENU/?guid=ECD-LAYERS

LayerName.PNG

For issue 3: I am not sure if I understand your question clearly. But you can try different options in the Unroute command dialog. For example, I choose Signal option and it helps me to ripup the entire signal.

For issue 4: You can follow the steps to change layer color. Step1. Click on any layer in Display panel. Step2. Expand the Details. Step3. Double click on Appearances color box.

ChangeColor.PNG

Hope it can do some help for you.

If you have any other questions, please let us know. Thanks a lot!

Regards,

Panpan Fan

Message 3 of 11
crgmakes
in reply to: panpan_fan

Thanks @panpan_fan.

 

1 - perhaps I was not clear -- the issue is not showing or hiding the origin per se. The issue is you can't move a component without the origin visible. For whatever reason, I wasn't seeing origins on the silkscreen layer without having top layer turned on. I just checked and they are now showing properly, so I don't know what was going on.

 

2 - I saw that message and no issues with the name changes. What I'm trying to say is the names for any given layer are different between footprint editor and pcb. The name given to the footprint layer 20 is "dimension" and the name given to layer 20 in the PCB editor is "BoardOutline" -- massive problem when you put items on the "dimension" layer in the footprint and they affect your board outline in PCB. Layer 20 name should be consistent across all views. This is a defect IMHO.

 

3 - I see now -- pop up window isn't tall enough and all the other options were below the fold. I didn't notice the scroll bar since it was right next to the scroll bar for the view pane. Regardless, in Eagle CAD double clicking the routed net ripped up all traces without having to select some special mode. I'd like to see that come back for speed sake. Many things Fusion has done to Eagle slow my workflow by requiring clicking and scrolling and opening popups. But on the plus side, Fusion has mostly fixed moving components which is nice -- just need to fix moving groups now!

 

4 - Got it now. Would love to see that "details" window open automatically when you double click the layer or color.

 

I suppose this is what happens when you take a 2 year break from using a piece of software and try to jump right back in! 🙂

 

Many thanks for the help.

 

-Tom

 

Message 4 of 11
cyberreefguru
in reply to: panpan_fan

Hello @panpan_fan -- while editing the same PCB today, I was able to reproduce the error with a component on the silkscreen not having the origin show until the top layer is visible. I've saved everything - reloaded, relaunched, etc - the problem persists. So either I've found an obscure bug, or I'm simply doing something massively wrong. I'm happy to upload a video showing the problem.

-Tom
--
Professional PowerPoint Jockey...
Message 5 of 11
jorge_garcia2
in reply to: crgmakes

Hello @cyberreefguru,

 

I hope you're doing well. The developers are investigating this. I'll let you know once we have more info.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 6 of 11
crgmakes
in reply to: jorge_garcia2

Thanks @jorge_garcia2 - I think I may have figured it out. Not entirely sure if it's a legit defect, but it's certainly not working as expected. Everything was working fine when my logo was created directly on the board. Once I converted it to a footprint and made a component out of it (so I could have multiple footprints in one component), that's when the problems started. Now that it is a component, I only get origin when the top layer is turned on, even though there is nothing on the top layer in that component.

 

As a test, I created a new footprint from the logo, but didn't make a component. I get the same effect - it can only be moved when the top layer is turned on even though everything within the footprint is on the silkscreen layer.

 

Further, if I mirror the logo, it moves the bottom silkscreen, and can only be selected when the bottom layer is shown rather than the bottom silkscreen.

 

I'm guessing the removal of the origin layer required some assumptions about which layer the component or footprint was on. In this case, that assumption is completely wrong. It also probably why I can place the logo directly on the bottom - I have to place it on the top and mirror it (which is a little annoying).

 

I suspect this probably happens with any footprint that lacks content on the top layer, like perhaps a keep out, though I'm not sure why you would make a footprint with just a keep out.

 

So, I understand what's going on now, but it's still broken IMHO.  No clue how to fix it short of brining the origin layer back, or 'putting' an origin on every layer that has content (which seems like the most reasonable fix for someone with no knowledge of the code base, design, or architecture of the application ;)).

 

Hope this helps!

 

-Tom

 

 

 

 

 

Message 7 of 11
jorge_garcia2
in reply to: crgmakes

Hi @crgmakes,

 

The developers are looking into this. We agree it's a problem so we are looking into a fix for it. Hope to have some news soon.

 

Let me know if there's anything else i can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 8 of 11
panpan_fan
in reply to: crgmakes

Hi @crgmakes 

As @jorge_garcia2  says, the Origin issue is reported to the develop team.

For issue 2, I want to do some explanation. All new files including 2d PCB and libraries, they should all use Boardoutline as layer 20 name. You can create a new library to check. If you see some libraries uses old layer name, it should be created in old build. We don't want to change user's old files. So all old files will use old layer names.

BoardOutline.PNG

For issue 4, double click to opening details is on our to do list. I will keep you updated when we release the fixing for this issue.

Regards,

Panpan Fan

Message 9 of 11
crgmakes
in reply to: jorge_garcia2

Thanks - sounds good!
Message 10 of 11
crgmakes
in reply to: panpan_fan

@panpan_fan I understand the new layer setup, and I saw the notification of the layer name changes.

 

What was not even remotely apparent to me after reading the notification was the implications to the older libraries.  I just went back and re-read the notification and literally the only layer with a consequential name change is Layer 20. I simply missed that when I read the note and certainly didn't understand the importance of the change in the real work vs semantically.

 

Fundamentally, any old library with components items on the "Dimension" layer, which is layer 20, will now show up on the BoardOutline layer - that's really, really suboptimal - so much so I think it's a defect.

 

Secondarily, and what is happening to me is, I create a *new* part in my existing ("old") libraries and I get the old names in the foot print editor, but the new names in the PCB editor (since the PCB is new). 

 

Either give me the new names for any new part regardless of library "age", or give me the ability to "migrate" the old library into the new format without having edit every part that is affected. I'm a one man shop and I have something like 20 libraries with 100's of parts -- maybe even 1000's. I can't imagine what a large team would face.

 

I am quite certain a year some now I will forget all this layer 20 business, I will make a new part in my highly curated library, blindly trust the name in the footprint editor, and get bitten again. I will smack my head on the monitor and fix the footprint, wasting time and energy and frustrating a user and a customer.

 

See the issue?

 

-Tom

 

 

 

 

Message 11 of 11
panpan_fan
in reply to: crgmakes

Hi @crgmakes 

Sorry to hear that it causes confusion to you.

The old layer 20 dimension and the new layer 20 Boardoutline works in the same way.

Only the layer name is different. The function is same.

I will bring this issue to the develop team.

I will keep you updated if I get more information.
Regards,

Panpan Fan

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums