Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

BUG: CANVAS only PUSHED/RENDERED correctly for "v1" (first Fusion360 PUSH from Eagle). CANVAS disappears from "v2"...

3 REPLIES 3
Reply
Message 1 of 4
javier.rodas
150 Views, 3 Replies

BUG: CANVAS only PUSHED/RENDERED correctly for "v1" (first Fusion360 PUSH from Eagle). CANVAS disappears from "v2"...

Affecting the current Eagle Premium 9.6.2 and Fusion 360 2.0.8816, macOS.

 

This bug was reported several times in the forums, and it's still present.

 

STEPS TO REPRODUCE THE BUG:

  1. EAGLE: Create a simple project with one Würth Elektronik component (managed library already available in Eagle, with 3D packages associated).
  2. EAGLE: Press "FUSION 360" panel => "Create new Fusion 360 design" => New "v1" is created and available at Cloud.
  3. FUSION360: Open "v1" => Navigate to RENDER section => Press "In-Canvas Render" play button... => EXPECTED RENDERING RESULTS: Both the PCB + Canvas (copper, soldermask and silkscreen) are RENDERED CORRECTLY.
  4. FUSION360: Close "v1".
  5. EAGLE: Without changing anything on the PCB, press again "FUSION 360" panel => "Push to Fusion..." => New "v2" is created and available at Cloud.
  6. FUSION360: Open "v2" => Navigate to RENDER section => Press "In-Canvas Render" play button... => WRONG RENDERING RESULTS: Only PCB is rendered, the Canvas (copper, soldermask and silkscreen) are not rendered!.

So, the CANVAS is only rendered in "v1" of each 3D project exported from Eagle to Fusion360.

 

I have attached the Eagle sample project and the respective Fusion360 "v1" and "v2" .f3d files, which SHOULD BE EQUAL, as we haven't made any changes in the PCB in Eagle between both versions, just launched a SECOND PUSH to Fusion360:

 

Can anyone explain this behaviour?.

Is there any workaround to RECOVER the "v2" (and successive versions) in order to make the CANVAS being rendered again?.

3 REPLIES 3
Message 2 of 4
javier.rodas
in reply to: javier.rodas

I see that after the first "Create new Fusion 360 design" from Eagle to Fusion360 the following line is added to the Eagle BRD file:

<fusionsync huburn="a.cGVyc29u................" projecturn="a.cGVyc29uYWw6dWUyZGI0Yj..........................." f3durn="urn:adsk.wipprod:dm.lineage:rTCpMzxOS76-.........." pcbguid="3dd86082-2be8-4c97-bd46-............" lastpulledtime="" lastsyncedchangeguid="" latestrevisionid="bbf7ece8-a860-4579-8562-............" lastsyncedrevisionid="bbf7ece8-a860-4579-8562-............" lastboardhashguid="75da4b9f-ef6c-050a-586e-............" lastpushedtime="2020-09-05T01:17:02Z" linktopcb3d="true"/>

The .b#1 and .brd (from "v1" and "v2") are only different at that line. Just to show that there were NOT any other changes applied to the PCB in Eagle.

Maybe this information is useful to track the BUG, or maybe not...

Message 3 of 4
panpan_fan
in reply to: javier.rodas

Hi @javier.rodas 

I hope you are doing well!

Thanks for your detailed steps. And I can reproduce this issue. I have reported this ticket  to our develop team. And we will try to find the root cause as soon as possible.

 Sorry for the inconvenience. 

 

Regards,

Panpan Fan

Message 4 of 4
panpan_fan
in reply to: javier.rodas

Hi @javier.rodas 

Today we release Fusion 360 V2.0.9142 and this issue should have been fixed.

You can update Fusion and have a try.

If you still have any problem, please let us know, thanks!

 

Regards,

Panpan Fan

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report