Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

App constantly crashes when using libraries "Operation Not Permitted" error

1 REPLY 1
Reply
Message 1 of 2
sebastienSQA5P
241 Views, 1 Reply

App constantly crashes when using libraries "Operation Not Permitted" error

I had a board use a local parts library I downloaded from a vendor as well as my own parts library within Fusion (I know, terrible I used my own harddrive, I should have just used everything-in-the-cloud right?).  No issues in the past using either library separately or together.


Opened up an old (3 month old?) project to change a single footprint of a LED chip to send to the manufacturer. A task which should take 30 seconds right? Well, colour me frustrated - I started this 30 second task at 8:30pm. It's now 11:30pm as I write this.  

 

Every. Time. I. Opened. The. Library. Manager. Autodesk would crash.  I would receive the informative "Operation Not Permitted" error message (screenshot).  Every. Time. I. Tried. To. Add-Part. Autodesk would crash.  I don't know how many crash reports I sent before I just gave up.

The file exists and the permissions are correct, see terminal output of PWD and LS in screenshot.


So not knowing if this is relevant, but I recently updated OSX to Catalina which includes a new file permission handling service, perhaps Autodesk isn't compatible with this? Other apps have "asked permission" to access my folders, Fusion did not.  Nonetheless, I granted Fusion permission (screenshot) manually in OSX System Preferences and this didn't fix the issue.

I even tried a New Electronics Design project, with nothing in it, and tried to open Library Manager - which resulted in the same crash.


The only way I was able to resolve this issue was doing a clean delete (so everything in ~/Library related to Autodesk and Fusion too) and re-install.

Posting this here in the hopes that if someone else experiences the same problem, then my advice to them is to uninstall Autodesk - and get rid of every Autodesk and fusion related folder in ~/Library (you will lose your preferences, which oddly are not stored in the cloud) and once you've uninstalled fusion, install Altium re-install fusion from scratch and your library manager will work again. 

3 hours to change the footprint of a F^&king LED.

1 REPLY 1
Message 2 of 2

I had a similar issue, but luckily it can be fixed without having to reinstall Fusion.

 

The "Operation Not Permitted" error and subsequent crash can be fixed by removing the reference to the parts library in ~/Library/Application Support/Autodesk/Autodesk Fusion 360/Electron/lbr/libraries.rc.

After removing the entries that start with "Lbr.Local" the Library Manager will open again without crashing.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums