Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Another Fusion 360 wasted day -- Library related

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
clark.emerick
259 Views, 5 Replies

Another Fusion 360 wasted day -- Library related

Stuck in the 360 hell scape trying to add a 20 pin dip for a Pic Micro. Can create a new device, footprint and 3d model. Created the symbol several times but the device/symbol/footprint never are associated together event though package is associated with new device. In library manager the symbol does not appear and I cant find a way to associate a symbol and device or footprint. Totally frustrated after trying so many options.  At the point it makes me sick to my stomach trying to accomplish anything worthwhile, just watching my days get burned up fighting broken processes. Maybe someday parts of it will be usable but for now as a consultant, it has been a huge waste of my time with no return in sight.

5 REPLIES 5
Message 2 of 6

Here is the status with the library from my perspective:

1. Technically, you can make parts and organize them successfully.
2. It is 2 million miles [3,218,688 km] from being intuitive.
3. It is very unforgiving of skipping a step or misunderstanding a step

My success ONLY came after putting in a considerable efforts OUTSIDE of a real project. I  made very simple [fake] parts like resistors and capacitors to help me experiment my way through the process a number of times. I focused on attributes, technologies, copying parts to other libraries, organizing libraries, and dealing with complex footprints.

I maintain that it is FAR harder than it should be but at the end - I make parts and the parts work perfectly. I have an organization scheme that is quite easy to deal with. Getting to that point required copious quantities of curse words.

I wish I had time in my schedule to make some short videos with my various tips and tricks.

Carlos Acosta
Factory400 - YouTube|Instagram
Message 3 of 6

Thanks for the reply. I spent the weekend doing something pretty close to what you outlined.

The main trick (not totally) was always using a copy of a current part.
Not always possible when you are working with custom devices.
I could make all of those work ok but never succeeded in making a new device from scratch.
Must be magic steps far outside my ability to intuit the missing pieces.
 
At least it is good to know I am not alone in the struggle. 
But time is not on my side in terms of getting work done on designs.
Unfortunately I don't get paid for trying, only for delivery of results.
 
Appreciate any help you can provide but I know most people have their own deadlines etc.
 
Message 4 of 6

Hi @clark.emerick ,

 

I'm actually working on this type of content right now. Hope to have it done by the end of the week. In the meantime this video might help

https://www.youtube.com/watch?v=fOzvXkk8x_s&list=PL1rOC5j_Fyi50V42nWPXNIBRQJwHf62Xw&index=3

The gui is from EAGLE but the fundamental steps are the same.

 

Let me know if you continue to run into problems.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 5 of 6

Thank you for the info.

It had the one missing step that was required to make a new device.

I could never see a way to add a new symbol for a new device.

From the video I saw the button was called add part so it never occurred to me it might let me add a symbol.

So once I saw that I was able to make a new part quickly plus fix devices that had missing symbols from previous library sync problems.   

 

Thanks again for the help.

Message 6 of 6
wwfeldman
in reply to: clark.emerick

first, i just watched the five videos, library overview, making a symbol, making a footprint, making a 3d package, making a device referenced in Fusion 360 Library Editor Frequently Asked Questions. fairly helpful, and relatively easy to follow, as the GUI in the tutorials was the same as the GUI i have.

 

second, the add part icon at top needs to be renamed as add symbol (as noted in a previous posting), and it needs its siblings, add footprint, add 3d package to be next to it, rather than "New" at the bottom and  ??? to add a 3D package.

 

also, how about "add new symbol to existing library" instead of always creating a new library?

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report