Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

activating command mode through keyboard

15 REPLIES 15
Reply
Message 1 of 16
djon_3V3
493 Views, 15 Replies

activating command mode through keyboard

Hi there,

 

All attempts failed. On macOS, French keyboard, "slash" key does not activate the commandline mode. This is one of the most used mechanism to switch between functions in the user interface and not having it forces me to have to click everywhere, which is a huge loss of (my precious) time.

 

Labels (1)
15 REPLIES 15
Message 2 of 16
Cocoader
in reply to: djon_3V3

Same for the german keyboard. Please fix this.

Message 3 of 16
panpan_fan
in reply to: Cocoader

Hi @Cocoader  @djon_3V3 

I hope you are doing well!

Thanks for reporting this issue to us.

I test the 'slash' and here is my conclusion:

Case 1: If you only open one schematic(Or one 2d PCB file) -> Then you Press Slash to activate command line -> It works well.

Case 2: If you open 2 schematic files (Or two 2d PCB files) -> Then you switch between two schematic files (Or two 2d PCB files) -> Then the Slash can't work well.

 

For Case 2, I have reported this issue to our develop team to track this issue.

Workaround for case 2: When you find that the Slash can't work. You can just click on the schematic or 2d PCB to activate the file, then you Press Slash. It will work.

 

Can you confirm if you meet this issue with two schematic files open? If you meet this issue in different scenarios, please leave your comment. 

 

Regards,

Panpan Fan

 

Message 4 of 16
djon_3V3
in reply to: panpan_fan

Hi there.

 

Thanks for your extensive testing.

I did check your two solutions but unfortunately none works. 

I made an unlisted screencast that i can pm you. (if that is even possible)

Message 5 of 16
panpan_fan
in reply to: djon_3V3

Hi @djon_3V3 

I hope you are doing well!

I just record a video to show what I have seen during my testing.

https://autode.sk/2FeyTzw

The Slash works well when I just open one schematic and one 2d CPB file.

Then I create a new schematic and back to the original schematic, then the slash can't work well.

But If I click on the canvas at any position to activate the original, the Slash will work again.

If you think something is different with your steps, please leave your comment. Thanks!

 

Regards,

Panpan Fan

Message 6 of 16
djon_3V3
in reply to: panpan_fan

Errr. So this is weird and definitively an i18n problem. Not sure its is due to macos/fusion/some api somewhere but at least screencast is quite not getting the right key strokes. Not sure if the key strokes are sent by fusion to screencast or if screencast is intercepting them but be sure i can still correctly type on my keyboard.

Please check the video below.

 

 
Message 7 of 16
panpan_fan
in reply to: djon_3V3

Hi @djon_3V3 

I hope you are doing well! Sorry that I misunderstand your issue here.

I changed the Language in Fusion 360 performance but I didn't change the keyboard.

I test with French Keyboard and other non-English keyboard. It seems that Fusion 360 can't support the Slash in all non-English Keyboards.

My suggestion is that you can add the English Keyboard and use the Ctrl+Space to Switch to English Keyboard when you want to activate command line.

Screen Shot 2020-09-08 at 3.04.43 PM.png

Sorry for the inconvenience.

 

Regards,

Panpan Fan

Message 8 of 16
djon_3V3
in reply to: panpan_fan

Hi there.

 

Thanks for checking again.

That is an issue i knew from experience, when managing keyboard from the "mechanical" point of view instead of the logical one. Mechanical only works when you stay within your own locale, but does not adapt to I18N.

 

Now that the issue is understood, i hope we'll have a fix soon, so that we can work at full speed. Again, from experience, this is no big issue so i am pretty confident someone can manage to correct rapidly.

Message 9 of 16
panpan_fan
in reply to: djon_3V3

Hi @djon_3V3 

Thanks again!

I have logged a ticket to track this non-US keyboard issue and our developers will fix it.

I will keep you updated.

 

Regards,

Panpan Fan 

Message 10 of 16
djon_3V3
in reply to: panpan_fan

Hi.

 

Any news on this? 

 

Thanks.

Message 11 of 16
panpan_fan
in reply to: djon_3V3

Hi @djon_3V3 

Sorry that this ticket is not fixed yet.

By the way, I am not sure if you try to check the 'Legacy Command Line Focus' box to see if it can make it easier for you to type commands. Please have a try, thanks!

Screen Shot 2021-02-10 at 10.51.29 AM.png

 

Regards,

Panpan Fan

Message 12 of 16
aabmar
in reply to: djon_3V3

Hi,

 

This seems to not be fixed. Now that Eagle is going to die this HAS TO be fixed! I'm using a Norwegian keyboard and NO keyboard shortcuts work. / does not activate the command line (in any state). The user defined key shortcuts do never trigger.

 

We have discussed this in the "Eagle is dying" thread, but no change.

 

Can you please fix this? Eagle is not a productive tool to use without keyboard.

Message 13 of 16
djon_3V3
in reply to: djon_3V3

Sure, still not fixed.

Autodesk is way too fixated on adding new features and does not spend enough time on correcting all the quirks that make our life more and more miserable, bit by bit. 

Message 14 of 16
jorge_garcia2
in reply to: djon_3V3

Hi @aabmar,

 

I hope you're doing well. I reported the issue you are having with your keyboard layout. From what I have seen this seems to be a limitation of Fusion itself. For now the only workaround is to use a US layout while we get this sorted.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 15 of 16
djon_3V3
in reply to: djon_3V3

Hi Jorge.

 

Thanks for coming in. 

As you might have heard a thousand times, this is an over three year old report with no fix. Almost day to day.

@aabmar would have been slapped for reviving a dead thread, if we were on stack overflow. This thread is slap old.

 

So no, switching keyboard layout is a nightmare i do not want to go through. Nor much would, imho.

Having a physical layout different from logical layout just corrupts brains. I give that as a fact. This ain't no fix for the problem, have some mercy.

 

Message 16 of 16
jorge_garcia2
in reply to: djon_3V3

Hi @djon_3V3,

 

I hope you're doing well. The issue has been reported and the developers are looking into it. That's as much as I can do.

 

I totally understand that changing the layout is an extreme measure and not a long term solution.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report