Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

3D PCB Generating with Circular Dependencies

56 REPLIES 56
SOLVED
Reply
Message 1 of 57
crefvem
2841 Views, 56 Replies

3D PCB Generating with Circular Dependencies

I am working on a project with a schematic file, board file, and 3D PCB. After I make certain changes (of which I am not sure) the link between the board and the 3D PCB becomes irrevocably corrupted.

 

I get an error the following error:

Error: Circular dependency found: from Packages:1 to PCBHole4.
First feature in timeline: Packages:1
Last feature in timeline: PCBHole4
Total 5 features

 

I am unable to delete the 3D PCB and receive the following dialog when I try to: "A version of this design has been referenced by drawings, other designs, or manufacturing-related files and cannot be deleted." Is it possible to un-associate the 3D PCB from the electronics design?

 

I have hit this problem twice now, first occurring last week. The only workaround I came up with was to duplicate the schematic and board files, re-associate them in a new electronics design, and then regenerate the 3D PCB. Clearly there is nothing wrong in the board file because after duplication the 3D PCB generates without issue. I find this solution to be unacceptable because I lose my entire revision history when I duplicate the files.

 

Here are a few more details that may be pertinent:

  • At all times I have the electronics design, the schematic, the board, and the 3D PCB all open concurrently.
  • I have not made any changes to the design from the 3D PCB. All changes have been made in the board file.
  • When this circular dependency issue presented itself the 3D PCB was included in an assembly. Deleting it from the assembly has no effect on the error.

 

I would very much appreciate a solution to this so that I don't have to duplicate my files again losing my full revision history. Please let me know if there is any other information that may be helpful in debugging this issue further.

Tags (1)
Labels (1)
56 REPLIES 56
Message 2 of 57
yiqiu.han
in reply to: crefvem

Hi, @crefvem 

 

Thanks for sharing detail information to us!

This is an issue that caused by adding single instance/multiple instances/deleting random instances in 3D package and then view in 3D. We have resolved this problem and fix will be delivered in next release, which will be delivered to public in a few days. Would you please have a try after new version of Fusion is adopted?

The current workaround for this problem is break link of 3D PCB from 2D PCB link and then regenerate 3D PCB.

The problem about unable to delete 3D PCB is a bit complex, Developers are currently working on this. The problem is to there are many links to build a 3D image and make it functional. In order to protect the linked data, at times the application will not allow you to delete it. For now, we have been suggesting to our users to create a project folder called Trash and move the 3D images you wish to disregard in there. 

 

Hope that helps,

-Yiqiu

Message 3 of 57
tschneemann
in reply to: yiqiu.han

Hello, I came across the same issue. Is this a newly appearing/introduced bug? Because before yesterday it worked flawlessly. I ask because ... what I should do next... wait for the f360 update, or did I do something unintentionally in the 2D PCB or in the 3D PCB which triggered this (?).

 

Could you advice what I should do, I could go back to the older files and continue from there. But there has been many updates, so a different route would be highly appreciated.

 

Context:

For me it happens when doing the /Edit Board/ command. There is no problem with >2 days versions of the 3D PCB file. These can /Edit Board/ update either from the derived sketch or from the 2D PCB outline without a hitch.

 

To make a new 3DPCB file works when doing the initial creation, but later updates fail with the circular dependency error message. In my case it gets hung at 2 Resistors (?). I had always only moved components in the 2D PCB file.

 

Because of the above my wild guess is that this bug originates in the 2DPCB and gets pushed into the 3DPCB(?).

 

I tried a fix by deleting the two resistors from the schematics, then updating the 2D, then to the 3D, but then error messages for PCBHole1/2/... came up.

 

General info regarding the set up:

One file/design where the derived sketch is in, the 3DPCB file/design through /Derive PCB from Sketch/ which is linked to the 2D PCB of an Electronics Design), one assembly file/design (to insert the file/design with the derived sketch and the 3D PCB into).

 

Side info/context: I first ran into this when doing -get latest- and -edit board- command to get the latest sketch into the 3DPCB. I added rounded corners to the outline sketch in the file/design with the outline sketch is in, which messed up the projected geometries in the sketch which was used for the /Derive PCB from sketch/ for the 3DPCB.

 

At first I suspected that this had caused the circular dependency issue, but it remained after fixing the derived sketch. (or did I not fix it, also possible. I deleted all projected geometries and re-project. But these projected geometries can in rare instances, e.g. from slot-type cutouts, loose their projection when the cut out is moved and then the projected lines from this cutout just 'fly' around somewhere on the sketch, are still pink, but e.g. one arc became bigger and/or the lines are no longer connected). So I thought, something similar may have happened with the projected rounded corners here too. I don't know for sure, gosh it is all quite complex 🙂 .

 

Thank you and happy Easter Greetings,

TS

 

Screenshot 2021-04-07 160909.png

 

 

 

Message 4 of 57
yiqiu.han
in reply to: tschneemann

Hi, @tschneemann 

 

Thanks for sharing detailed information with us too.

The cylinder dependency exposes to us during EIP, but the data is corrupted during previous operations so that it looks difficult to dig out the root cause of the problem. This doesn't mean you are operating wrongly.

The suggested way to fix corrupted data is by breaking 3D PCB link and then generate a new one with the latest or newer releases(April release is 2.0.10027).

If you could see cylinder dependency error after regeneration of 3D PCB, please let us know😃

 

Thanks,

Yiqiu

Tags (1)
Message 5 of 57
john.baillieMKKGY
in reply to: crefvem

Hello,
I have had the same issue.
Even promoting versions from yesterday or a week ago that were fine produced the problem.
I have made a new electronics design and it seems to be OK.

Message 6 of 57
john.baillieMKKGY
in reply to: crefvem

I broke PCB link, made new electronics design, succesfully made a few versions but now the problem has come back... don't really feel like it's reasonable to have to create a new electronics design every save. 
Is this a bug or must I dig into my history?

Message 7 of 57

Hi, @john.baillieMKKGY 

Sorry to hear about that, Could you please double-check the version of Fusion that is used to generate a new one? 

BTW your data and steps would be very useful for our investigation. I have shared my contact information from private message and hope you could take a look.

 

Thanks,

-Yiqiu

Message 8 of 57

I also have this problem often with various projects.

When I click 'render 3d pcb' I always have to pray it's gonna work. If the Circular Dependencies error shows up the only solution is to break the link and create a new one. The weird thing, I think, is that without changing anything Fusion has no problem creating a new 3d pcb.

 

Another side effect of this problem is that my project folder is filling op with 3d pcb's that for some reason cannot be deleted.

 

I've noticed some other bugs with Fusion only sometimes show up for people who have Windows set with a comma as decimal separator (like is common in many European countries). Since this also seems to be a bug that shows up at random I wonder if there is a relation?

 

Best regards,

Benno

Message 9 of 57
robmacklin
in reply to: crefvem

I am also getting circular reference errors, or a complete crash of Fusion when I try to generate the 3D model of my PCB.  I am running Fusion 2.0.10027.  Most of the time Fusion just crashes and exits during the generation process, but twice I saw a circular reference error.  I checked the two capacitors that were mentioned and there is nothing I can find that is wrong.  They haven't changed in a while.  

 

I am also unable to delete the 3D model.  I have invested a lot of time in the schematic and PCB layout.  Is there any way to fix the 3D model?

Message 10 of 57
AutomaticRock
in reply to: robmacklin

Hi @robmacklin ,

 

To create a new 3D model of your pcb, you first have to break the link to the current 3D PCB:

 

Clipboard01.jpg

 

Now you can just click 'View 3D PCB' again to generate a new 3D model. I think you can save it over the older version, but I've only tried this once. Just keeping the name the same will make a new model I know.

Anyway, at least you can get a new 3D model again. Only it seems a matter of random luck when the "Circular Dependencies" show up again. 🙁

Best regards,
Benno

Message 11 of 57

Hi @crefvem , et.al.,

 

Much appreciated for all your feedback and so sorry for any inconvenience.

We have identified the problem and our development team are working with a fix about this issue. We will keep you be posted once this fix is ready.

 

Currently the workaround is breaking link for the 3D PCB file and view 3D PCB file again.

So sorry for any inconvenience again.

 

Regards,

Helen 



Helen Chen
Principle QA for Fusion 360 Electronics
Message 12 of 57
cedric.duchene
in reply to: yiqiu.han

I had the same problem after an update of Fusion360 (2.0.10032, Active Plan: Fusion 360, Student
, macOS 10.15.7)

It looks like it has been solved by "breaking link of 3D PCB from 2D PCB link and then regenerate 3D PCB.

Cédric
Message 13 of 57
necoinside
in reply to: crefvem

Well, I'm here for the same problem...

I'm facing this from about a week ago.

Found solution to break 3d pcb and regenerate(as some others mentioned here) but history gets complicated and there becomes so many 3d old pcb views.. Also my pcb is in another 3d enclosure design, so I have to change 3d pcb file inside of this 3d design..

Message 14 of 57
AutomaticRock
in reply to: crefvem

Indeed @necoinside , you get many old 3D PCB views, and Fusion won't let you delete them. And also when your 3D PCB is referenced somewhere else, like an enclosure, you get even more extra work you don't need.
I really hope Autodesk will solve this problem soon...

Message 15 of 57
shaun.grahamXRLJN
in reply to: crefvem

I am also having a similar problem to most of the above.  My 2D PCB to 3D PCB link becomes corrupted somehow and come up with 13 errors about PCB hole dependencies.  Now I have tried the unlink 3D PCB and then generate a new one which does work with no changes to the 2D PCB.  I can then carry on changing the PCB and pushing it to 3D but then if I save the design and close and reopen it the link becomes broken and it comes up with all the errors about PCB holes.  Now this is weird because between saving it and reopening it there have been no changes but these errors just appear?  This only just started happening in the last couple of days so looks like it was something in the latest updates.  I have version 2.0.10032.  Autodesk you need to fix this as it is not an acceptable solution unlinking and generating a new 3D PCB every time I open the file especially because this 3D PCB is referenced in the enclosure design which means I have to redo half of that every time.

Message 16 of 57

Hello @shaun.grahamXRLJN ,

 

Sorry to hear that you're having trouble.

Our development team has made a fix and if everything goes on well it will public to users in the coming Fusion release.

We will keep you be posted.

 

Sorry for any inconvenience.

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 17 of 57

Glad to hear you have as fix for this.  Do you have an eta on this patch being rolled out?  I cant work on my project when it is in this state.

Message 18 of 57

I am facing the same problem since about a week ago: Windows, Germany. Fusion 2.0.10032


The Link between 2D PCB and 3D PCB worked well for around 50 cycles. Suddenly the "View 3D PCB" action resulted in the 3D PCB without any components and showing the "Circular dependency found" error.

I went back to an older version of the Electronics Design and the 2D - 3D link worked again. I made changes and around ten update cycles without problems. Then the error occured again. This time even the previous versions cause the error.


More details:
- I also faced the comma issue in my gerber files. To solve this i set the environment variable: FORCE_DECIMAL_GERBER_OUTPUT value set to true
- Since setting this variable i get the "error in constant" when I try to run import-bmp.ulp (this one is not solved yet)

 

Maybe all of these issues are somehow related?


I am very much looking forward to the promised fix in the coming Fusion release, as this error really keeps me from working. When is the planned release date?

Message 19 of 57
contact3K8F2
in reply to: contact3K8F2

I'd also like to add that you see on the screenshots all the blocks in the timeline that were added when clicking View 3D PCB, which caused the error. Normally when everything works only the last six steps were visible.

Message 20 of 57
yiqiu.han
in reply to: contact3K8F2

The circular dependency appears when modifying updated 3D PCB that contains device with no 3D package associated. To avoid the problem temporary is avoid updating 3D PCB contains this kind of device. I understand it's not such a  valid way for daily working...really apologize about that.

 

The delivery of fix for this issue is scheduled, We will let you know when the new version is deployed and thanks for your feedback! 

 

-Yiqiu

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums