Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

3D Packages are being left out randomly

13 REPLIES 13
Reply
Message 1 of 14
ESCAPEKIT
357 Views, 13 Replies

3D Packages are being left out randomly

I've made a full schematic for a PCB I am working on. I've made it in Fusion because I'll need a custom 3D printed enclosure and I thought it would be easier to make everything in Fusion. Hahaha BIG mistake!
After finishing the schematic I created the 2D pcb and placed most of the components where I think they should be. Then I decided to create the 3D PCB (by clicking on "view 3D pcb" while on the 2D PCB.
Well most packages loaded right and a few others did not. I tried deleting and replacing the components with the missing packages. It did not work. 
I decided to close the 3D PCB without saving and create it again. Now a completely different set of Packages are missing. They are all packages that I created in Fusion (mostly connectors and buttons) and added to a package created with "create package from footprint".
You can do this several times (closing without saving and creating again) and each time a different random set of packages will be missing. I just can't begin to express how frustrating this is and how disappointed in Autodesk I am. 
I am so disappointed I don't even want to try the new slicing part of Fusion. A month ago I would have been thrilled to know Fusion could do slicing. Now I just assume it will be a disaster, so why bother.
You can see a few screen captures of the random missing components down below:
packages.jpg

 

packages2.jpg

 

packages3.jpg

 

packages4.jpg

 
I hope you learnt that launching a product with this MANY bugs is a very, very, VERY bad idea. 
I have lost countless hours trying to make this disaster work. 
I love my work and I love designing PCB's but really, you've managed to make me feel like I never want to design another one. That's how frustrated I am with Fusion Electronics. And I still have to finish this one! ::facepalm

13 REPLIES 13
Message 2 of 14
ESCAPEKIT
in reply to: ESCAPEKIT

Well just after posting I had an idea and I thought "what the hell, let's try it" Even though its 01:30AM here. 
I discovered a way to get back all the missing packages. It is slow, it is painful, it is boring and it is the least efficient thing I can fathom, but it seems to work, at least for now, we'll see what I find tomorrow.
To get the Packages on the 3D PCB I went to the schematic, deleted one component with the missing package, pushed to 2D PCB, pushed to 3D PCB and waited for the footprint of the component to disappear. Went back to schematic, added the component again in the same place, Pushed to 2d PCB, moved the component where it should be, pushed to 3D PCB and surprise surprise it was there. Then repeat all this process for the rest of the components with missing packages, all in all abut 20 minutes lost.
Packages_painfully_fixed.jpg

 

Now lets save and get mentally prepared to find everything lost when I turn on the computer tomorrow.
Good night. I hope I don't have Fusion360 nightmares. (Spoiler, I will).

Message 3 of 14
dieter.menne
in reply to: ESCAPEKIT

You are not alone. 

https://forums.autodesk.com/t5/fusion-360-electronics/inconsistent-display-of-packages-with-without-...

 

and others, but considered often as a relatively minor issue compare to the shifting of components and dependency nightmares. Don't try to find workarounds, all only works occasionally or even only on the first try.

 

Autodesk has acknowledged several times that this is an issue. The only thing you can do is wait until you get a green "new version" when you switch on in the morning.

Message 4 of 14
ESCAPEKIT
in reply to: dieter.menne

I know Dieter, I've been following the forum closely the last couple of weeks.
I think if we all give feedback and explain our cases in a detailed way it will be easier for them to find the cause and fix it. I just woke up and I am really afraid to open Fusion in case it is all messed up 😞

Message 5 of 14
ESCAPEKIT
in reply to: ESCAPEKIT

Of course, when opening Fusion there was an error message saying the.sch could not be read. The schematic was ALL lost. Luckily I saved 3 consecutive times on purpose yesterday (changing only meaningless things to get it to let me save) and was able to revert to one of the previous versions.
This is like playing the russian roulette. 

Message 6 of 14
ESCAPEKIT
in reply to: ESCAPEKIT

Obviously after reverting to one of the versions saved with all the Packages fixed, now half of them are missing again. I am seriously considering going back to Eagle and just discard the last two weeks worth of work.
In a matter of weeks I've come from loving Autodesk to hating it. 😡

Message 7 of 14
jorge_garcia2
in reply to: ESCAPEKIT

Hi @ESCAPEKIT,

I hope you're all doing well. This has happened to me and we are looking for the solution as fast as we can. For now if you have business critical work, your best option is to stick to EAGLE and keep an eye on Fusion as it matures.

Let me know if there's anything else I can do for you.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 8 of 14
dieter.menne
in reply to: dieter.menne

I downloaded a new version this morning, but nothing was mentioned about changes in the electronics department. 

 

Let's be patient and give them some time to work on this. 

Message 9 of 14

Hi @ESCAPEKIT ,

 

Sorry to hear that you're having trouble.

 

Before this issue is addressed, could you please try below workaround to remove the cached files (.f3d and .txt) from the circuitslib folder and try again?

I posted the workaround in another thread too: https://forums.autodesk.com/t5/fusion-360-electronics/wrong-designation-in-3d/m-p/9378785/highlight/...

 

You could find the circuitslib folder from below path on your Windows OS:

C:\Users\#### YourOSAccount ####\AppData\Roaming\Autodesk\Autodesk Fusion 360\### YourAccount###\circuitslib

 

By the way, if your OS is Mac, you could find the circuitslib folder from:

Users/###UserName###/Library/Application Support/Autodesk/Autodesk Fusion 360/###YourAccount###/Circuitslib

 

Hope it helps.

 

Thanks,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 10 of 14

I made a few changes to the schematic and pushed to 2d, then pushed to 3d and all Packages just disappeared. There is no such directory i n my pcfolder.jpg

 

all_packages_missing.jpg

 

Message 11 of 14
ESCAPEKIT
in reply to: ESCAPEKIT

Found the folder using the search. Deleted all the .txt files and pushed to 3d again. No luck, all packages still are missing. Throwing the pc out the window is more tempting every time Fusion ****s everything up. Which is several times a day.

Message 12 of 14
ESCAPEKIT
in reply to: ESCAPEKIT

The team behind Fusion electronics should be embarrassed of themselves. This is a joke. People uses your software to make a living. You can't expect us to deal with your mess and report the trillions of bugs your code has. This has cost me a ton of hours, not a few, but a TON. Who's going to pay for this hours? I am extremely angry.

Message 13 of 14
jorge_garcia2
in reply to: ESCAPEKIT

Hi @ESCAPEKIT,

I understand your frustration, I have to face yours and every other user that has complained on these forums. I'm doing my best to get these reported up the chain and we have put some processes in place to get them resolved as soon as possible.

I know the state the tool is in right now, that's why I've urged users to stick to EAGLE for paid work and keep an eye on Fusion Electronics as it matures. This is a high priority issue and I've brought this thread and others up to management. If you need help getting these files into EAGLE, I'll do my best to help you.

We are working hard to get these resolved as fast as possible. I'll do whatever I can to help.

Best Regards,


Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 14 of 14

Hi @ESCAPEKIT ,

 

Hope all is well.

 

We have made a fix in the latest Fusion 360 which is released today.

Could you please upgrade to latest version 2.0.8111 to have a try? Hope it helps.

 

So sorry for any inconvenience.

Regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report